~ubuntu-branches/ubuntu/lucid/konversation/lucid-updates

« back to all changes in this revision

Viewing changes to debian/patches/kubuntu/0001-Adds-support-for-Message-Indicator.diff

  • Committer: Package Import Robot
  • Author(s): Jonathan Riddell
  • Date: 2014-11-04 17:40:19 UTC
  • mfrom: (2.4.4 experimental)
  • Revision ID: package-import@ubuntu.com-20141104174019-djxmmslchwd6uowc
Tags: 1.2.3-1ubuntu2.1
* SECURITY UPDATE: out-of-bounds read on a heap-allocated array LP: #1389296
  - Add kubuntu_02_cve-2014-8483.diff to verify read bounds
  - CVE-2014-8483
  - https://www.kde.org/info/security/advisory-20140923-1.txt

Show diffs side-by-side

added added

removed removed

Lines of Context:
15
15
 8 files changed, 259 insertions(+), 3 deletions(-)
16
16
 create mode 100644 src/config/messageindicator_config.ui
17
17
 
18
 
Index: konversation-1.2.2/CMakeLists.txt
 
18
Index: konversation-1.2.3/CMakeLists.txt
19
19
===================================================================
20
 
--- konversation-1.2.2.orig/CMakeLists.txt      2010-02-11 12:59:25.000000000 -0500
21
 
+++ konversation-1.2.2/CMakeLists.txt   2010-02-11 14:53:29.109599658 -0500
22
 
@@ -8,6 +8,7 @@
 
20
--- konversation-1.2.3.orig/CMakeLists.txt
 
21
+++ konversation-1.2.3/CMakeLists.txt
 
22
@@ -8,6 +8,7 @@ set(KDE_MIN_VERSION "4.00.82")
23
23
 #atm this gets us FindQt4 and FindX11 (provided that the default cmake FindQt4 doesn't get used)
24
24
 find_package(KDE4 REQUIRED)
25
25
 find_package(KdepimLibs REQUIRED)
27
27
 include(KDE4Defaults)
28
28
 include(MacroLibrary)
29
29
 include(CheckIncludeFile)
30
 
@@ -37,6 +38,10 @@
 
30
@@ -37,6 +38,10 @@ macro_optional_find_package(QCA2)
31
31
 macro_bool_to_01(QCA2_FOUND HAVE_QCA2)
32
32
 macro_log_feature(QCA2_FOUND "QCA" "Qt Cryptographic Architecture" "http://delta.affinix.com/qca" FALSE "2.0.0" "Required for using encryption in IRC")
33
33
 
38
38
 #check for greater than 4.3.80
39
39
 macro_ensure_version( "4.3.80" ${KDE_VERSION} HAVEKDE4_4 )
40
40
 macro_bool_to_01(HAVEKDE4_4 HAVE_KSTATUSNOTIFIERITEM)
41
 
Index: konversation-1.2.2/config-konversation.h.cmake
 
41
Index: konversation-1.2.3/config-konversation.h.cmake
42
42
===================================================================
43
 
--- konversation-1.2.2.orig/config-konversation.h.cmake 2010-02-11 12:57:29.000000000 -0500
44
 
+++ konversation-1.2.2/config-konversation.h.cmake      2010-02-11 14:53:29.109599658 -0500
 
43
--- konversation-1.2.3.orig/config-konversation.h.cmake
 
44
+++ konversation-1.2.3/config-konversation.h.cmake
45
45
@@ -2,4 +2,5 @@
46
46
 #cmakedefine HAVE_X11 1
47
47
 #cmakedefine HAVE_XUTIL 1
50
50
\ No newline at end of file
51
51
+#cmakedefine HAVE_KSTATUSNOTIFIERITEM 1
52
52
+#cmakedefine HAVE_INDICATEQT 1
53
 
Index: konversation-1.2.2/src/CMakeLists.txt
 
53
Index: konversation-1.2.3/src/CMakeLists.txt
54
54
===================================================================
55
 
--- konversation-1.2.2.orig/src/CMakeLists.txt  2010-02-11 12:57:29.000000000 -0500
56
 
+++ konversation-1.2.2/src/CMakeLists.txt       2010-02-11 14:53:29.113601913 -0500
57
 
@@ -126,6 +126,7 @@
 
55
--- konversation-1.2.3.orig/src/CMakeLists.txt
 
56
+++ konversation-1.2.3/src/CMakeLists.txt
 
57
@@ -126,6 +126,7 @@ kde4_add_ui_files(config_SRCS
58
58
     config/theme_configui.ui
59
59
     config/warnings_configui.ui
60
60
     config/watchednicknames_configui.ui
62
62
 )
63
63
 
64
64
     #=== Viewer
65
 
@@ -198,6 +199,11 @@
 
65
@@ -198,6 +199,11 @@ if (QCA2_FOUND)
66
66
         cipher.cpp)
67
67
 endif (QCA2_FOUND)
68
68
 
74
74
 set(upnp_SRCS
75
75
     upnp/soap.cpp
76
76
     upnp/upnpdescriptionparser.cpp
77
 
@@ -230,7 +236,8 @@
 
77
@@ -230,7 +236,8 @@ kde4_add_executable(konversation ${konve
78
78
 
79
79
 target_link_libraries(konversation ${KDE4_KIO_LIBS} ${KDE4_KUTILS_LIBS} ${KDE4_KPARTS_LIBS}
80
80
                             ${KDE4_KDE3SUPPORT_LIBS} ${KDE4_KABC_LIBS}
84
84
 
85
85
 if (X11_FOUND AND X11_Xutil_FOUND)
86
86
     target_link_libraries(konversation ${X11_X11_LIB})
87
 
Index: konversation-1.2.2/src/config/konversation.kcfg
 
87
Index: konversation-1.2.3/src/config/konversation.kcfg
88
88
===================================================================
89
 
--- konversation-1.2.2.orig/src/config/konversation.kcfg        2010-02-11 12:57:29.000000000 -0500
90
 
+++ konversation-1.2.2/src/config/konversation.kcfg     2010-02-11 14:53:29.113601913 -0500
 
89
--- konversation-1.2.3.orig/src/config/konversation.kcfg
 
90
+++ konversation-1.2.3/src/config/konversation.kcfg
91
91
@@ -518,6 +518,23 @@
92
92
       <whatsthis></whatsthis>
93
93
     </entry>
112
112
   <group name="Notify List">
113
113
     <entry key="NotifyDelay" type="Int">
114
114
       <default>20</default>
115
 
Index: konversation-1.2.2/src/config/messageindicator_config.ui
 
115
Index: konversation-1.2.3/src/config/messageindicator_config.ui
116
116
===================================================================
117
 
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
118
 
+++ konversation-1.2.2/src/config/messageindicator_config.ui    2010-02-11 14:53:29.113601913 -0500
 
117
--- /dev/null
 
118
+++ konversation-1.2.3/src/config/messageindicator_config.ui
119
119
@@ -0,0 +1,69 @@
120
120
+<?xml version="1.0" encoding="UTF-8"?>
121
121
+<ui version="4.0">
186
186
+ <resources/>
187
187
+ <connections/>
188
188
+</ui>
189
 
Index: konversation-1.2.2/src/config/settingsdialog.cpp
 
189
Index: konversation-1.2.3/src/config/settingsdialog.cpp
190
190
===================================================================
191
 
--- konversation-1.2.2.orig/src/config/settingsdialog.cpp       2010-02-11 12:57:29.000000000 -0500
192
 
+++ konversation-1.2.2/src/config/settingsdialog.cpp    2010-02-11 14:53:29.117600745 -0500
 
191
--- konversation-1.2.3.orig/src/config/settingsdialog.cpp
 
192
+++ konversation-1.2.3/src/config/settingsdialog.cpp
193
193
@@ -10,6 +10,7 @@
194
194
   Copyright (C) 2006 Eike Hein <hein@kde.org>
195
195
 */
209
209
 
210
210
 KonviSettingsDialog::KonviSettingsDialog( QWidget *parent) :
211
211
     KonviConfigDialog( parent, "settings", Preferences::self(), KPageDialog::Tree)
212
 
@@ -176,6 +181,14 @@
 
212
@@ -176,6 +181,14 @@ KonviSettingsDialog::KonviSettingsDialog
213
213
   //no modified connection needed - it's all kcfg widgets
214
214
   m_pages.append(m_confOSDWdg);
215
215
 
224
224
   //Notification/Warning Dialogs
225
225
   m_confWarningsWdg = new Warnings_Config( this, "Warnings" );
226
226
   addPage ( m_confWarningsWdg, notificationGroup, "dialog-warning", i18n("Warning Dialogs") );
227
 
Index: konversation-1.2.2/src/notificationhandler.cpp
 
227
Index: konversation-1.2.3/src/notificationhandler.cpp
228
228
===================================================================
229
 
--- konversation-1.2.2.orig/src/notificationhandler.cpp 2010-02-11 12:57:29.000000000 -0500
230
 
+++ konversation-1.2.2/src/notificationhandler.cpp      2010-02-11 14:53:29.117600745 -0500
 
229
--- konversation-1.2.3.orig/src/notificationhandler.cpp
 
230
+++ konversation-1.2.3/src/notificationhandler.cpp
231
231
@@ -18,11 +18,27 @@
232
232
 #include "viewcontainer.h"
233
233
 #include "trayicon.h"
256
256
 
257
257
 namespace Konversation
258
258
 {
259
 
@@ -31,6 +47,23 @@
 
259
@@ -31,6 +47,23 @@ namespace Konversation
260
260
         : QObject(parent)
261
261
     {
262
262
         m_mainWindow = parent->getMainWindow();
280
280
     }
281
281
 
282
282
     NotificationHandler::~NotificationHandler()
283
 
@@ -48,6 +81,9 @@
 
283
@@ -48,6 +81,9 @@ namespace Konversation
284
284
         if (!chatWin || !chatWin->notificationsEnabled())
285
285
             return;
286
286
 
290
290
         if (Preferences::self()->disableNotifyWhileAway() && chatWin->getServer() && chatWin->getServer()->isAway())
291
291
             return;
292
292
 
293
 
@@ -76,6 +112,9 @@
 
293
@@ -76,6 +112,9 @@ namespace Konversation
294
294
         if (!chatWin || !chatWin->notificationsEnabled())
295
295
             return;
296
296
 
300
300
         if (Preferences::self()->disableNotifyWhileAway() && chatWin->getServer() && chatWin->getServer()->isAway())
301
301
             return;
302
302
 
303
 
@@ -102,6 +141,9 @@
 
303
@@ -102,6 +141,9 @@ namespace Konversation
304
304
         if (!chatWin || !chatWin->notificationsEnabled())
305
305
             return;
306
306
 
310
310
         if (Preferences::self()->disableNotifyWhileAway() && chatWin->getServer() && chatWin->getServer()->isAway())
311
311
             return;
312
312
 
313
 
@@ -378,6 +420,90 @@
 
313
@@ -378,6 +420,90 @@ namespace Konversation
314
314
         return cutup;
315
315
     }
316
316
 
401
401
 }
402
402
 
403
403
 #include "notificationhandler.moc"
404
 
Index: konversation-1.2.2/src/notificationhandler.h
 
404
Index: konversation-1.2.3/src/notificationhandler.h
405
405
===================================================================
406
 
--- konversation-1.2.2.orig/src/notificationhandler.h   2010-02-11 12:57:29.000000000 -0500
407
 
+++ konversation-1.2.2/src/notificationhandler.h        2010-02-11 14:53:29.117600745 -0500
 
406
--- konversation-1.2.3.orig/src/notificationhandler.h
 
407
+++ konversation-1.2.3/src/notificationhandler.h
408
408
@@ -12,6 +12,7 @@
409
409
 #ifndef KONVERSATIONNOTIFICATIONHANDLER_H
410
410
 #define KONVERSATIONNOTIFICATIONHANDLER_H
413
413
 #include <QObject>
414
414
 
415
415
 
416
 
@@ -19,9 +20,15 @@
 
416
@@ -19,9 +20,15 @@ class ChatWindow;
417
417
 class Application;
418
418
 class MainWindow;
419
419
 
430
430
     class NotificationHandler : public QObject
431
431
     {
432
432
         Q_OBJECT
433
 
@@ -54,9 +61,20 @@
 
433
@@ -54,9 +61,20 @@ namespace Konversation
434
434
         protected:
435
435
             void startTrayNotification(ChatWindow* chatWin);
436
436
             QString addLineBreaks(const QString& string);