~ubuntu-branches/ubuntu/lucid/ladr/lucid

« back to all changes in this revision

Viewing changes to debian/patches/03-no-2.5isms.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Peter Collingbourne
  • Date: 2008-04-08 23:44:14 UTC
  • Revision ID: james.westby@ubuntu.com-20080408234414-9m92wof3zygsssn3
Tags: 0.0.200804a-1
* New upstream release.
* debian/patches/01-libtoolise.dpatch: updated for new Makefiles
* debian/patches/02-shebangs.dpatch: deleted, applied upstream
* debian/ladr4-apps.install, debian/ladr4-apps.links, debian/ladr4-apps.docs:
  added new application directproof
* debian/watch: added support for new version numbering scheme
* debian/interpformat.1, debian/prover9.1: replaced hyphens with minus
  signs
* debian/libladr4.symbols: updated
* debian/control: updated for new prover9-doc
* debian/copyright: give correct license information

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## no-python2.5isms.dpatch by  <peter@xenon.peter.uk.to>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Removes Python 2.5isms from utility scripts, namely gvizify.
 
6
 
 
7
@DPATCH@
 
8
diff -urNad ladr-0.0.200712~/utilities/gvizify ladr-0.0.200712/utilities/gvizify
 
9
--- ladr-0.0.200712~/utilities/gvizify  2008-01-24 20:57:07.000000000 +0000
 
10
+++ ladr-0.0.200712/utilities/gvizify   2008-01-24 20:58:24.000000000 +0000
 
11
@@ -208,7 +208,10 @@
 
12
   if options.multipage:
 
13
     print " page=\"%s\";" % (options.size,)
 
14
   else:
 
15
-    force="" if options.relax else "!"
 
16
+    if options.relax:
 
17
+      force=""
 
18
+    else:
 
19
+      force="!"
 
20
     print " size=\"%s%s\";" % (options.size, force)
 
21
   print " margin=\"%s\";" % (options.margin,)
 
22
   if options.command != "":