~ubuntu-branches/ubuntu/lucid/mumps/lucid

« back to all changes in this revision

Viewing changes to debian/patches/tests-shlibs.patch

  • Committer: Bazaar Package Importer
  • Author(s): Adam C. Powell, IV
  • Date: 2009-12-07 17:56:51 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20091207175651-ftogh061hebcqzty
Tags: 4.9.2.dfsg-1
* New upstream release (closes: #554159).
* Changed -lblas to -lblas-3gf in Makefile.*.inc (closes: #557699).
* Linking tests to shared instead of static libs (closes: #555759).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Have the tests link against the shared libs instead of static ones.
 
2
 
 
3
--- mumps-4.9.2.dfsg/examples/Makefile~ 2009-11-05 02:05:21.000000000 -0500
 
4
+++ mumps-4.9.2.dfsg/examples/Makefile  2009-12-07 17:54:56.000000000 -0500
 
5
@@ -19,28 +19,28 @@
 
6
 
 
7
 include $(topdir)/Makefile.inc
 
8
 
 
9
-LIBMUMPS_COMMON = $(libdir)/libmumps_common$(PLAT).a
 
10
+LIBMUMPS_COMMON = $(libdir)/libmumps_common$(PLAT).so
 
11
 
 
12
 
 
13
-LIBSMUMPS = $(libdir)/libsmumps$(PLAT).a $(LIBMUMPS_COMMON)
 
14
+LIBSMUMPS = $(libdir)/libsmumps$(PLAT).so $(LIBMUMPS_COMMON)
 
15
 
 
16
 ssimpletest:  $(LIBSMUMPS) $$@.o 
 
17
        $(FL) -o $@ $(OPTL) ssimpletest.o $(LIBSMUMPS)  $(LORDERINGS) $(LIB) $(LIBBLAS) $(LIBOTHERS)
 
18
 
 
19
 
 
20
-LIBDMUMPS = $(libdir)/libdmumps$(PLAT).a $(LIBMUMPS_COMMON)
 
21
+LIBDMUMPS = $(libdir)/libdmumps$(PLAT).so $(LIBMUMPS_COMMON)
 
22
 
 
23
 dsimpletest: $(LIBDMUMPS) $$@.o 
 
24
        $(FL) -o $@ $(OPTL) dsimpletest.o $(LIBDMUMPS)  $(LORDERINGS) $(LIB) $(LIBBLAS) $(LIBOTHERS)
 
25
 
 
26
 
 
27
-LIBCMUMPS = $(libdir)/libcmumps$(PLAT).a $(LIBMUMPS_COMMON)
 
28
+LIBCMUMPS = $(libdir)/libcmumps$(PLAT).so $(LIBMUMPS_COMMON)
 
29
 
 
30
 csimpletest: $(LIBCMUMPS) $$@.o 
 
31
        $(FL) -o $@ $(OPTL) csimpletest.o $(LIBCMUMPS)  $(LORDERINGS) $(LIB) $(LIBBLAS) $(LIBOTHERS)
 
32
 
 
33
 
 
34
-LIBZMUMPS = $(libdir)/libzmumps$(PLAT).a $(LIBMUMPS_COMMON)
 
35
+LIBZMUMPS = $(libdir)/libzmumps$(PLAT).so $(LIBMUMPS_COMMON)
 
36
 
 
37
 zsimpletest: $(LIBZMUMPS) $$@.o 
 
38
        $(FL) -o $@ $(OPTL) zsimpletest.o $(LIBZMUMPS)  $(LORDERINGS) $(LIB) $(LIBBLAS) $(LIBOTHERS)
 
39
@@ -57,19 +57,19 @@
 
40
        $(CC) $(OPTC) $(INC) -I. -I$(topdir)/include -c $*.c
 
41
 
 
42
 
 
43
-$(libdir)/libsmumps$(PLAT).a:
 
44
+$(libdir)/libsmumps$(PLAT).so:
 
45
        @echo 'Error: you should build the library' $@ 'first'
 
46
        exit -1
 
47
 
 
48
-$(libdir)/libdmumps$(PLAT).a:
 
49
+$(libdir)/libdmumps$(PLAT).so:
 
50
        @echo 'Error: you should build the library' $@ 'first'
 
51
        exit -1
 
52
 
 
53
-$(libdir)/libcmumps$(PLAT).a:
 
54
+$(libdir)/libcmumps$(PLAT).so:
 
55
        @echo 'Error: you should build the library' $@ 'first'
 
56
        exit -1
 
57
 
 
58
-$(libdir)/libzmumps$(PLAT).a:
 
59
+$(libdir)/libzmumps$(PLAT).so:
 
60
        @echo 'Error: you should build the library' $@ 'first'
 
61
        exit -1
 
62