~ubuntu-branches/ubuntu/lucid/nss/lucid-security

« back to all changes in this revision

Viewing changes to debian/patches/38_kbsd.patch

  • Committer: Package Import Robot
  • Author(s): Jamie Strandboge
  • Date: 2013-03-13 13:18:17 UTC
  • mfrom: (1.2.6)
  • Revision ID: package-import@ubuntu.com-20130313131817-nl4k88f5xjj1rkdh
Tags: 3.14.3-0ubuntu0.10.04.1
* SECURITY UPDATE: New upstream release to fix TLS timing side-channel
  attacks
  - CVE-2013-1620
* Remaining changes:
  - 98_ckbi-1.93.patch: Dropped (included upstream)
  - 01_dont_build_nspr.patch
  - 38_kbsd.patch: refresh/update
  - 80_security_build.patch
  - 85_security_load.patch
  - 97_SSL_RENEGOTIATE_TRANSITIONAL.patch
* debian/libnss3.symbols: add NSS_3.14.3 symbols

Show diffs side-by-side

added added

removed removed

Lines of Context:
4
4
## DP: GNU/kFreeBSD support. bz#356011
5
5
## DP: Added Hurd support.
6
6
 
7
 
Index: nss-3.14.1/mozilla/security/coreconf/Linux.mk
 
7
Index: nss-3.14.3/mozilla/security/coreconf/Linux.mk
8
8
===================================================================
9
 
--- nss-3.14.1.orig/mozilla/security/coreconf/Linux.mk  2012-11-13 19:14:07.000000000 -0600
10
 
+++ nss-3.14.1/mozilla/security/coreconf/Linux.mk       2013-01-10 16:54:23.000000000 -0600
11
 
@@ -69,7 +69,7 @@
12
 
 
 
9
--- nss-3.14.3.orig/mozilla/security/coreconf/Linux.mk  2013-03-13 11:17:44.000000000 -0500
 
10
+++ nss-3.14.3/mozilla/security/coreconf/Linux.mk       2013-03-13 11:20:33.000000000 -0500
 
11
@@ -93,7 +93,7 @@
13
12
 LIBC_TAG               = _glibc
 
13
 endif
14
14
 
15
15
-ifeq ($(OS_RELEASE),2.0)
16
16
+ifeq ($(KERNEL)-$(OS_RELEASE),linux-2.0)
17
17
        OS_REL_CFLAGS   += -DLINUX2_0
18
18
        MKSHLIB         = $(CC) -shared -Wl,-soname -Wl,$(@:$(OBJDIR)/%.so=%.so) $(RPATH)
19
19
        ifdef MAPFILE
20
 
@@ -104,14 +104,21 @@
 
20
@@ -128,7 +128,10 @@
21
21
 # -ansi on platforms like Android where the system headers are C99 and do
22
22
 # not build with -ansi.
23
 
 STANDARDS_CFLAGS       = -ansi -D_POSIX_SOURCE -D_BSD_SOURCE -D_XOPEN_SOURCE
 
23
 STANDARDS_CFLAGS       = -D_POSIX_SOURCE -D_BSD_SOURCE -D_XOPEN_SOURCE
24
24
-OS_CFLAGS              = $(STANDARDS_CFLAGS) $(DSO_CFLAGS) $(OS_REL_CFLAGS) $(ARCHFLAG) -Wall -Werror-implicit-function-declaration -Wno-switch -pipe -DLINUX -Dlinux -DHAVE_STRERROR
25
25
+OS_CFLAGS              = $(STANDARDS_CFLAGS) $(DSO_CFLAGS) $(OS_REL_CFLAGS) $(ARCHFLAG) -Wall -Werror-implicit-function-declaration -Wno-switch -pipe -DHAVE_STRERROR
26
26
+ifeq ($(KERNEL),linux)
29
29
 OS_LIBS                        = $(OS_PTHREAD) -ldl -lc
30
30
 
31
31
 ifdef USE_PTHREADS
32
 
        DEFINES         += -D_REENTRANT
33
 
 endif
34
 
 
35
 
-ARCH                   = linux
36
 
+ifeq ($(KERNEL),linux)
37
 
+       ARCH            = linux
38
 
+else
39
 
+       ARCH            = gnu
40
 
+endif
41
 
 
42
 
 DSO_CFLAGS             = -fPIC
43
 
 DSO_LDOPTS             = -shared $(ARCHFLAG)
44
 
@@ -128,7 +135,7 @@
 
32
@@ -152,7 +155,7 @@
45
33
 LDFLAGS                        += -Wl,-rpath-link,/usr/lib:/lib
46
34
 endif
47
35
 
50
38
 G++INCLUDES            = -I/usr/include/g++
51
39
 
52
40
 #
53
 
@@ -161,7 +168,9 @@
 
41
@@ -187,7 +190,9 @@
54
42
 endif
55
43
 endif
56
44
 
60
48
 MKSHLIB         = $(CC) $(DSO_LDOPTS) -Wl,-soname -Wl,$(@:$(OBJDIR)/%.so=%.so) $(RPATH)
61
49
 
62
50
 ifdef MAPFILE
63
 
Index: nss-3.14.1/mozilla/security/coreconf/arch.mk
 
51
Index: nss-3.14.3/mozilla/security/coreconf/arch.mk
64
52
===================================================================
65
 
--- nss-3.14.1.orig/mozilla/security/coreconf/arch.mk   2012-05-03 04:42:57.000000000 -0500
66
 
+++ nss-3.14.1/mozilla/security/coreconf/arch.mk        2013-01-10 16:54:23.000000000 -0600
 
53
--- nss-3.14.3.orig/mozilla/security/coreconf/arch.mk   2013-03-13 11:17:44.000000000 -0500
 
54
+++ nss-3.14.3/mozilla/security/coreconf/arch.mk        2013-03-13 11:17:44.000000000 -0500
67
55
@@ -122,6 +122,14 @@
68
56
     ifneq ($(words $(OS_RELEASE)),1)
69
57
        OS_RELEASE := $(word 1,$(OS_RELEASE)).$(word 2,$(OS_RELEASE))
79
67
 endif
80
68
 
81
69
 #
82
 
Index: nss-3.14.1/mozilla/security/coreconf/config.mk
 
70
Index: nss-3.14.3/mozilla/security/coreconf/config.mk
83
71
===================================================================
84
 
--- nss-3.14.1.orig/mozilla/security/coreconf/config.mk 2012-11-13 19:14:07.000000000 -0600
85
 
+++ nss-3.14.1/mozilla/security/coreconf/config.mk      2013-01-10 16:54:23.000000000 -0600
 
72
--- nss-3.14.3.orig/mozilla/security/coreconf/config.mk 2013-03-13 11:17:44.000000000 -0500
 
73
+++ nss-3.14.3/mozilla/security/coreconf/config.mk      2013-03-13 11:23:38.000000000 -0500
86
74
@@ -31,7 +31,7 @@
87
75
 #######################################################################
88
76
 
89
77
 TARGET_OSES = FreeBSD BSD_OS NetBSD OpenUNIX OS2 QNX Darwin BeOS OpenBSD \
90
 
-              AIX RISCOS WINNT WIN95 Linux
91
 
+              AIX RISCOS WINNT WIN95 Linux GNU GNU_%
 
78
-              AIX RISCOS WINNT WIN95 Linux Android
 
79
+              AIX RISCOS WINNT WIN95 Linux Android GNU GNU_%
92
80
 
93
81
 ifeq (,$(filter-out $(TARGET_OSES),$(OS_TARGET)))
94
82
 include $(CORE_DEPTH)/coreconf/$(OS_TARGET).mk
95
 
Index: nss-3.14.1/mozilla/security/nss/lib/freebl/unix_rand.c
 
83
Index: nss-3.14.3/mozilla/security/nss/lib/freebl/unix_rand.c
96
84
===================================================================
97
 
--- nss-3.14.1.orig/mozilla/security/nss/lib/freebl/unix_rand.c 2013-01-10 16:52:58.000000000 -0600
98
 
+++ nss-3.14.1/mozilla/security/nss/lib/freebl/unix_rand.c      2013-01-10 16:54:23.000000000 -0600
 
85
--- nss-3.14.3.orig/mozilla/security/nss/lib/freebl/unix_rand.c 2013-03-13 11:17:44.000000000 -0500
 
86
+++ nss-3.14.3/mozilla/security/nss/lib/freebl/unix_rand.c      2013-03-13 11:17:44.000000000 -0500
99
87
@@ -156,7 +156,8 @@
100
88
 
101
89
 #if defined(SCO) || defined(UNIXWARE) || defined(BSDI) || defined(FREEBSD) \
106
94
 #include <sys/times.h>
107
95
 
108
96
 #define getdtablesize() sysconf(_SC_OPEN_MAX)
109
 
Index: nss-3.14.1/mozilla/security/nss/lib/softoken/softoken.h
 
97
Index: nss-3.14.3/mozilla/security/nss/lib/softoken/softoken.h
110
98
===================================================================
111
 
--- nss-3.14.1.orig/mozilla/security/nss/lib/softoken/softoken.h        2012-04-25 09:50:10.000000000 -0500
112
 
+++ nss-3.14.1/mozilla/security/nss/lib/softoken/softoken.h     2013-01-10 16:54:23.000000000 -0600
113
 
@@ -282,7 +282,7 @@
 
99
--- nss-3.14.3.orig/mozilla/security/nss/lib/softoken/softoken.h        2013-03-13 11:17:44.000000000 -0500
 
100
+++ nss-3.14.3/mozilla/security/nss/lib/softoken/softoken.h     2013-03-13 11:17:44.000000000 -0500
 
101
@@ -296,7 +296,7 @@
114
102
 
115
103
 #define CHECK_FORK_MIXED
116
104
 
119
107
 
120
108
 #define CHECK_FORK_PTHREAD
121
109
 
122
 
Index: nss-3.14.1/mozilla/security/nss/lib/ssl/sslmutex.c
 
110
Index: nss-3.14.3/mozilla/security/nss/lib/ssl/sslmutex.c
123
111
===================================================================
124
 
--- nss-3.14.1.orig/mozilla/security/nss/lib/ssl/sslmutex.c     2012-04-25 09:50:12.000000000 -0500
125
 
+++ nss-3.14.1/mozilla/security/nss/lib/ssl/sslmutex.c  2013-01-10 16:54:23.000000000 -0600
 
112
--- nss-3.14.3.orig/mozilla/security/nss/lib/ssl/sslmutex.c     2013-03-13 11:17:44.000000000 -0500
 
113
+++ nss-3.14.3/mozilla/security/nss/lib/ssl/sslmutex.c  2013-03-13 11:17:44.000000000 -0500
126
114
@@ -57,7 +57,7 @@
127
115
     return SECSuccess;
128
116
 }
132
120
 
133
121
 #include <unistd.h>
134
122
 #include <fcntl.h>
135
 
Index: nss-3.14.1/mozilla/security/nss/lib/ssl/sslmutex.h
 
123
Index: nss-3.14.3/mozilla/security/nss/lib/ssl/sslmutex.h
136
124
===================================================================
137
 
--- nss-3.14.1.orig/mozilla/security/nss/lib/ssl/sslmutex.h     2012-04-25 09:50:12.000000000 -0500
138
 
+++ nss-3.14.1/mozilla/security/nss/lib/ssl/sslmutex.h  2013-01-10 16:54:23.000000000 -0600
 
125
--- nss-3.14.3.orig/mozilla/security/nss/lib/ssl/sslmutex.h     2013-03-13 11:17:44.000000000 -0500
 
126
+++ nss-3.14.3/mozilla/security/nss/lib/ssl/sslmutex.h  2013-03-13 11:17:44.000000000 -0500
139
127
@@ -51,7 +51,7 @@
140
128
 
141
129
 typedef int    sslPID;