~ubuntu-branches/ubuntu/lucid/ntp/lucid

« back to all changes in this revision

Viewing changes to debian/patches/no-ipv6-fix.patch

  • Committer: Bazaar Package Importer
  • Author(s): Steve Langasek
  • Date: 2009-04-29 06:08:19 UTC
  • mfrom: (4.1.2 squeeze)
  • Revision ID: james.westby@ubuntu.com-20090429060819-ejgcea6z6hy6xv1f
Tags: 1:4.2.4p6+dfsg-1ubuntu1
* Merge from Debian unstable, remaining changes:
  - debian/ntp.conf, debian/ntpdate.default: Change default server to
    ntp.ubuntu.com.
  - debian/ntpdate.ifup: Stop ntp before running ntpdate when an interface 
    comes up, then start again afterwards
  - debian/ntp.init, debian/rules: Only stop when entering single user mode.
  - debian/man/ntpdate.8 - fix debian shipped manpage; patch by
    Josh Holland <jrh@joshh.co.uk>
* Dropped changes, merged in Debian:
  - Build against libcap2 instead of libcap1, fixing a kernel warning
    about using an old interface.
* Dropped changes, superseded upstream/in Debian:
  - debian/patches/CVE-2009-0021.patch: update ntpd/ntp_crypto.c to properly
    check the return code of EVP_VerifyFinal()
  - debian/patches/ipv6-gnu-source.patch: Define _GNU_SOURCE to make IPv6
    work.
* Fixes LP: #217699

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
compilation fix for systems without IPv6 support (bug #387665,
2
 
http://bugs.ntp.org/977)
3
 
 
4
 
--- ntp-4.2.2.orig/libisc/net.c
5
 
+++ ntp-4.2.2/libisc/net.c
6
 
@@ -206,7 +206,6 @@
7
 
        RUNTIME_CHECK(isc_once_do(&once_ipv6only,
8
 
                                  try_ipv6only) == ISC_R_SUCCESS);
9
 
 }
10
 
-#endif /* IPV6_V6ONLY */
11
 
 
12
 
 static void
13
 
 try_ipv6pktinfo(void) {
14
 
@@ -257,6 +256,7 @@
15
 
                                  try_ipv6pktinfo) == ISC_R_SUCCESS);
16
 
 }
17
 
 #endif /* WANT_IPV6 */
18
 
+#endif /* ISC_PLATFORM_HAVEIPV6 */
19
 
 
20
 
 isc_result_t
21
 
 isc_net_probe_ipv6only(void) {