~ubuntu-branches/ubuntu/lucid/procps/lucid

« back to all changes in this revision

Viewing changes to debian/patches/20_watch_8bitchar.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Kees Cook
  • Date: 2009-06-03 07:28:56 UTC
  • mfrom: (2.1.3 squeeze)
  • Revision ID: james.westby@ubuntu.com-20090603072856-zbj1y7nvc1bquf1o
Tags: 1:3.2.8-1ubuntu1
* Merge from debian unstable, remaining changes:
  - debian/rules (Ubuntu-specific):
    - set init script to priority 17.
    - install sysctl files from new sysctl.d directory.
    - append debian/sysctl.d/*.conf.$DEB_HOST_ARCH to 10-arch-specific.conf
  - debian/sysctl.d (Ubuntu-specific):
    - 10-console-messages.conf: stop low-level kernel messages on console.
    - 10-network-security.conf: enable rp_filter and SYN-flood protection.
    - 10-keyboard.conf.powerpc: mouse button emulation on PowerPC.
  - Drop conf-file-cleanups in debian/{preinst,postinst,postrm}.
  - Drop pre-Hardy rcS.d procps.sh cleanups in debian/postinst.

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
## DP: Make char unsigned
6
6
 
7
7
@DPATCH@
8
 
diff -urNad procps-3.2.7~/watch.c procps-3.2.7/watch.c
9
 
--- procps-3.2.7~/watch.c       2006-06-17 19:18:38.000000000 +1000
10
 
+++ procps-3.2.7/watch.c        2006-06-26 08:47:57.000000000 +1000
 
8
diff -urNad procps-3.2.8~/watch.c procps-3.2.8/watch.c
 
9
--- procps-3.2.8~/watch.c       2009-05-11 22:20:14.000000000 +1000
 
10
+++ procps-3.2.8/watch.c        2009-05-11 22:22:52.000000000 +1000
11
11
@@ -297,7 +297,7 @@
12
12
                                move(y, x);
13
13
                                if (option_differences) {
14
 
                                        int oldch = inch();
 
14
                                        chtype oldch = inch();
15
15
-                                       char oldc = oldch & A_CHARTEXT;
16
16
+                                       unsigned char oldc = oldch & A_CHARTEXT;
17
17
                                        attr = !first_screen
18
 
                                            && (c != oldc
 
18
                                            && ((char)c != oldc
19
19
                                                ||