~ubuntu-branches/ubuntu/lucid/sawfish/lucid-updates

« back to all changes in this revision

Viewing changes to debian/patches/fix-select-workspace.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Luis Rodrigo Gallardo Cruz
  • Date: 2007-08-09 14:02:43 UTC
  • mfrom: (1.2.6 upstream)
  • Revision ID: james.westby@ubuntu.com-20070809140243-vb0olmsg3jtcasn0
Tags: 1:1.3.1-1
* New upstream release, by a new upstream maintainer team.
 - Update homepage URL.
* Fix debian/rules to link to scripts in /usr/share/sawfish/$(version),
  instead of hardcoded 1.3
* fix-select-workspace.dpatch (closes: #413584).
* A bit more debian/rules cleanups.
* Upgrade to new menu policy.
* Fix .desktop files to compy with freedesktop.org standard.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## fix-select-workspace.dpatch by  GSR <gsr.bugs@infernal-iceberg.com>
 
3
##
 
4
## DP: Ooverrides the original function to one that makes sure the
 
5
## DP: dont-focus and inner-thunk are key params as expected by
 
6
## DP: select-workspace*
 
7
## DP: Closes: #413584
 
8
 
 
9
 
 
10
@DPATCH@
 
11
diff -urNad sawfish-1.3+svn4194~/lisp/sawfish/wm/workspace.jl sawfish-1.3+svn4194/lisp/sawfish/wm/workspace.jl
 
12
--- sawfish-1.3+svn4194~/lisp/sawfish/wm/workspace.jl   2003-04-02 20:50:12.000000000 -0600
 
13
+++ sawfish-1.3+svn4194/lisp/sawfish/wm/workspace.jl    2007-06-28 18:22:57.225442169 -0500
 
14
@@ -562,7 +562,7 @@
 
15
        (call-hook 'workspace-state-change-hook))))
 
16
 
 
17
   (define (select-workspace space #!optional dont-focus inner-thunk)
 
18
-    (select-workspace* space dont-focus inner-thunk))
 
19
+    (select-workspace* space #:dont-focus dont-focus #:inner-thunk inner-thunk))
 
20
 
 
21
   ;; return a list of all windows on workspace index SPACE
 
22
   (define (workspace-windows