~ubuntu-branches/ubuntu/lucid/seamonkey/lucid-security

« back to all changes in this revision

Viewing changes to debian/patches/65_composer_charset.patch

  • Committer: Bazaar Package Importer
  • Author(s): Fabien Tassin
  • Date: 2007-12-07 20:52:32 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20071207205232-e8z67dkmmgptikl4
Tags: 1.1.7+nobinonly-0ubuntu1
* New security upstream release: 1.1.7 (LP: #174739)
* MSFA 2007-37, MSFA 2007-38, MSFA 2007-39
* Drop patches applied upstream
  - drop debian/patches/65_branding_bug_401824.patch
  - drop debian/patches/65_composer_charset.patch
  - update debian/patches/series
* Update debian/patches/99_configure.patch
* Add Vcs-Bzr: and Homepage: fields to control
  - update debian/control
* Change dfsg into nobinonly in watch file
  - update debian/watch

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
---
2
 
 editor/ui/composer/content/editor.js |    1 +
3
 
 1 file changed, 1 insertion(+)
4
 
 
5
 
## 65_composer_charset.patch converted from dpatch file initially by Mike Hommey <glandium@debian.org>
6
 
#
7
 
# Align editor character set with meta tag character set at document 
8
 
# creation
9
 
 
10
 
Index: iceape-1.1.4/editor/ui/composer/content/editor.js
11
 
===================================================================
12
 
--- iceape-1.1.4.orig/editor/ui/composer/content/editor.js
13
 
+++ iceape-1.1.4/editor/ui/composer/content/editor.js
14
 
@@ -2494,16 +2494,17 @@
15
 
     if ( prefCharsetString && prefCharsetString != 0)
16
 
     {
17
 
         element = domdoc.createElement("meta");
18
 
         if ( element )
19
 
         {
20
 
           element.setAttribute("http-equiv", "content-type");
21
 
           element.setAttribute("content", "text/html; charset=" + prefCharsetString);
22
 
           headelement.insertBefore( element, headelement.firstChild );
23
 
+          editor.documentCharacterSet = prefCharsetString;
24
 
         }
25
 
     }
26
 
 
27
 
     var node = 0;
28
 
     var listlength = nodelist.length;
29
 
 
30
 
     // let's start by assuming we have an author in case we don't have the pref
31
 
     var authorFound = false;