~ubuntu-branches/ubuntu/lucid/tomboy/lucid-proposed

« back to all changes in this revision

Viewing changes to debian/patches/01_tinin.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastian Dröge
  • Date: 2006-11-16 21:24:14 UTC
  • mfrom: (1.1.7 upstream) (3 etch)
  • mto: This revision was merged to the branch mainline in revision 4.
  • Revision ID: james.westby@ubuntu.com-20061116212414-i9mqu3nnn90ulo7m
Tags: 0.5.0-0ubuntu1
* New upstream release
* debian/patches/52_applet-crash.patch:
  + Dropped, merged upstream
* debian/control,
  debian/patches/52_external-dbus-sharp.patch:
  + Build depend on libdbus-1-cil and build against it instead of the
    bundled version
* debian/rules:
  + Install DBus service file into the correct directory
* debian/patches/53_tomboy-tray-icon.patch:
  + Correctly set the icon for the trayicon

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- Tomboy/Applet.cs.old        2006-09-18 12:36:40.745304750 +0200
2
 
+++ Tomboy/Applet.cs    2006-09-18 12:36:45.949630000 +0200
3
 
@@ -42,8 +42,6 @@
4
 
                        tray = new TomboyTray (manager);
5
 
                        keybinder = new TomboyGConfXKeybinder (manager, tray);
6
 
 
7
 
-                       Flags |= PanelAppletFlags.ExpandMinor;
8
 
-
9
 
                        Add (tray);
10
 
                        OnChangeSize (Size);
11
 
                        ShowAll ();
12
 
@@ -124,7 +122,7 @@
13
 
                        if (tray == null)
14
 
                                return;
15
 
 
16
 
-                       tray.SetSizeRequest ((int) size, (int) size);
17
 
+                       tray.Image.Pixbuf = GuiUtils.GetIcon ("tomboy", (int)size);
18
 
                }
19
 
        }
20
 
 
21
 
--- Tomboy/Tray.cs.old  2006-09-18 12:36:31.648736250 +0200
22
 
+++ Tomboy/Tray.cs      2006-09-18 12:36:56.138266750 +0200
23
 
@@ -50,8 +50,6 @@
24
 
                        tips.Sink ();
25
 
 
26
 
                        SetupDragAndDrop ();
27
 
-
28
 
-                       InitSomeStuff ();
29
 
                }
30
 
 
31
 
                void ButtonPress (object sender, Gtk.ButtonPressEventArgs args) 
32
 
@@ -390,57 +388,6 @@
33
 
                                                        insert_text.ToString ());
34
 
                        }
35
 
                }
36
 
-
37
 
-               protected override void OnSizeAllocated (Gdk.Rectangle rect)
38
 
-               {
39
 
-                       base.OnSizeAllocated (rect);
40
 
-
41
 
-                       int icon_size = Math.Min (rect.Height, rect.Width);
42
 
-                       if (icon_size_last != icon_size) {
43
 
-                               icon_size_last = icon_size;
44
 
-                               image.Pixbuf = GuiUtils.GetIcon (GetIconName (), icon_size);
45
 
-                       }
46
 
-               }
47
 
-
48
 
-               void ReloadIcon ()
49
 
-               {
50
 
-                       icon_size_last = -1;
51
 
-                       QueueResize ();
52
 
-               }
53
 
-
54
 
-               // NOTHING TO SEE HERE
55
 
-               void InitSomeStuff ()
56
 
-               {
57
 
-                       manager.NoteDeleted += OnNoteDeletedUpdateIcon;
58
 
-                       manager.NoteAdded += OnNoteAddedUpdateIcon;
59
 
-                       manager.NoteRenamed += OnNoteRenamedUpdateIcon;
60
 
-               }
61
 
-
62
 
-               void OnNoteDeletedUpdateIcon (object sender, Note changed)
63
 
-               {
64
 
-                       if (changed.Title == "Tintin")
65
 
-                               ReloadIcon ();
66
 
-               }
67
 
-
68
 
-               void OnNoteAddedUpdateIcon (object sender, Note changed)
69
 
-               {
70
 
-                       if (changed.Title == "Tintin")
71
 
-                               ReloadIcon ();
72
 
-               }
73
 
-
74
 
-               void OnNoteRenamedUpdateIcon (Note note, string old_title)
75
 
-               {
76
 
-                       if (note.Title == "Tintin" || old_title == "Tintin")
77
 
-                               ReloadIcon ();
78
 
-               }
79
 
-
80
 
-               string GetIconName ()
81
 
-               {
82
 
-                       if (manager.Find ("Tintin") != null)
83
 
-                               return "tintin";
84
 
-                       return "tomboy";
85
 
-               }
86
 
-               // GO ABOUT YOUR BUSINESS
87
 
        }
88
 
 
89
 
        //