~ubuntu-branches/ubuntu/lucid/tomboy/lucid-proposed

« back to all changes in this revision

Viewing changes to debian/patches/01-dbus0.9.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastian Dröge
  • Date: 2006-11-22 19:22:17 UTC
  • mfrom: (1.1.8 upstream)
  • mto: This revision was merged to the branch mainline in revision 4.
  • Revision ID: james.westby@ubuntu.com-20061122192217-odnb17d1ib22okof
Tags: 0.5.1-0ubuntu1
* New upstream release:
  + New Managed D-Bus/DBusSharp (Sebastian Dröge)
  + Additional search interface improvements
  + More secure wrapper script to launch Tomboy.exe
  + Fix panel and TrayIcon resizing
  + Fix 1x1 pixel TrayIcon
  + Removed old tintin image
* debian/control:
  + Update build dependencies
* debian/patches/01-dbus0.9.patch,
  debian/patches/50_tintin.patch,
  debian/patches/51_tomboy-dllmap.patch,
  debian/patches/52_external-dbus-sharp.patch,
  debian/patches/53_tomboy-tray-icon.patch:
  + Dropped, merged upstream
* debian/rules,
  debian/tomboy.desktop:
  + Use upstream's desktop file again after it was fixed now
* debian/rules:
  + DBus service file path workaround removed, it's fixed upstream

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- Tomboy/dbus-sharp/Connection.cs.old 2006-08-24 17:14:03.056705000 +0200
2
 
+++ Tomboy/dbus-sharp/Connection.cs     2006-08-24 17:14:15.061455250 +0200
3
 
@@ -89,7 +89,7 @@
4
 
     {
5
 
       if (disposing && RawConnection != IntPtr.Zero) 
6
 
        {
7
 
-         dbus_connection_disconnect(rawConnection);
8
 
+         dbus_connection_close(rawConnection);
9
 
 
10
 
          RawConnection = IntPtr.Zero; // free the native object
11
 
        }
12
 
@@ -314,7 +314,7 @@
13
 
                                                           int    slot);
14
 
     
15
 
     [DllImport ("dbus-1")]
16
 
-    private extern static void dbus_connection_disconnect (IntPtr ptr);
17
 
+    private extern static void dbus_connection_close (IntPtr ptr);
18
 
 
19
 
     [DllImport ("dbus-1")]
20
 
     private extern static IntPtr dbus_bus_get_unique_name (IntPtr ptr);