~ubuntu-branches/ubuntu/lucid/zlib/lucid

« back to all changes in this revision

Viewing changes to debian/patches/001-link_to_shared_zlib_in_contrib

  • Committer: Bazaar Package Importer
  • Author(s): Matthias Klose
  • Date: 2007-07-09 17:25:35 UTC
  • mfrom: (1.2.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20070709172535-fywqps3hjk0bvi12
Tags: 1:1.2.3.3.dfsg-5ubuntu1
* Merge with Debian; remaining changes:
  - Install multilib into /usr/lib32 on amd64.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- zlib-1.2.1.orig/contrib/minizip/Makefile    2003-09-10 09:00:16.000000000 +0100
2
 
+++ zlib-1.2.1/contrib/minizip/Makefile 2003-11-17 22:11:05.000000000 +0000
3
 
@@ -1,8 +1,8 @@
4
 
 CC=cc
5
 
-CFLAGS=-O -I../..
6
 
+CFLAGS=-O2 -g -I../..
7
 
 
8
 
-UNZ_OBJS = miniunz.o unzip.o ioapi.o ../../libz.a
9
 
-ZIP_OBJS = minizip.o zip.o   ioapi.o ../../libz.a
10
 
+UNZ_OBJS = miniunz.o unzip.o ioapi.o
11
 
+ZIP_OBJS = minizip.o zip.o   ioapi.o
12
 
 
13
 
 .c.o:
14
 
        $(CC) -c $(CFLAGS) $*.c
15
 
@@ -10,10 +10,10 @@
16
 
 all: miniunz minizip
17
 
 
18
 
 miniunz:  $(UNZ_OBJS)
19
 
-       $(CC) $(CFLAGS) -o $@ $(UNZ_OBJS)
20
 
+       $(CC) $(CFLAGS) -o $@ $(UNZ_OBJS) -L ../.. -lz
21
 
 
22
 
 minizip:  $(ZIP_OBJS)
23
 
-       $(CC) $(CFLAGS) -o $@ $(ZIP_OBJS)
24
 
+       $(CC) $(CFLAGS) -o $@ $(ZIP_OBJS) -L ../.. -lz
25
 
 
26
 
 test:  miniunz minizip
27
 
        ./minizip test readme.txt