~ubuntu-branches/ubuntu/maverick/curl/maverick

« back to all changes in this revision

Viewing changes to debian/patches/no_com_err

  • Committer: Bazaar Package Importer
  • Author(s): Kees Cook
  • Date: 2009-12-11 19:33:21 UTC
  • mfrom: (3.4.2 squeeze) (40.1.2 curl)
  • Revision ID: james.westby@ubuntu.com-20091211193321-tenukopudyznzbjj
* Merge with Debian testing.  Remaining changes:
  - Keep build deps in main:
    - Drop build dependencies: stunnel, libdb4.6-dev, libssh2-1-dev
    - Add build-dependency on openssh-server
    - Drop libssh2-1-dev from libcurl4-openssl-dev's Depends.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Index: curl/configure.ac
2
2
===================================================================
3
 
--- curl.orig/configure.ac      2009-03-10 00:30:10.000000000 +0100
4
 
+++ curl/configure.ac   2009-03-10 00:30:39.000000000 +0100
5
 
@@ -1035,7 +1035,8 @@
 
3
--- curl.orig/configure.ac      2009-11-08 23:07:05.000000000 +0100
 
4
+++ curl/configure.ac   2009-11-08 23:07:32.000000000 +0100
 
5
@@ -1029,7 +1029,8 @@
6
6
   if test -z "$GSSAPI_INCS"; then
7
7
      if test -f "$GSSAPI_ROOT/bin/krb5-config"; then
8
8
         GSSAPI_INCS=`$GSSAPI_ROOT/bin/krb5-config --cflags gssapi`
12
12
      elif test "$GSSAPI_ROOT" != "yes"; then
13
13
         GSSAPI_INCS="-I$GSSAPI_ROOT/include"
14
14
         GSSAPI_LIBS="-lgssapi"
15
 
@@ -1114,7 +1115,8 @@
 
15
@@ -1108,7 +1109,8 @@
16
16
         dnl krb5-config doesn't have --libs-only-L or similar, put everything
17
17
         dnl into LIBS
18
18
         gss_libs=`$GSSAPI_ROOT/bin/krb5-config --libs gssapi`
24
24
         LIBS="$LIBS -lgssapi"
25
25
Index: curl/libcurl.pc.in
26
26
===================================================================
27
 
--- curl.orig/libcurl.pc.in     2009-03-10 00:30:10.000000000 +0100
28
 
+++ curl/libcurl.pc.in  2009-03-10 00:30:39.000000000 +0100
 
27
--- curl.orig/libcurl.pc.in     2009-11-08 23:07:05.000000000 +0100
 
28
+++ curl/libcurl.pc.in  2009-11-08 23:07:08.000000000 +0100
29
29
@@ -35,6 +35,6 @@
30
30
 URL: http://curl.haxx.se/
31
31
 Description: Library to transfer files with ftp, http, etc.
36
36
 Cflags: -I${includedir}
37
37
Index: curl/curl-config.in
38
38
===================================================================
39
 
--- curl.orig/curl-config.in    2009-03-10 00:30:10.000000000 +0100
40
 
+++ curl/curl-config.in 2009-03-10 00:30:39.000000000 +0100
41
 
@@ -139,14 +139,14 @@
 
39
--- curl.orig/curl-config.in    2009-11-08 23:07:05.000000000 +0100
 
40
+++ curl/curl-config.in 2009-11-08 23:07:08.000000000 +0100
 
41
@@ -136,14 +136,14 @@
42
42
           CURLLIBDIR=""
43
43
        fi
44
44
        if test "X@REQUIRE_LIB_DEPS@" = "Xyes"; then