~ubuntu-branches/ubuntu/maverick/f-spot/maverick

« back to all changes in this revision

Viewing changes to debian/patches/debian_link-system-gnome-keyring.patch

  • Committer: Bazaar Package Importer
  • Author(s): Iain Lane
  • Date: 2010-05-24 10:35:57 UTC
  • mfrom: (2.4.7 experimental)
  • Revision ID: james.westby@ubuntu.com-20100524103557-1j0i8f66caybci2n
Tags: 0.7.0-1
* New upstream release 0.7.0
 + First release of the unstable 0.7 development series. Massive changes.
 + Reparenting and detaching support (Anton Keks) (Closes: #559745)
 + A new Mallard-based documentation (Harold Schreckengost)
 + No longer embeds flickrnet, uses distribution copy (Iain Lane)
 + Adoption of a large amount of Hyena functionality (Paul Lange, Peter
   Goetz)
 + No longer embeds gnome-keyring-sharp
 + Completely rewritten import, much faster and less memory hungry (Ruben
   Vermeersch) (Closes: #559080, #492658, #341790, #357811, #426017) (LP:
   #412091)
 + No longer use gphoto2-sharp, now uses gvfs which is less crash-pron
   (Ruben Vermeersch)
 + Fix Facebook support (Ruben Vermeersch)
 + Modernized unit tests
 + Revamped build (Mike Gemünde)
 + Much improved duplicate detection (much faster too) (Ruben Vermeersch)
 + Mouse selection in Iconview (Vincent Pomey)
 + Image panning support using middle mouse button (Wojciech Dzierżanowski)
 + Timeline slider now restricted to the size of the window (Iain Churcher)
 + Over 100 bugs closed (http://bit.ly/cyVjnD)
   - No more warnings about schema defaults (Closes: #584215) (LP: #586132)
* debian/control: Clean up build deps to match configure checks
* debian/rules: Don't run dh_makeshilbs as we don't ship any shared
  libraries. There are some private ones though, which get picked up and
  result in a useless postinst/postrm call to ldconfig. Thanks, lintian.
* debian/patches/debian_fix-distclean.patch,
  debian/patches/debian_fix_f-spot.exe.config.patch,
  debian/patches/debian_link-system-flickrnet.patch,
  debian/patches/debian_link-system-gnome-keyring.patch,
  debian/patches/debian_disable-unit-tests,
  debian/patches/git_transition_duration.patch,
  debian/patches/ubuntu_fix_folder_export_hang.patch:
  Clean up obsolete patches which are no longer necessary 
* debian/patches/*: Temporarily disable patches which originated from Ubuntu
  and no longer apply cleanly. We will get these back in a future upstream
  development release.
* debian/patches/*: Refresh to apply cleanly 
* debian/rules: Add new include dir to autoreconf call to pick up f-spot
  macros 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## debian_link-system-gnome-keyring.dpatch by Mirco Bauer <meebey@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: No description.
6
 
 
7
 
Index: f-spot.git/Makefile.include
8
 
===================================================================
9
 
--- f-spot.git.orig/Makefile.include    2010-05-17 11:59:36.000000000 +0100
10
 
+++ f-spot.git/Makefile.include 2010-05-17 16:55:09.267960224 +0100
11
 
@@ -18,7 +18,7 @@
12
 
 
13
 
 ## Links
14
 
 
15
 
-LINK_KEYRING = -r:$(DIR_KEYRING)/gnome-keyring-sharp.dll
16
 
+LINK_KEYRING = -pkg:gnome-keyring-sharp-1.0
17
 
 LINK_GPHOTO2 = -r:$(DIR_GPHOTO2)/libgphoto2-sharp.dll
18
 
 LINK_SEMWEB = -r:$(DIR_SEMWEB)/SemWeb.dll
19
 
 LINK_GIOSHARP = -r:$(DIR_GIOSHARP)/gio-sharp.dll
20
 
Index: f-spot.git/lib/Makefile.am
21
 
===================================================================
22
 
--- f-spot.git.orig/lib/Makefile.am     2010-05-17 11:59:36.000000000 +0100
23
 
+++ f-spot.git/lib/Makefile.am  2010-05-17 16:55:49.197959582 +0100
24
 
@@ -4,7 +4,6 @@
25
 
 UNCONDITIONAL_SUBDIRS = \
26
 
        GKeyFile                        \
27
 
        gio-sharp                       \
28
 
-       gnome-keyring-sharp     \
29
 
        gtk-sharp-beans         \
30
 
        libjpegtran                     \
31
 
        libfspot                        \