~ubuntu-branches/ubuntu/maverick/kdemultimedia/maverick

« back to all changes in this revision

Viewing changes to debian/patches/97_fix_target_link_libraries.diff

  • Committer: Bazaar Package Importer
  • Author(s): Jonathan Thomas
  • Date: 2010-05-19 13:16:54 UTC
  • mfrom: (1.2.42 upstream)
  • Revision ID: james.westby@ubuntu.com-20100519131654-xfn7gesg3qu6ay87
Tags: 4:4.4.3-2ubuntu1
* Merge with Debian Unstable, remaining changes:
  - Keep Kubuntu docs path
  - Build-Depend on libtag-extras-dev to make juk read MP4 tags
  - Don't recommend mplayerthumbs in kdemultimedia, it's in multiverse
  - The mplayerthumbs package depends on mplayer or mplayer-nogui
* Bump kde-config-cddb's replace version on libkcddb4 to 4.4.60
* Update KUBUNTU-DEBIAN-DIFFERENCEs

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: kdemultimedia-4.3.90/libkcompactdisc/CMakeLists.txt
2
 
===================================================================
3
 
--- kdemultimedia-4.3.90.orig/libkcompactdisc/CMakeLists.txt    2010-01-06 18:59:52.125023604 -0500
4
 
+++ kdemultimedia-4.3.90/libkcompactdisc/CMakeLists.txt 2010-01-06 19:00:35.874001792 -0500
 
1
--- a/libkcompactdisc/CMakeLists.txt
 
2
+++ b/libkcompactdisc/CMakeLists.txt
5
3
@@ -47,7 +47,7 @@
6
4
 
7
5
 kde4_add_library(kcompactdisc SHARED ${kcompactdisc_LIB_SRCS})
8
6
 
9
7
-target_link_libraries(kcompactdisc ${KDE4_KDECORE_LIBS} ${KDE4_PHONON_LIBS} ${KDE4_SOLID_LIBS})
10
 
+target_link_libraries(kcompactdisc ${KDE4_KIO_LIBS} ${KDE4_PHONON_LIBS} ${KDE4_SOLID_LIBS} ${CMAKE_THREAD_LIBS_INIT})
 
8
+target_link_libraries(kcompactdisc ${KDE4_KDECORE_LIBS} ${KDE4_PHONON_LIBS} ${KDE4_SOLID_LIBS} ${CMAKE_THREAD_LIBS_INIT})
11
9
 if (HAVE_LIBASOUND2)
12
10
     target_link_libraries(kcompactdisc ${ASOUND_LIBRARY})
13
11
 endif (HAVE_LIBASOUND2)