~ubuntu-branches/ubuntu/maverick/libpng/maverick-updates

« back to all changes in this revision

Viewing changes to debian/patches/debian-changes-1.2.41-1ubuntu1

  • Committer: Bazaar Package Importer
  • Author(s): Steve Langasek
  • Date: 2010-01-28 11:57:34 UTC
  • mfrom: (1.1.11 upstream) (15.2.4 squeeze)
  • Revision ID: james.westby@ubuntu.com-20100128115734-5b6dgb3hf38bw9cn
Tags: 1.2.42-1ubuntu1
* Merge from Debian testing.  Remaining changes:
  - Move libpng from /usr/lib to /lib, so that plymouth is usable on
    systems with a separate /usr.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- libpng-1.2.41.orig/Makefile.in
2
 
+++ libpng-1.2.41/Makefile.in
3
 
@@ -408,7 +408,7 @@ config.h: stamp-h1
4
 
 stamp-h1: $(srcdir)/config.h.in $(top_builddir)/config.status
5
 
        @rm -f stamp-h1
6
 
        cd $(top_builddir) && $(SHELL) ./config.status config.h
7
 
-$(srcdir)/config.h.in: @MAINTAINER_MODE_TRUE@ $(am__configure_deps)
8
 
+$(srcdir)/config.h.in: @MAINTAINER_MODE_TRUE@ $(am__configure_deps) 
9
 
        ($(am__cd) $(top_srcdir) && $(AUTOHEADER))
10
 
        rm -f stamp-h1
11
 
        touch $@
12
 
@@ -450,9 +450,9 @@ clean-libLTLIBRARIES:
13
 
          echo "rm -f \"$${dir}/so_locations\""; \
14
 
          rm -f "$${dir}/so_locations"; \
15
 
        done
16
 
-libpng.la: $(libpng_la_OBJECTS) $(libpng_la_DEPENDENCIES)
17
 
+libpng.la: $(libpng_la_OBJECTS) $(libpng_la_DEPENDENCIES) 
18
 
        $(libpng_la_LINK)  $(libpng_la_OBJECTS) $(libpng_la_LIBADD) $(LIBS)
19
 
-libpng12.la: $(libpng12_la_OBJECTS) $(libpng12_la_DEPENDENCIES)
20
 
+libpng12.la: $(libpng12_la_OBJECTS) $(libpng12_la_DEPENDENCIES) 
21
 
        $(libpng12_la_LINK) -rpath $(libdir) $(libpng12_la_OBJECTS) $(libpng12_la_LIBADD) $(LIBS)
22
 
 
23
 
 clean-checkPROGRAMS:
24
 
@@ -463,7 +463,7 @@ clean-checkPROGRAMS:
25
 
        list=`for p in $$list; do echo "$$p"; done | sed 's/$(EXEEXT)$$//'`; \
26
 
        echo " rm -f" $$list; \
27
 
        rm -f $$list
28
 
-pngtest$(EXEEXT): $(pngtest_OBJECTS) $(pngtest_DEPENDENCIES)
29
 
+pngtest$(EXEEXT): $(pngtest_OBJECTS) $(pngtest_DEPENDENCIES) 
30
 
        @rm -f pngtest$(EXEEXT)
31
 
        $(LINK) $(pngtest_OBJECTS) $(pngtest_LDADD) $(LIBS)
32
 
 install-binSCRIPTS: $(bin_SCRIPTS)
33
 
--- libpng-1.2.41.orig/aclocal.m4
34
 
+++ libpng-1.2.41/aclocal.m4
35
 
@@ -2460,7 +2460,7 @@ linux*oldld* | linux*aout* | linux*coff*
36
 
   ;;
37
 
 
38
 
 # This must be Linux ELF.
39
 
-linux* | k*bsd*-gnu)
40
 
+linux* | k*bsd*-gnu | kopensolaris*-gnu)
41
 
   version_type=linux
42
 
   need_lib_prefix=no
43
 
   need_version=no
44
 
@@ -2500,6 +2500,18 @@ linux* | k*bsd*-gnu)
45
 
   dynamic_linker='GNU/Linux ld.so'
46
 
   ;;
47
 
 
48
 
+netbsdelf*-gnu)
49
 
+  version_type=linux
50
 
+  need_lib_prefix=no
51
 
+  need_version=no
52
 
+  library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
53
 
+  soname_spec='${libname}${release}${shared_ext}$major'
54
 
+  shlibpath_var=LD_LIBRARY_PATH
55
 
+  shlibpath_overrides_runpath=no
56
 
+  hardcode_into_libs=yes
57
 
+  dynamic_linker='NetBSD ld.elf_so'
58
 
+  ;;
59
 
+
60
 
 netbsd*)
61
 
   version_type=sunos
62
 
   need_lib_prefix=no
63
 
@@ -3087,11 +3099,11 @@ irix5* | irix6* | nonstopux*)
64
 
   ;;
65
 
 
66
 
 # This must be Linux ELF.
67
 
-linux* | k*bsd*-gnu)
68
 
+linux* | k*bsd*-gnu | kopensolaris*-gnu)
69
 
   lt_cv_deplibs_check_method=pass_all
70
 
   ;;
71
 
 
72
 
-netbsd*)
73
 
+netbsd* | netbsdelf*-gnu)
74
 
   if echo __ELF__ | $CC -E - | $GREP __ELF__ > /dev/null; then
75
 
     lt_cv_deplibs_check_method='match_pattern /lib[[^/]]+(\.so\.[[0-9]]+\.[[0-9]]+|_pic\.a)$'
76
 
   else
77
 
@@ -3708,7 +3720,7 @@ m4_if([$1], [CXX], [
78
 
            ;;
79
 
        esac
80
 
        ;;
81
 
-      linux* | k*bsd*-gnu)
82
 
+      linux* | k*bsd*-gnu | kopensolaris*-gnu)
83
 
        case $cc_basename in
84
 
          KCC*)
85
 
            # KAI C++ Compiler
86
 
@@ -3772,7 +3784,7 @@ m4_if([$1], [CXX], [
87
 
            ;;
88
 
        esac
89
 
        ;;
90
 
-      netbsd*)
91
 
+      netbsd* | netbsdelf*-gnu)
92
 
        ;;
93
 
       *qnx* | *nto*)
94
 
         # QNX uses GNU C++, but need to define -shared option too, otherwise
95
 
@@ -3992,7 +4004,7 @@ m4_if([$1], [CXX], [
96
 
       _LT_TAGVAR(lt_prog_compiler_static, $1)='-non_shared'
97
 
       ;;
98
 
 
99
 
-    linux* | k*bsd*-gnu)
100
 
+    linux* | k*bsd*-gnu | kopensolaris*-gnu)
101
 
       case $cc_basename in
102
 
       # old Intel for x86_64 which still supported -KPIC.
103
 
       ecc*)
104
 
@@ -4197,6 +4209,9 @@ m4_if([$1], [CXX], [
105
 
   cygwin* | mingw* | cegcc*)
106
 
     _LT_TAGVAR(export_symbols_cmds, $1)='$NM $libobjs $convenience | $global_symbol_pipe | $SED -e '\''/^[[BCDGRS]][[ ]]/s/.*[[ ]]\([[^ ]]*\)/\1 DATA/;/^.*[[ ]]__nm__/s/^.*[[ ]]__nm__\([[^ ]]*\)[[ ]][[^ ]]*/\1 DATA/;/^I[[ ]]/d;/^[[AITW]][[ ]]/s/.* //'\'' | sort | uniq > $export_symbols'
107
 
   ;;
108
 
+  linux* | k*bsd*-gnu)
109
 
+    _LT_TAGVAR(link_all_deplibs, $1)=no
110
 
+  ;;
111
 
   *)
112
 
     _LT_TAGVAR(export_symbols_cmds, $1)='$NM $libobjs $convenience | $global_symbol_pipe | $SED '\''s/.* //'\'' | sort | uniq > $export_symbols'
113
 
   ;;
114
 
@@ -4261,6 +4276,9 @@ dnl Note also adjust exclude_expsyms for
115
 
   openbsd*)
116
 
     with_gnu_ld=no
117
 
     ;;
118
 
+  linux* | k*bsd*-gnu)
119
 
+    _LT_TAGVAR(link_all_deplibs, $1)=no
120
 
+    ;;
121
 
   esac
122
 
 
123
 
   _LT_TAGVAR(ld_shlibs, $1)=yes
124
 
@@ -4282,6 +4300,7 @@ dnl Note also adjust exclude_expsyms for
125
 
     fi
126
 
     supports_anon_versioning=no
127
 
     case `$LD -v 2>&1` in
128
 
+      *GNU\ gold*) supports_anon_versioning=yes ;;
129
 
       *\ [[01]].* | *\ 2.[[0-9]].* | *\ 2.10.*) ;; # catch versions < 2.11
130
 
       *\ 2.11.93.0.2\ *) supports_anon_versioning=yes ;; # RH7.3 ...
131
 
       *\ 2.11.92.0.12\ *) supports_anon_versioning=yes ;; # Mandrake 8.2 ...
132
 
@@ -4373,7 +4392,7 @@ _LT_EOF
133
 
       _LT_TAGVAR(archive_expsym_cmds, $1)='sed "s,^,_," $export_symbols >$output_objdir/$soname.expsym~$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-h,$soname ${wl}--retain-symbols-file,$output_objdir/$soname.expsym ${wl}--image-base,`expr ${RANDOM-$$} % 4096 / 2 \* 262144 + 1342177280` -o $lib'
134
 
       ;;
135
 
 
136
 
-    gnu* | linux* | tpf* | k*bsd*-gnu)
137
 
+    gnu* | linux* | tpf* | k*bsd*-gnu | kopensolaris*-gnu)
138
 
       tmp_diet=no
139
 
       if test "$host_os" = linux-dietlibc; then
140
 
        case $cc_basename in
141
 
@@ -4443,7 +4462,7 @@ _LT_EOF
142
 
       fi
143
 
       ;;
144
 
 
145
 
-    netbsd*)
146
 
+    netbsd* | netbsdelf*-gnu)
147
 
       if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
148
 
        _LT_TAGVAR(archive_cmds, $1)='$LD -Bshareable $libobjs $deplibs $linker_flags -o $lib'
149
 
        wlarc=
150
 
@@ -4618,6 +4637,7 @@ _LT_EOF
151
 
        if test "$aix_use_runtimelinking" = yes; then
152
 
          shared_flag="$shared_flag "'${wl}-G'
153
 
        fi
154
 
+       _LT_TAGVAR(link_all_deplibs, $1)=no
155
 
       else
156
 
        # not using gcc
157
 
        if test "$host_cpu" = ia64; then
158
 
@@ -4856,7 +4876,7 @@ _LT_EOF
159
 
       _LT_TAGVAR(link_all_deplibs, $1)=yes
160
 
       ;;
161
 
 
162
 
-    netbsd*)
163
 
+    netbsd* | netbsdelf*-gnu)
164
 
       if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
165
 
        _LT_TAGVAR(archive_cmds, $1)='$LD -Bshareable -o $lib $libobjs $deplibs $linker_flags'  # a.out
166
 
       else
167
 
@@ -5852,7 +5872,7 @@ if test "$_lt_caught_CXX_error" != yes; 
168
 
         _LT_TAGVAR(inherit_rpath, $1)=yes
169
 
         ;;
170
 
 
171
 
-      linux* | k*bsd*-gnu)
172
 
+      linux* | k*bsd*-gnu | kopensolaris*-gnu)
173
 
         case $cc_basename in
174
 
           KCC*)
175
 
            # Kuck and Associates, Inc. (KAI) C++ Compiler
176
 
--- libpng-1.2.41.orig/ltmain.sh
177
 
+++ libpng-1.2.41/ltmain.sh
178
 
@@ -65,7 +65,7 @@
179
 
 #       compiler:              $LTCC
180
 
 #       compiler flags:                $LTCFLAGS
181
 
 #       linker:                $LD (gnu? $with_gnu_ld)
182
 
-#       $progname:             (GNU libtool) 2.2.6b
183
 
+#       $progname:             (GNU libtool) 2.2.6b Debian-2.2.6b-2ubuntu1
184
 
 #       automake:              $automake_version
185
 
 #       autoconf:              $autoconf_version
186
 
 #
187
 
@@ -73,7 +73,7 @@
188
 
 
189
 
 PROGRAM=ltmain.sh
190
 
 PACKAGE=libtool
191
 
-VERSION=2.2.6b
192
 
+VERSION="2.2.6b Debian-2.2.6b-2ubuntu1"
193
 
 TIMESTAMP=""
194
 
 package_revision=1.3017
195
 
 
196
 
@@ -5033,7 +5033,10 @@ func_mode_link ()
197
 
        case $pass in
198
 
        dlopen) libs="$dlfiles" ;;
199
 
        dlpreopen) libs="$dlprefiles" ;;
200
 
-       link) libs="$deplibs %DEPLIBS% $dependency_libs" ;;
201
 
+       link)
202
 
+         libs="$deplibs %DEPLIBS%"
203
 
+         test "X$link_all_deplibs" != Xno && libs="$libs $dependency_libs"
204
 
+         ;;
205
 
        esac
206
 
       fi
207
 
       if test "$linkmode,$pass" = "lib,dlpreopen"; then
208
 
@@ -5344,19 +5347,19 @@ func_mode_link ()
209
 
            # It is a libtool convenience library, so add in its objects.
210
 
            convenience="$convenience $ladir/$objdir/$old_library"
211
 
            old_convenience="$old_convenience $ladir/$objdir/$old_library"
212
 
+           tmp_libs=
213
 
+           for deplib in $dependency_libs; do
214
 
+             deplibs="$deplib $deplibs"
215
 
+             if $opt_duplicate_deps ; then
216
 
+               case "$tmp_libs " in
217
 
+               *" $deplib "*) specialdeplibs="$specialdeplibs $deplib" ;;
218
 
+               esac
219
 
+             fi
220
 
+             tmp_libs="$tmp_libs $deplib"
221
 
+           done
222
 
          elif test "$linkmode" != prog && test "$linkmode" != lib; then
223
 
            func_fatal_error "\`$lib' is not a convenience library"
224
 
          fi
225
 
-         tmp_libs=
226
 
-         for deplib in $dependency_libs; do
227
 
-           deplibs="$deplib $deplibs"
228
 
-           if $opt_duplicate_deps ; then
229
 
-             case "$tmp_libs " in
230
 
-             *" $deplib "*) specialdeplibs="$specialdeplibs $deplib" ;;
231
 
-             esac
232
 
-           fi
233
 
-           tmp_libs="$tmp_libs $deplib"
234
 
-         done
235
 
          continue
236
 
        fi # $pass = conv
237
 
 
238
 
@@ -5893,6 +5896,7 @@ func_mode_link ()
239
 
          if test "$link_all_deplibs" != no; then
240
 
            # Add the search paths of all dependency libraries
241
 
            for deplib in $dependency_libs; do
242
 
+             path=
243
 
              case $deplib in
244
 
              -L*) path="$deplib" ;;
245
 
              *.la)
246
 
@@ -6206,6 +6210,9 @@ func_mode_link ()
247
 
            revision="$number_minor"
248
 
            lt_irix_increment=no
249
 
            ;;
250
 
+         *)
251
 
+           func_fatal_configuration "$modename: unknown library version type \`$version_type'"
252
 
+           ;;
253
 
          esac
254
 
          ;;
255
 
        no)
256
 
--- libpng-1.2.41.orig/configure
257
 
+++ libpng-1.2.41/configure
258
 
@@ -5613,11 +5613,11 @@ irix5* | irix6* | nonstopux*)
259
 
   ;;
260
 
 
261
 
 # This must be Linux ELF.
262
 
-linux* | k*bsd*-gnu)
263
 
+linux* | k*bsd*-gnu | kopensolaris*-gnu)
264
 
   lt_cv_deplibs_check_method=pass_all
265
 
   ;;
266
 
 
267
 
-netbsd*)
268
 
+netbsd* | netbsdelf*-gnu)
269
 
   if echo __ELF__ | $CC -E - | $GREP __ELF__ > /dev/null; then
270
 
     lt_cv_deplibs_check_method='match_pattern /lib[^/]+(\.so\.[0-9]+\.[0-9]+|_pic\.a)$'
271
 
   else
272
 
@@ -7909,7 +7909,7 @@ $as_echo_n "checking for $compiler optio
273
 
       lt_prog_compiler_static='-non_shared'
274
 
       ;;
275
 
 
276
 
-    linux* | k*bsd*-gnu)
277
 
+    linux* | k*bsd*-gnu | kopensolaris*-gnu)
278
 
       case $cc_basename in
279
 
       # old Intel for x86_64 which still supported -KPIC.
280
 
       ecc*)
281
 
@@ -8358,6 +8358,9 @@ $as_echo_n "checking whether the $compil
282
 
   openbsd*)
283
 
     with_gnu_ld=no
284
 
     ;;
285
 
+  linux* | k*bsd*-gnu)
286
 
+    link_all_deplibs=no
287
 
+    ;;
288
 
   esac
289
 
 
290
 
   ld_shlibs=yes
291
 
@@ -8379,6 +8382,7 @@ $as_echo_n "checking whether the $compil
292
 
     fi
293
 
     supports_anon_versioning=no
294
 
     case `$LD -v 2>&1` in
295
 
+      *GNU\ gold*) supports_anon_versioning=yes ;;
296
 
       *\ [01].* | *\ 2.[0-9].* | *\ 2.10.*) ;; # catch versions < 2.11
297
 
       *\ 2.11.93.0.2\ *) supports_anon_versioning=yes ;; # RH7.3 ...
298
 
       *\ 2.11.92.0.12\ *) supports_anon_versioning=yes ;; # Mandrake 8.2 ...
299
 
@@ -8470,7 +8474,7 @@ _LT_EOF
300
 
       archive_expsym_cmds='sed "s,^,_," $export_symbols >$output_objdir/$soname.expsym~$CC -shared $pic_flag $libobjs $deplibs $compiler_flags ${wl}-h,$soname ${wl}--retain-symbols-file,$output_objdir/$soname.expsym ${wl}--image-base,`expr ${RANDOM-$$} % 4096 / 2 \* 262144 + 1342177280` -o $lib'
301
 
       ;;
302
 
 
303
 
-    gnu* | linux* | tpf* | k*bsd*-gnu)
304
 
+    gnu* | linux* | tpf* | k*bsd*-gnu | kopensolaris*-gnu)
305
 
       tmp_diet=no
306
 
       if test "$host_os" = linux-dietlibc; then
307
 
        case $cc_basename in
308
 
@@ -8540,7 +8544,7 @@ _LT_EOF
309
 
       fi
310
 
       ;;
311
 
 
312
 
-    netbsd*)
313
 
+    netbsd* | netbsdelf*-gnu)
314
 
       if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
315
 
        archive_cmds='$LD -Bshareable $libobjs $deplibs $linker_flags -o $lib'
316
 
        wlarc=
317
 
@@ -8715,6 +8719,7 @@ _LT_EOF
318
 
        if test "$aix_use_runtimelinking" = yes; then
319
 
          shared_flag="$shared_flag "'${wl}-G'
320
 
        fi
321
 
+       link_all_deplibs=no
322
 
       else
323
 
        # not using gcc
324
 
        if test "$host_cpu" = ia64; then
325
 
@@ -9041,7 +9046,7 @@ rm -f core conftest.err conftest.$ac_obj
326
 
       link_all_deplibs=yes
327
 
       ;;
328
 
 
329
 
-    netbsd*)
330
 
+    netbsd* | netbsdelf*-gnu)
331
 
       if echo __ELF__ | $CC -E - | $GREP __ELF__ >/dev/null; then
332
 
        archive_cmds='$LD -Bshareable -o $lib $libobjs $deplibs $linker_flags'  # a.out
333
 
       else
334
 
@@ -9931,7 +9936,7 @@ linux*oldld* | linux*aout* | linux*coff*
335
 
   ;;
336
 
 
337
 
 # This must be Linux ELF.
338
 
-linux* | k*bsd*-gnu)
339
 
+linux* | k*bsd*-gnu | kopensolaris*-gnu)
340
 
   version_type=linux
341
 
   need_lib_prefix=no
342
 
   need_version=no
343
 
@@ -9986,6 +9991,18 @@ rm -f core conftest.err conftest.$ac_obj
344
 
   dynamic_linker='GNU/Linux ld.so'
345
 
   ;;
346
 
 
347
 
+netbsdelf*-gnu)
348
 
+  version_type=linux
349
 
+  need_lib_prefix=no
350
 
+  need_version=no
351
 
+  library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}$major ${libname}${shared_ext}'
352
 
+  soname_spec='${libname}${release}${shared_ext}$major'
353
 
+  shlibpath_var=LD_LIBRARY_PATH
354
 
+  shlibpath_overrides_runpath=no
355
 
+  hardcode_into_libs=yes
356
 
+  dynamic_linker='NetBSD ld.elf_so'
357
 
+  ;;
358
 
+
359
 
 netbsd*)
360
 
   version_type=sunos
361
 
   need_lib_prefix=no
362
 
@@ -10606,7 +10623,7 @@ else
363
 
   lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
364
 
   lt_status=$lt_dlunknown
365
 
   cat > conftest.$ac_ext <<_LT_EOF
366
 
-#line 10609 "configure"
367
 
+#line 10626 "configure"
368
 
 #include "confdefs.h"
369
 
 
370
 
 #if HAVE_DLFCN_H
371
 
@@ -10702,7 +10719,7 @@ else
372
 
   lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
373
 
   lt_status=$lt_dlunknown
374
 
   cat > conftest.$ac_ext <<_LT_EOF
375
 
-#line 10705 "configure"
376
 
+#line 10722 "configure"
377
 
 #include "confdefs.h"
378
 
 
379
 
 #if HAVE_DLFCN_H