~ubuntu-branches/ubuntu/maverick/lighttpd/maverick

« back to all changes in this revision

Viewing changes to debian/patches/lighttpd-1.4.x_request_header_memleak.patch

  • Committer: Bazaar Package Importer
  • Author(s): Dustin Kirkland
  • Date: 2008-11-22 21:12:01 UTC
  • mfrom: (6.1.1 lenny)
  • Revision ID: james.westby@ubuntu.com-20081122211201-lrmc15h29b6u3jjq
Tags: 1.4.19-5ubuntu1
* Merge from debian unstable, remaining changes:
 - debian/control: Depend on lsb >= 3.2-14, which has the
   status_of_proc() function; libgamin-dev rather than libfam-dev
   to fix startup warning
 - debian/init.d: Add the 'status' action, clean environment
 - debian/rules: set DEB_UPDATE_RCD_PARAMS to "defaults 91 09" to not
   start lighty before apache2 but in the same runlevel with the same
   priority
 - debian/index.html: s/Debian/Ubuntu/g branding on the default page
 - debian/compat: standards version 3.7.3, bump compat to 6, adjusted
   build-dep of debhelper accordingly
* Dropped changes
 - debian/lighttpd.install: all changes upstream now, order adjusted
   accordingly

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- src/request.c.orig
 
2
+++ src/request.c
 
3
@@ -825,6 +825,7 @@
 
4
                                                                                                "request-header:\n",
 
5
                                                                                                con->request.request);
 
6
                                                                        }
 
7
+                                                                       array_insert_unique(con->request.headers, (data_unset *)ds);
 
8
                                                                        return 0;
 
9
                                                                }
 
10
 
 
11
@@ -874,6 +875,7 @@
 
12
                                                                                                "request-header:\n",
 
13
                                                                                                con->request.request);
 
14
                                                                        }
 
15
+                                                                       array_insert_unique(con->request.headers, (data_unset *)ds);
 
16
                                                                        return 0;
 
17
                                                                }
 
18
                                                        } else if (cmp > 0 && 0 == (cmp = buffer_caseless_compare(CONST_BUF_LEN(ds->key), CONST_STR_LEN("Expect")))) {
 
19
@@ -911,6 +913,7 @@
 
20
                                                                                                "request-header:\n",
 
21
                                                                                                con->request.request);
 
22
                                                                        }
 
23
+                                                                       array_insert_unique(con->request.headers, (data_unset *)ds);
 
24
                                                                        return 0;
 
25
                                                                }
 
26
                                                        } else if (cmp > 0 && 0 == (cmp = buffer_caseless_compare(CONST_BUF_LEN(ds->key), CONST_STR_LEN("If-Modified-Since")))) {
 
27
@@ -936,6 +939,7 @@
 
28
                                                                                                "request-header:\n",
 
29
                                                                                                con->request.request);
 
30
                                                                        }
 
31
+                                                                       array_insert_unique(con->request.headers, (data_unset *)ds);
 
32
                                                                        return 0;
 
33
                                                                }
 
34
                                                        } else if (cmp > 0 && 0 == (cmp = buffer_caseless_compare(CONST_BUF_LEN(ds->key), CONST_STR_LEN("If-None-Match")))) {
 
35
@@ -953,6 +957,7 @@
 
36
                                                                                                "request-header:\n",
 
37
                                                                                                con->request.request);
 
38
                                                                        }
 
39
+                                                                       array_insert_unique(con->request.headers, (data_unset *)ds);
 
40
                                                                        return 0;
 
41
                                                                }
 
42
                                                        } else if (cmp > 0 && 0 == (cmp = buffer_caseless_compare(CONST_BUF_LEN(ds->key), CONST_STR_LEN("Range")))) {
 
43
@@ -976,6 +981,7 @@
 
44
                                                                                                "request-header:\n",
 
45
                                                                                                con->request.request);
 
46
                                                                        }
 
47
+                                                                       array_insert_unique(con->request.headers, (data_unset *)ds);
 
48
                                                                        return 0;
 
49
                                                                }
 
50
                                                        }