~ubuntu-branches/ubuntu/maverick/mousepad/maverick

« back to all changes in this revision

Viewing changes to debian/patches/01_fix-recent-items-sort.patch

  • Committer: Bazaar Package Importer
  • Author(s): Lionel Le Folgoc
  • Date: 2008-02-13 20:38:01 UTC
  • mfrom: (0.1.3 lenny)
  • Revision ID: james.westby@ubuntu.com-20080213203801-51jpn4343km04ojp
Tags: 0.2.13-2ubuntu1
* Merge from Debian unstable, remaining Ubuntu changes:
  - debian/rules: add the gettext domain in the desktop file
  - debian/control: adhere to DebianMaintainerField
  - debian/patches: keep 10_fix-sigserv-invalid-config.patch.
* debian/patches/series: updated.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: mousepad/src/menu.c
 
2
===================================================================
 
3
--- mousepad.orig/src/menu.c    (revision 26427)
 
4
+++ mousepad/src/menu.c (working copy)
 
5
@@ -210,6 +210,7 @@
 
6
   gtk_recent_chooser_set_local_only(GTK_RECENT_CHOOSER(recent_menu), TRUE);
 
7
   gtk_recent_chooser_set_limit(GTK_RECENT_CHOOSER(recent_menu), 10);
 
8
   gtk_recent_chooser_set_show_tips(GTK_RECENT_CHOOSER(recent_menu), TRUE);
 
9
+  gtk_recent_chooser_set_sort_type(GTK_RECENT_CHOOSER(recent_menu), GTK_RECENT_SORT_MRU);
 
10
   g_signal_connect_swapped(G_OBJECT(recent_menu), "item-activated", G_CALLBACK(cb_file_open_recent), sd);
 
11
 
 
12
   recent_menu_item = gtk_item_factory_get_widget(ifactory, "/File/Open Recent");