~ubuntu-branches/ubuntu/maverick/openldap/maverick-proposed

« back to all changes in this revision

Viewing changes to debian/patches/evolution-ntlm

  • Committer: Bazaar Package Importer
  • Author(s): Mathias Gug, Steve Langasek, Mathias Gug
  • Date: 2009-02-18 18:44:00 UTC
  • mfrom: (1.1.2 upstream) (0.1.2 lenny)
  • Revision ID: james.westby@ubuntu.com-20090218184400-zw4mjse9eywt5566
Tags: 2.4.14-0ubuntu1
[ Steve Langasek ]
* New upstream version
  - Fixes a bug with the pcache overlay not returning cached entries
    (closes: #497697)
  - Update evolution-ntlm patch to apply to current Makefiles.
  - (tentatively) drop gnutls-ciphers, since this bug was reported to be
    fixed upstream in 2.4.8.  The fix applied in 2.4.8 didn't match the
    patch from the bug report, so this should be watched for regressions.
* Build against db4.7 instead of db4.2 at last!  Closes: #421946.
* Build with --disable-ndb, to avoid a misbuild when libmysqlclient is
  installed in the build environment.
* New patch, no-crlcheck-for-gnutls, to fix a build failure when using
  --with-tls=gnutls.

[ Mathias Gug ]
* Merge from debian unstable, remaining changes:
  - debian/apparmor-profile: add AppArmor profile
  - debian/slapd.postinst: Reload AA profile on configuration
  - updated debian/slapd.README.Debian for note on AppArmor
  - debian/control: Recommends apparmor >= 2.1+1075-0ubuntu6
  - debian/control: Conflicts with apparmor-profiles << 2.1+1075-0ubuntu4
    to make sure that if earlier version of apparmour-profiles gets
    installed it won't overwrite our profile.
  - Modify Maintainer value to match the DebianMaintainerField
    speficication.
  - follow ApparmorProfileMigration and force apparmor compalin mode on 
    some upgrades (LP: #203529)
  - debian/slapd.dirs: add etc/apparmor.d/force-complain
  - debian/slapd.preinst: create symlink for force-complain on pre-feisty
    upgrades, upgrades where apparmor-profiles profile is unchanged (ie
    non-enforcing) and upgrades where apparmor profile does not exist.
  - debian/slapd.postrm: remove symlink in force-complain/ on purge
  - debian/patches/fix-ucred-libc due to changes how newer glibc handle
    the ucred struct now.
  - debian/control:
    - Build-depend on libltdl7-dev rather then libltdl3-dev.
  - debian/patches/autogen.sh:
    - Call libtoolize with the --install option to install config.{guess,sub}
      files.
  - Don't use local statement in config script as it fails if /bin/sh
    points to bash (LP: #286063).
  - Disable the testsuite on hppa. Allows building of packages on this
    architecture again, once this package is in the archive.
    LP: #288908.
  - debian/slapd.postinst, debian/slapd.script-common: set correct ownership
    and permissions on /var/lib/ldap, /etc/ldap/slapd.d (group readable) and
    /var/run/slapd (world readable). (LP: #257667).
  - debian/patches/nssov-build, debian/rules: 
    Build and package the nss overlay.
    debian/schema/misc.ldif: add ldif file for the misc schema, which defines
    rfc822MailMember (required by the nss overlay).
  - debian/{control,rules}: enable PIE hardening
  - Use cn=config as the default configuration backend instead of 
    slapd.conf. Migrate slapd.conf  file to /etc/ldap/slapd.d/ on upgrade
    asking the end user to enter a new password to control the access to the
    cn=config tree.
* debian/patches/corrupt-contextCSN: The contextCSN can get corrupted at
  times. (ITS: #5947)

Show diffs side-by-side

added added

removed removed

Lines of Context:
11
11
Bug#457374 filed against evolution-data-server asking if this support is
12
12
still required on 2007-12-21.
13
13
 
14
 
Index: ubuntu-i/include/ldap.h
 
14
Index: trunk/include/ldap.h
15
15
===================================================================
16
 
--- ubuntu-i.orig/include/ldap.h        2008-08-11 14:03:23.000000000 -0400
17
 
+++ ubuntu-i/include/ldap.h     2008-08-11 15:14:16.000000000 -0400
18
 
@@ -2359,5 +2359,25 @@
19
 
        int             iscritical,
20
 
        LDAPControl     **ctrlp ));
 
16
--- trunk.orig/include/ldap.h
 
17
+++ trunk/include/ldap.h
 
18
@@ -2461,5 +2461,25 @@
 
19
        LDAPControl     **ctrls,
 
20
        LDAPDerefRes    **drp ));
21
21
 
22
22
+/*
23
23
+ * hacks for NTLM
41
41
+
42
42
 LDAP_END_DECL
43
43
 #endif /* _LDAP_H */
44
 
Index: ubuntu-i/libraries/libldap/ntlm.c
 
44
Index: trunk/libraries/libldap/ntlm.c
45
45
===================================================================
46
 
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
47
 
+++ ubuntu-i/libraries/libldap/ntlm.c   2008-08-11 15:14:16.000000000 -0400
 
46
--- /dev/null
 
47
+++ trunk/libraries/libldap/ntlm.c
48
48
@@ -0,0 +1,138 @@
49
49
+/* $OpenLDAP: pkg/ldap/libraries/libldap/ntlm.c,v 1.1.4.10 2002/01/04 20:38:21 kurt Exp $ */
50
50
+/*
184
184
+ return( ld->ld_errno );
185
185
+}
186
186
+
187
 
Index: ubuntu-i/libraries/libldap/Makefile.in
 
187
Index: trunk/libraries/libldap/Makefile.in
188
188
===================================================================
189
 
--- ubuntu-i.orig/libraries/libldap/Makefile.in 2008-08-11 14:03:23.000000000 -0400
190
 
+++ ubuntu-i/libraries/libldap/Makefile.in      2008-08-11 19:07:30.000000000 -0400
 
189
--- trunk.orig/libraries/libldap/Makefile.in
 
190
+++ trunk/libraries/libldap/Makefile.in
191
191
@@ -27,7 +27,7 @@
192
192
        init.c options.c print.c string.c util-int.c schema.c \
193
 
        charray.c tls.c os-local.c dnssrv.c utf-8.c utf-8-conv.c \
194
 
        turn.c ppolicy.c dds.c txn.c ldap_sync.c stctrl.c \
195
 
-       assertion.c
196
 
+       assertion.c ntlm.c
 
193
        charray.c os-local.c dnssrv.c utf-8.c utf-8-conv.c \
 
194
        tls2.c tls_o.c tls_g.c tls_m.c \
 
195
-       turn.c ppolicy.c dds.c txn.c ldap_sync.c stctrl.c \
 
196
+       turn.c ppolicy.c dds.c txn.c ldap_sync.c stctrl.c ntlm.c \
 
197
        assertion.c deref.c
197
198
 
198
199
 OBJS   = bind.lo open.lo result.lo error.lo compare.lo search.lo \
199
 
        controls.lo messages.lo references.lo extended.lo cyrus.lo \
200
 
@@ -39,7 +39,7 @@
 
200
@@ -40,7 +40,7 @@
201
201
        init.lo options.lo print.lo string.lo util-int.lo schema.lo \
202
 
        charray.lo tls.lo os-local.lo dnssrv.lo utf-8.lo utf-8-conv.lo \
203
 
        turn.lo ppolicy.lo dds.lo txn.lo ldap_sync.lo stctrl.lo \
204
 
-       assertion.lo
205
 
+       assertion.lo ntlm.lo
 
202
        charray.lo os-local.lo dnssrv.lo utf-8.lo utf-8-conv.lo \
 
203
        tls2.lo tls_o.lo tls_g.lo tls_m.lo \
 
204
-       turn.lo ppolicy.lo dds.lo txn.lo ldap_sync.lo stctrl.lo \
 
205
+       turn.lo ppolicy.lo dds.lo txn.lo ldap_sync.lo stctrl.lo ntlm.lo \
 
206
        assertion.lo deref.lo
206
207
 
207
208
 LDAP_INCDIR= ../../include       
208
 
 LDAP_LIBDIR= ../../libraries
209
 
Index: ubuntu-i/libraries/libldap_r/Makefile.in
 
209
Index: trunk/libraries/libldap_r/Makefile.in
210
210
===================================================================
211
 
--- ubuntu-i.orig/libraries/libldap_r/Makefile.in       2008-08-11 14:03:23.000000000 -0400
212
 
+++ ubuntu-i/libraries/libldap_r/Makefile.in    2008-08-11 19:08:52.000000000 -0400
 
211
--- trunk.orig/libraries/libldap_r/Makefile.in
 
212
+++ trunk/libraries/libldap_r/Makefile.in
213
213
@@ -29,7 +29,7 @@
214
214
        init.c options.c print.c string.c util-int.c schema.c \
215
 
        charray.c tls.c os-local.c dnssrv.c utf-8.c utf-8-conv.c \
216
 
        turn.c ppolicy.c dds.c txn.c ldap_sync.c stctrl.c \
217
 
-       assertion.c
218
 
+       assertion.c ntlm.c
 
215
        charray.c os-local.c dnssrv.c utf-8.c utf-8-conv.c \
 
216
        tls2.c tls_o.c tls_g.c tls_m.c \
 
217
-       turn.c ppolicy.c dds.c txn.c ldap_sync.c stctrl.c \
 
218
+       turn.c ppolicy.c dds.c txn.c ldap_sync.c stctrl.c ntlm.c \
 
219
        assertion.c deref.c
219
220
 SRCS   = threads.c rdwr.c rmutex.c tpool.c rq.c \
220
221
        thr_posix.c thr_cthreads.c thr_thr.c thr_lwp.c thr_nt.c \
221
 
        thr_pth.c thr_stub.c thr_debug.c
222
 
@@ -46,7 +46,7 @@
 
222
@@ -47,7 +47,7 @@
223
223
        init.lo options.lo print.lo string.lo util-int.lo schema.lo \
224
 
        charray.lo tls.lo os-local.lo dnssrv.lo utf-8.lo utf-8-conv.lo \
225
 
        turn.lo ppolicy.lo dds.lo txn.lo ldap_sync.lo stctrl.lo \
226
 
-       assertion.lo
227
 
+       assertion.lo ntlm.lo
 
224
        charray.lo os-local.lo dnssrv.lo utf-8.lo utf-8-conv.lo \
 
225
        tls2.lo tls_o.lo tls_g.lo tls_m.lo \
 
226
-       turn.lo ppolicy.lo dds.lo txn.lo ldap_sync.lo stctrl.lo \
 
227
+       turn.lo ppolicy.lo dds.lo txn.lo ldap_sync.lo stctrl.lo ntlm.lo \
 
228
        assertion.lo deref.lo
228
229
 
229
230
 LDAP_INCDIR= ../../include       
230
 
 LDAP_LIBDIR= ../../libraries