~ubuntu-branches/ubuntu/maverick/openldap/maverick-updates

« back to all changes in this revision

Viewing changes to debian/patches/back-perl-init

  • Committer: Bazaar Package Importer
  • Author(s): Mathias Gug, Steve Langasek, Mathias Gug
  • Date: 2009-02-18 18:44:00 UTC
  • mfrom: (1.1.2 upstream) (0.1.2 lenny)
  • Revision ID: james.westby@ubuntu.com-20090218184400-zw4mjse9eywt5566
Tags: 2.4.14-0ubuntu1
[ Steve Langasek ]
* New upstream version
  - Fixes a bug with the pcache overlay not returning cached entries
    (closes: #497697)
  - Update evolution-ntlm patch to apply to current Makefiles.
  - (tentatively) drop gnutls-ciphers, since this bug was reported to be
    fixed upstream in 2.4.8.  The fix applied in 2.4.8 didn't match the
    patch from the bug report, so this should be watched for regressions.
* Build against db4.7 instead of db4.2 at last!  Closes: #421946.
* Build with --disable-ndb, to avoid a misbuild when libmysqlclient is
  installed in the build environment.
* New patch, no-crlcheck-for-gnutls, to fix a build failure when using
  --with-tls=gnutls.

[ Mathias Gug ]
* Merge from debian unstable, remaining changes:
  - debian/apparmor-profile: add AppArmor profile
  - debian/slapd.postinst: Reload AA profile on configuration
  - updated debian/slapd.README.Debian for note on AppArmor
  - debian/control: Recommends apparmor >= 2.1+1075-0ubuntu6
  - debian/control: Conflicts with apparmor-profiles << 2.1+1075-0ubuntu4
    to make sure that if earlier version of apparmour-profiles gets
    installed it won't overwrite our profile.
  - Modify Maintainer value to match the DebianMaintainerField
    speficication.
  - follow ApparmorProfileMigration and force apparmor compalin mode on 
    some upgrades (LP: #203529)
  - debian/slapd.dirs: add etc/apparmor.d/force-complain
  - debian/slapd.preinst: create symlink for force-complain on pre-feisty
    upgrades, upgrades where apparmor-profiles profile is unchanged (ie
    non-enforcing) and upgrades where apparmor profile does not exist.
  - debian/slapd.postrm: remove symlink in force-complain/ on purge
  - debian/patches/fix-ucred-libc due to changes how newer glibc handle
    the ucred struct now.
  - debian/control:
    - Build-depend on libltdl7-dev rather then libltdl3-dev.
  - debian/patches/autogen.sh:
    - Call libtoolize with the --install option to install config.{guess,sub}
      files.
  - Don't use local statement in config script as it fails if /bin/sh
    points to bash (LP: #286063).
  - Disable the testsuite on hppa. Allows building of packages on this
    architecture again, once this package is in the archive.
    LP: #288908.
  - debian/slapd.postinst, debian/slapd.script-common: set correct ownership
    and permissions on /var/lib/ldap, /etc/ldap/slapd.d (group readable) and
    /var/run/slapd (world readable). (LP: #257667).
  - debian/patches/nssov-build, debian/rules: 
    Build and package the nss overlay.
    debian/schema/misc.ldif: add ldif file for the misc schema, which defines
    rfc822MailMember (required by the nss overlay).
  - debian/{control,rules}: enable PIE hardening
  - Use cn=config as the default configuration backend instead of 
    slapd.conf. Migrate slapd.conf  file to /etc/ldap/slapd.d/ on upgrade
    asking the end user to enter a new password to control the access to the
    cn=config tree.
* debian/patches/corrupt-contextCSN: The contextCSN can get corrupted at
  times. (ITS: #5947)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Perl 5.10 (and some earlier versions) require calling some additional
 
2
macros around Perl interpreter setup and shutdown.  Not doing these
 
3
calls causes problems on HPPA at least, and may affect other platforms
 
4
in the future.  This patch adds the additional code modelled on the
 
5
perlembed man page and a working patch for INN.
 
6
 
 
7
Debian Bug#495069
 
8
ITS #5658
 
9
 
 
10
--- openldap.orig/servers/slapd/back-perl/close.c
 
11
+++ openldap/servers/slapd/back-perl/close.c
 
12
@@ -30,6 +30,9 @@
 
13
 {
 
14
        perl_destruct(PERL_INTERPRETER);
 
15
        perl_free(PERL_INTERPRETER);
 
16
+#ifdef PERL_SYS_TERM
 
17
+       PERL_SYS_TERM();
 
18
+#endif
 
19
        PERL_INTERPRETER = NULL;
 
20
 
 
21
        ldap_pvt_thread_mutex_destroy( &perl_interpreter_mutex );       
 
22
--- openldap.orig/servers/slapd/back-perl/init.c
 
23
+++ openldap/servers/slapd/back-perl/init.c
 
24
@@ -37,6 +37,7 @@
 
25
 )
 
26
 {
 
27
        char *embedding[] = { "", "-e", "0" };
 
28
+       int argc = 3;
 
29
 
 
30
        bi->bi_open = NULL;
 
31
        bi->bi_config = 0;
 
32
@@ -77,9 +78,15 @@
 
33
        
 
34
        ldap_pvt_thread_mutex_init( &perl_interpreter_mutex );
 
35
 
 
36
+#ifdef PERL_SYS_INIT3
 
37
+       PERL_SYS_INIT3(&argc, &embedding, (char **)NULL);
 
38
+#endif
 
39
        PERL_INTERPRETER = perl_alloc();
 
40
        perl_construct(PERL_INTERPRETER);
 
41
-       perl_parse(PERL_INTERPRETER, perl_back_xs_init, 3, embedding, (char **)NULL);
 
42
+#ifdef PERL_EXIT_DESTRUCT_END
 
43
+       PL_exit_flags |= PERL_EXIT_DESTRUCT_END;
 
44
+#endif
 
45
+       perl_parse(PERL_INTERPRETER, perl_back_xs_init, argc, embedding, (char **)NULL);
 
46
        perl_run(PERL_INTERPRETER);
 
47
        return 0;
 
48
 }