~ubuntu-branches/ubuntu/maverick/pitivi/maverick

« back to all changes in this revision

Viewing changes to debian/patches/01_disable-devel-mode.patch

  • Committer: Bazaar Package Importer
  • Author(s): Robert Ancell
  • Date: 2010-06-01 13:49:39 UTC
  • mfrom: (6.1.5 sid)
  • Revision ID: james.westby@ubuntu.com-20100601134939-2d77sie8w7vmnlln
Tags: 0.13.4-2ubuntu1
* Resync on Debian unstable, remaining Ubuntu changes:
* debian/control:
  - Add Vcs-Bzr link
  - Build-depend on python-launchpad-integration
* 01_lpi.patch:
  - Add lauchpad integration
* debian/patches/02_remove_version_from_title.patch:
  - Removes versio from title
* debian/patches/lp537619_gdk_cairo_reset_clip.patch:
  - Use correct parameters for gtk.gdk.CairoContext.reset_clip.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- pitivi-0.13.3.orig/bin/pitivi.in    2009-12-17 00:22:50.000000000 +0100
 
2
+++ pitivi-0.13.3/bin/pitivi.in 2009-12-17 00:43:42.000000000 +0100
 
3
@@ -32,29 +32,17 @@
 
4
 
 
5
 localedir = ""
 
6
 
 
7
-# Check if we're in development or installed version
 
8
 # Add the path of pitivi stuff
 
9
 # TODO : change it when it's finally in cvs
 
10
 
 
11
 def _get_root_dir():
 
12
     return '/'.join(os.path.dirname(os.path.abspath(__file__)).split('/')[:-1])
 
13
 
 
14
-def _in_devel():
 
15
-    rd = _get_root_dir()
 
16
-    return (os.path.exists(os.path.join(rd, '.svn')) or
 
17
-            os.path.exists(os.path.join(rd, 'CVS')) or
 
18
-            os.path.exists(os.path.join(rd, '.git')))
 
19
-
 
20
 def _add_pitivi_path():
 
21
     global localedir
 
22
     dir = os.path.dirname(os.path.abspath(__file__))
 
23
-    root = None
 
24
-    if _in_devel():
 
25
-        root = os.path.split(dir)[0]
 
26
-        localedir = os.path.join(os.path.split(dir)[0], 'locale')
 
27
-    else:
 
28
-        root = os.path.join(LIBDIR, 'pitivi', 'python')
 
29
-        localedir = "@DATADIR@/locale"
 
30
+    root = os.path.join(LIBDIR, 'pitivi', 'python')
 
31
+    localedir = "@DATADIR@/locale"
 
32
 
 
33
     if not root in sys.path:
 
34
         sys.path.insert(0, root)