~ubuntu-branches/ubuntu/maverick/pm-utils/maverick

« back to all changes in this revision

Viewing changes to debian/patches/90-nm-proper-wakeup.patch

  • Committer: Bazaar Package Importer
  • Author(s): Michael Biebl, Michael Biebl, Martin Pitt
  • Date: 2010-07-13 16:24:27 UTC
  • mfrom: (40.1.2 experimental)
  • Revision ID: james.westby@ubuntu.com-20100713162427-vpmf1kkj79e715j0
Tags: 1.4.1-1
[ Michael Biebl ]
* New upstream release. (Closes: #588587)
  The main improvement is that this ships some generally useful power
  management hooks by default. Note that this conflicts with similar
  packages such as laptop-mode-tools or pm-utils-powersave-policy, so you
  should not enable them and pm-utils at the same time.
  Current hooks when switching to battery:
  - [disable_wol] Disable Wake-on-LAN on ethernet cards
  - [hal-cd-polling] Disable HAL's polling of CD drives for automounting
    them. Note that this HAL functionality is already obsolete in Debian's
    current GNOME, but still being used in current KDE and XFCE desktops.
  - [harddrive] More aggressive harddrive spindown times
  - [intel-audio-powersave] Put ac97 and hda cards to sleep when inactive.
  - [journal-commit, xfs_buffer] Delay ext[34]/ext journal/metadata
    writeback
  - [laptop-mode] Delay hard disk writeback times of dirty caches, to avoid
    spin ups
  - [pcie_aspm] PCI express cards power saving
  - [readahead] More speculative readahead, at the expense of using more
    memory
  - [sata_alpm] Enable SATA link power management
  - [sched-powersave] Try to use fewer cores on multi-core machines
  - [wireless] Reduce RX/TX power when idle on some known-working drivers
    (various Intel chips for now)
* video-quirks/*
  - Update quirks to latest upstream release pm-quirks-20100619.
* Drop patches applied upstream
  - debian/patches/05-inspiron-8600-ati-quirk.patch
  - debian/patches/08-fix-lock-file-handling.patch
  - debian/patches/12-man-page-fixes.patch
* Refresh and update all patches so they apply cleanly.
* debian/control
  - Demote radeontool to Suggests. The standard Debian/Ubuntu kernels use
    KMS for radeon which makes this tool obsolete. (Closes: #588768)

[ Martin Pitt ]
* debian/control: Add hdparm Recommends and ethtool/wireless-tools Suggests,
  for the newly added power saving hooks.
* debian/control: Conflicts/Replaces: pm-utils-powersave-policy, superseded
  by the now integrated power.d hooks.

Show diffs side-by-side

added added

removed removed

Lines of Context:
2
2
 pm/sleep.d/55NetworkManager |    8 ++++----
3
3
 1 file changed, 4 insertions(+), 4 deletions(-)
4
4
 
5
 
Index: pm-utils-1.2.2.4/pm/sleep.d/55NetworkManager
 
5
Index: pm-utils/pm/sleep.d/55NetworkManager
6
6
===================================================================
7
 
--- pm-utils-1.2.2.4.orig/pm/sleep.d/55NetworkManager
8
 
+++ pm-utils-1.2.2.4/pm/sleep.d/55NetworkManager
9
 
@@ -6,29 +6,29 @@
10
 
 #       not break established connections.  Apple can do this, and it is
11
 
 #       rather nifty.
12
 
 
13
 
 . "${PM_FUNCTIONS}"
14
 
 
15
 
 suspend_nm()
 
7
--- pm-utils.orig/pm/sleep.d/55NetworkManager   2010-06-18 15:19:18.000000000 +0200
 
8
+++ pm-utils/pm/sleep.d/55NetworkManager        2010-06-18 16:16:09.056074013 +0200
 
9
@@ -12,7 +12,7 @@
16
10
 {
17
11
        # Tell NetworkManager to shut down networking
 
12
         printf "Having NetworkManager put all interaces to sleep..."
18
13
-       dbus_send --system                         \
19
14
+       dbus_send --print-reply --system                         \
20
15
                --dest=org.freedesktop.NetworkManager  \
21
16
                /org/freedesktop/NetworkManager        \
22
 
-               org.freedesktop.NetworkManager.sleep
23
 
+               org.freedesktop.NetworkManager.sleep 2>&1 > /dev/null
24
 
 }
25
 
 
26
 
 resume_nm()
 
17
                org.freedesktop.NetworkManager.sleep && \
 
18
@@ -23,7 +23,7 @@
27
19
 {
28
20
        # Wake up NetworkManager and make it do a new connection
29
 
-       dbus_send --system                        \
30
 
+       dbus_send --print-reply --system                        \
 
21
        printf "Having NetworkManager wake interfaces back up..."
 
22
-        dbus_send --system                        \
 
23
+        dbus_send --print-reply --system                        \
31
24
                --dest=org.freedesktop.NetworkManager \
32
25
                /org/freedesktop/NetworkManager       \
33
 
-               org.freedesktop.NetworkManager.wake
34
 
+               org.freedesktop.NetworkManager.wake 2>&1 > /dev/null
35
 
 }
36
 
 
37
 
 case "$1" in
38
 
        hibernate|suspend)
39
 
                suspend_nm
40
 
                ;;
41
 
        thaw|resume)
42
 
                resume_nm
 
26
                org.freedesktop.NetworkManager.wake && \