~ubuntu-branches/ubuntu/maverick/speech-tools/maverick

« back to all changes in this revision

Viewing changes to debian/patches/stats_EST_DProbDist.cc.diff

  • Committer: Bazaar Package Importer
  • Author(s): Kumar Appaiah, Kartik Mistry, Kumar Appaiah
  • Date: 2010-07-17 11:32:04 UTC
  • mfrom: (3.1.6 sid)
  • Revision ID: james.westby@ubuntu.com-20100717113204-mnse3jo236j107q8
Tags: 1:2.0.95~beta-1
[ Kartik Mistry ]
* debian/control:
  + [Lintian] Added missing ${misc:Depends}
  + Updated Standards-Version to 3.8.4 (no changes needed)
* debian/patches/const_char.diff:
  + Added missing patch header
* Removed unused patch invalid_const_char_conversion_fixes.diff

[ Kumar Appaiah ]
* New upstream release.
* Standards Version is now 3.9.0 (No changes needed)
* Update debian/rules to specify version numbers.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
This patch is part of a series of patches for speech-tools for
2
2
Debian GNU/Linux, which primarily fix build errors with GCC 4.3 and newer.
3
3
 
4
 
--- speech-tools-1.2.96~beta.orig/stats/EST_DProbDist.cc
5
 
+++ speech-tools-1.2.96~beta/stats/EST_DProbDist.cc
6
 
@@ -310,7 +310,7 @@
7
 
     if (type == tprob_discrete)
8
 
        return 0;
9
 
     else
10
 
-       return (int)scounts.list.head();
11
 
+       return (long)scounts.list.head();
12
 
 }
13
 
 
14
 
 int EST_DiscreteProbDistribution::item_end(int idx) const
15
 
@@ -326,7 +326,7 @@
16
 
     if (type == tprob_discrete)
17
 
        return ++idx;
18
 
     else
19
 
-       return (int)next((EST_Litem *)idx);
20
 
+       return (long)next((EST_Litem *)idx);
21
 
 }
22
 
 
23
 
 const EST_String &EST_DiscreteProbDistribution::item_name(int idx) const
 
4
Index: speech-tools-2.0.95~beta/stats/EST_DProbDist.cc
 
5
===================================================================
 
6
--- speech-tools-2.0.95~beta.orig/stats/EST_DProbDist.cc        2006-10-05 12:45:39.000000000 -0500
 
7
+++ speech-tools-2.0.95~beta/stats/EST_DProbDist.cc     2010-07-17 09:15:15.000000000 -0500
 
8
@@ -372,7 +372,7 @@
 
9
     if (type == tprob_discrete)
 
10
        return NULL;
 
11
     else
 
12
-       return scounts.list.head();
 
13
+        return scounts.list.head();
 
14
 }
 
15
 
 
16
 int EST_DiscreteProbDistribution::item_end(EST_Litem *idx) const
 
17
@@ -388,7 +388,7 @@
 
18
     if (type == tprob_discrete)
 
19
        return (EST_Litem *)(((unsigned char *)idx)+1);
 
20
     else
 
21
-       return next(idx);
 
22
+        return next(idx);
 
23
 }
 
24
 
 
25
 const EST_String &EST_DiscreteProbDistribution::item_name(EST_Litem *idx) const