~ubuntu-branches/ubuntu/maverick/tomboy/maverick

« back to all changes in this revision

Viewing changes to debian/patches/06_use_ubuntu_sso.patch

  • Committer: Bazaar Package Importer
  • Author(s): Rodrigo Moya
  • Date: 2010-09-08 12:03:27 UTC
  • Revision ID: james.westby@ubuntu.com-20100908120327-obdsbsks82r5dtdp
Tags: 1.3.2-1ubuntu4
* debian/patches/06_use_ubuntu_sso.patch:
  - Add .config file to do the correct ddlmap'ing
* debian/control:
  - Remove explicit dependency on libsyncdaemon-1.0-1

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
diff --git a/Tomboy/Addins/WebSyncService/Makefile.am b/Tomboy/Addins/WebSyncService/Makefile.am
2
 
index d50eadb..2699865 100644
 
2
index d50eadb..8abc3d4 100644
3
3
--- a/Tomboy/Addins/WebSyncService/Makefile.am
4
4
+++ b/Tomboy/Addins/WebSyncService/Makefile.am
5
5
@@ -27,6 +27,8 @@ CSFILES = \
11
11
        $(srcdir)/Tests/*.cs                    \
12
12
        $(srcdir)/Api/*.cs                  \
13
13
        $(srcdir)/Api/Tests/*.cs            \
 
14
@@ -47,7 +49,8 @@ $(TARGET): $(CSFILES) $(TOMBOY_EXE_PATH)
 
15
 addinsdir = $(pkglibdir)/addins
 
16
 addins_DATA =                  \
 
17
        $(TARGET)               \
 
18
-       $(TARGET).mdb
 
19
+       $(TARGET).mdb           \
 
20
+       WebSyncServiceAddin.dll.config
 
21
 
 
22
 EXTRA_DIST =                   \
 
23
        $(CSFILES) \
14
24
diff --git a/Tomboy/Addins/WebSyncService/U1SyncPreferencesWidget.cs b/Tomboy/Addins/WebSyncService/U1SyncPreferencesWidget.cs
15
25
new file mode 100644
16
26
index 0000000..0c88ec1
556
566
+               <SyncServiceAddin type="Tomboy.WebSync.U1SyncServiceAddin" />
557
567
+       </Extension>
558
568
 </Addin>
 
569
diff --git a/Tomboy/Addins/WebSyncService/WebSyncServiceAddin.dll.config b/Tomboy/Addins/WebSyncService/WebSyncServiceAddin.dll.config
 
570
new file mode 100644
 
571
index 0000000..91fc201
 
572
--- /dev/null
 
573
+++ b/Tomboy/Addins/WebSyncService/WebSyncServiceAddin.dll.config
 
574
@@ -0,0 +1,5 @@
 
575
+<configuration>
 
576
+  <dllmap dll="gobject-2.0" target="libgobject-2.0.so.0"/>
 
577
+  <dllmap dll="syncdaemon-1.0" target="libsyncdaemon-1.0.so.1"/>
 
578
+  <dllmap dll="proxy" target="libproxy.so.0"/>
 
579
+</configuration>