~ubuntu-branches/ubuntu/maverick/uim/maverick

« back to all changes in this revision

Viewing changes to debian/patches/99_dlopen_filefix.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Masahito Omote
  • Date: 2004-06-18 19:32:34 UTC
  • Revision ID: james.westby@ubuntu.com-20040618193234-ljro97hmg52dsnt7
Tags: 1:0.3.9-1
* New upstream release
* debian/rules: Add --without-m17nlib in configure.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh -e
 
2
## 99_dlopen_filefix.dpatch by Masahito Omote <omote@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: No description.
 
6
 
 
7
if [ $# -lt 1 ]; then
 
8
    echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
 
9
    exit 1
 
10
fi
 
11
 
 
12
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
 
13
patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
 
14
 
 
15
case "$1" in
 
16
    -patch) patch -p1 ${patch_opts} < $0;;
 
17
    -unpatch) patch -R -p1 ${patch_opts} < $0;;
 
18
    *)
 
19
        echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
 
20
        exit 1;;
 
21
esac
 
22
 
 
23
exit 0
 
24
 
 
25
@DPATCH@
 
26
diff -urNad /home/omote/debian/debian-official/inputmethod/uim/debian/uim-0.3.0.1/uim/anthy.c uim-0.3.0.1/uim/anthy.c
 
27
--- /home/omote/debian/debian-official/inputmethod/uim/debian/uim-0.3.0.1/uim/anthy.c   2004-02-24 00:58:32.000000000 +0900
 
28
+++ uim-0.3.0.1/uim/anthy.c     2004-02-24 00:59:40.000000000 +0900
 
29
@@ -9,8 +9,8 @@
 
30
   #define LIBANTHY_SO    "libanthy.dylib"
 
31
   #define LIBANTHYDIC_SO "libanthydic.dylib"
 
32
 #else
 
33
-  #define LIBANTHY_SO    "libanthy.so"
 
34
-  #define LIBANTHYDIC_SO "libanthydic.so"
 
35
+  #define LIBANTHY_SO    "libanthy.so.0"
 
36
+  #define LIBANTHYDIC_SO "libanthydic.so.0"
 
37
 
 
38
 #endif /*__APPLE__*/
 
39
 
 
40
diff -urNad /home/omote/debian/debian-official/inputmethod/uim/debian/uim-0.3.0.1/uim/canna.c uim-0.3.0.1/uim/canna.c
 
41
--- /home/omote/debian/debian-official/inputmethod/uim/debian/uim-0.3.0.1/uim/canna.c   2004-02-24 00:58:32.000000000 +0900
 
42
+++ uim-0.3.0.1/uim/canna.c     2004-02-24 00:59:46.000000000 +0900
 
43
@@ -64,7 +64,7 @@
 
44
 #include "context.h"
 
45
 
 
46
 #define MAX_CONTEXT 256
 
47
-#define LIBCANNA_SO    "libcanna.so"
 
48
+#define LIBCANNA_SO    "libcanna.so.1"
 
49
 
 
50
 #define BUFSIZE 1024
 
51