~ubuntu-branches/ubuntu/maverick/wildmidi/maverick

« back to all changes in this revision

Viewing changes to debian/patches/07_invalid-free.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastian Dröge
  • Date: 2010-05-11 06:31:11 UTC
  • Revision ID: james.westby@ubuntu.com-20100511063111-2a4vv5u5kg06xcz7
Tags: 0.2.2-3
* debian/libwildmidi0.symbols,
  debian/patches/08_export-symbols-regex.patch,
  debian/patches/99_autoreconf.patch:
  + Add export symbols regex to only export symbols that should be exported.
* debian/patches/07_invalid-free.patch:
  + Patch by Benjamin Otte to fix an invalid free.
    https://bugzilla.gnome.org/show_bug.cgi?id=618247
* debian/source/format,
  debian/rules:
  + Switch to source format 3.0 (quilt).
* debian/rules:
  + Generate correct shlibs file and fail the build if the symbols file
    is wrong.
* debian/control:
  + Update Standards-Version to 3.8.4.
  + Line-wrap control fields.
  + Add ${misc:Depends} to the -dev package.
  + Make shared library package dependency of the -dev package
    more strict to fix a lintian warning.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: src/wildmidi_lib.c
 
2
===================================================================
 
3
--- wildmidi/src/wildmidi_lib.c (revision 39)
 
4
+++ wildmidi/src/wildmidi_lib.c (working copy)
 
5
@@ -3488,7 +3488,6 @@
 
6
                first_handle->next = NULL;
 
7
        } else {
 
8
                tmp_handle = first_handle;
 
9
-                       free(tmp_trackdata);
 
10
                if (tmp_handle->next != NULL) {
 
11
                        while (tmp_handle->next != NULL)
 
12
                                tmp_handle = tmp_handle->next;
 
13
@@ -3496,6 +3495,7 @@
 
14
                tmp_handle->next = malloc(sizeof(struct _hndl));
 
15
                if (tmp_handle->next == NULL) {
 
16
                        WM_ERROR(__FUNCTION__, __LINE__, WM_ERR_MEM," to parse midi data", errno);
 
17
+                       free(tmp_trackdata);
 
18
                        free(mdi->data);
 
19
                        free(mdi);
 
20
                        return NULL;
 
21