~ubuntu-branches/ubuntu/maverick/xchat/maverick

« back to all changes in this revision

Viewing changes to debian/patches/72_fix_connect_button.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Andres Rodriguez
  • Date: 2009-08-04 15:47:54 UTC
  • Revision ID: james.westby@ubuntu.com-20090804154754-tdaq07kpjv3fammc
Tags: 2.8.6-4ubuntu2
* debian/patches/72_fix_connect_button.dpatch: Fixes 'C_onnect' button on 
  'Network List' dialog. (LP: #409024)
* debian/control: Updated Maintainer field to match Ubuntu Developers.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 72_fix_connect_button.dpatch by Andres Rodriguez <andreserl@ubuntu.com>
 
3
##
 
4
## Ubuntu: https://bugs.launchpad.net/ubuntu/+source/xchat/+bug/409024
 
5
## Upstream: https://bugzilla.redhat.com/show_bug.cgi?id=512034#attach_353926
 
6
## Patch: https://bugzilla.redhat.com/attachment.cgi?id=354251
 
7
## DP: Fixes 'C_onnect' button showed on 'Network List' dialog.
 
8
 
 
9
@DPATCH@
 
10
diff -urNad xchat-2.8.6~/src/fe-gtk/gtkutil.c xchat-2.8.6/src/fe-gtk/gtkutil.c
 
11
--- xchat-2.8.6~/src/fe-gtk/gtkutil.c   2008-06-08 02:52:42.000000000 -0500
 
12
+++ xchat-2.8.6/src/fe-gtk/gtkutil.c    2009-08-04 15:10:28.235049658 -0500
 
13
@@ -376,6 +376,7 @@
 
14
        {
 
15
                gtk_button_set_label (GTK_BUTTON (wid), labeltext);
 
16
                gtk_button_set_image (GTK_BUTTON (wid), gtk_image_new_from_stock (stock, GTK_ICON_SIZE_MENU));
 
17
+               gtk_button_set_use_underline (GTK_BUTTON (wid), TRUE);
 
18
                if (box)
 
19
                        gtk_container_add (GTK_CONTAINER (box), wid);
 
20
        }