~ubuntu-branches/ubuntu/maverick/xchat/maverick

« back to all changes in this revision

Viewing changes to debian/patches/99_ubuntu-fix_implicit_declaration.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Lorenzo De Liso
  • Date: 2010-06-09 15:29:05 UTC
  • mfrom: (2.1.6 sid)
  • Revision ID: james.westby@ubuntu.com-20100609152905-nuxvjl7pfanxogco
Tags: 2.8.6-6ubuntu1
* Merge from debian unstable (LP: #591714), remaining changes:
  - debian/patches:
    + 00list: Refreshed.
    + 01_serverlist.dpatch: Numerous changes to default serverlist.
    + 02_ubuntu_default_server.dpatch: select "Ubuntu servers" by default.
    + 37_lpi.dpatch: Add launchpad integration.
    + 38_autoconf.dpatch: Autoconf modifications for launchpad integration.
    + 45_brand_ctcp_version: Add Ubuntu brand to CTCP version response.
    + 53_fix_deprecated_widgets.dpatch: Fix FTBFS errors due to new GTK 2.20
      widgets names. Patch taken from Debian.
    + 70_notification_strings_shorten.dpatch: Shorten notification strings.
    + 71_notification_icon_change.dpatch: Use nicer icon for notifications.
  - debian/control:
    + Build-depend on libgtk2.0-dev (>= 2.10.0).
    + Build-depend on liblaunchpad-integration-dev.
    + Remove conflict/replaces on xchat-gnome.
    + Updated Maintainer field to match Ubuntu Developers.
  - debian/rules:
    + Make build independent of the python version.
  - debian/patches/45_ctcp_version_less_information.dpatch: 
    + Renamed to debian/patches/45_brand_ctcp_version.dpatch
    + Added short description.
* Dropped changes:
  - 72_fix_connect_button.dpatch: Replaced with 50_fix_connect.dpatch from
    debian
  - 73_freenode_ircd-seven.dpatch: Replaced with 51_freenode_ircd-seven.dpatch
    from debian
  - 99_ubuntu-fix_implicit_declaration.dpatch: Replaced with 52_fix_implicit_declaration.dpatch
    from debian
  - debian/rules: XCHATSHAREDIR, fixes the FTBFS.
 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 99_fix_implicit_declaration.dpatch by Fabrice Coutadeur <fabricesp@ubuntu.com>
3
 
##
4
 
## Origin: http://lists.opensuse.org/opensuse-commit/2009-07/msg00981.html
5
 
## Description: Fix "implicitly converted to pointer at ignoregui.c:192" error.
6
 
## This fixes a FTBFS in ia64 and amd64
7
 
 
8
 
@DPATCH@
9
 
diff -urNad xchat-2.8.6~/src/fe-gtk/ignoregui.c xchat-2.8.6/src/fe-gtk/ignoregui.c
10
 
--- xchat-2.8.6~/src/fe-gtk/ignoregui.c 2010-01-15 19:15:11.193846344 +0000
11
 
+++ xchat-2.8.6/src/fe-gtk/ignoregui.c  2010-01-15 19:18:24.222593849 +0000
12
 
@@ -38,6 +38,7 @@
13
 
 #include <gtk/gtkliststore.h>
14
 
 #include <gtk/gtktreeview.h>
15
 
 #include <gtk/gtktreeselection.h>
16
 
+#include <gtk/gtkcelllayout.h>
17
 
 #include <gtk/gtkcellrenderertext.h>
18
 
 #include <gtk/gtkcellrenderertoggle.h>
19
 
 
20
 
@@ -189,7 +190,7 @@
21
 
        for (col_id=0; (col = gtk_tree_view_get_column (GTK_TREE_VIEW (view), col_id));
22
 
             col_id++)
23
 
        {
24
 
-               GList *list = gtk_tree_view_column_get_cell_renderers (col);
25
 
+               GList *list = gtk_cell_layout_get_cells (GTK_CELL_LAYOUT (col));
26
 
                GList *tmp;
27
 
 
28
 
                for (tmp = list; tmp; tmp = tmp->next)