~ubuntu-branches/ubuntu/natty/alsa-lib/natty

« back to all changes in this revision

Viewing changes to debian/patches/Add-config-file-for-SB-XFi-driver.patch

  • Committer: Bazaar Package Importer
  • Author(s): Luke Yelavich
  • Date: 2009-11-04 19:04:11 UTC
  • mfrom: (1.1.12 upstream) (2.2.4 squeeze)
  • Revision ID: james.westby@ubuntu.com-20091104190411-igse8f4bzca8dq5x
Tags: 1.0.21a-1ubuntu1
* Merge from debian unstable, remaining changes:
  - debian/rules:
    + Don't bail when removing include/alsa
  - debian/control: Add Vcs-Bzr URI
  - Add configuration files for bluetooth/bluez-alsa and pulseaudio
  - debian/libasound2.install: Ship smixer plugins for native and bi-arch
    packages
  - drop libcxxtools-dev build dependency, its in universe
  - debian/patches/Fix-fpe-snd_pcm_mmap_begin.patch: Handle attempts to
    divide by zero

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 29841e67e945ce87c0ef767bda9a90cc4af3d562 Mon Sep 17 00:00:00 2001
2
 
From: Takashi Iwai <tiwai@suse.de>
3
 
Date: Tue, 2 Jun 2009 16:08:57 +0200
4
 
Subject: [PATCH] Add config file for SB-XFi driver
5
 
 
6
 
Signed-off-by: Takashi Iwai <tiwai@suse.de>
7
 
---
8
 
 src/conf/cards/Makefile.am |    1 +
9
 
 src/conf/cards/SB-XFi.conf |   86 ++++++++++++++++++++++++++++++++++++++++++++
10
 
 2 files changed, 87 insertions(+), 0 deletions(-)
11
 
 create mode 100644 src/conf/cards/SB-XFi.conf
12
 
 
13
 
Index: alsa-lib-1.0.20/src/conf/cards/Makefile.am
14
 
===================================================================
15
 
--- alsa-lib-1.0.20.orig/src/conf/cards/Makefile.am     2009-05-06 03:07:23.000000000 -0400
16
 
+++ alsa-lib-1.0.20/src/conf/cards/Makefile.am  2009-09-05 14:17:37.000000000 -0400
17
 
@@ -41,6 +41,7 @@
18
 
        RME9636.conf \
19
 
        RME9652.conf \
20
 
        SI7018.conf \
21
 
+       SB-XFi.conf \
22
 
        TRID4DWAVENX.conf \
23
 
        USB-Audio.conf \
24
 
        YMF744.conf \
25
 
Index: alsa-lib-1.0.20/src/conf/cards/SB-XFi.conf
26
 
===================================================================
27
 
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
28
 
+++ alsa-lib-1.0.20/src/conf/cards/SB-XFi.conf  2009-09-05 14:17:56.000000000 -0400
29
 
@@ -0,0 +1,86 @@
30
 
+#
31
 
+# Configuration for the SB X-Fi driver
32
 
+#
33
 
+
34
 
+<confdir:pcm/front.conf>
35
 
+
36
 
+SB-XFi.pcm.front.0 {
37
 
+       @args [ CARD ]
38
 
+       @args.CARD {
39
 
+               type string
40
 
+       }
41
 
+       type hw
42
 
+       card $CARD
43
 
+       device 0
44
 
+}      
45
 
+
46
 
+<confdir:pcm/rear.conf>
47
 
+
48
 
+SB-XFi.pcm.rear.0 {
49
 
+       @args [ CARD ]
50
 
+       @args.CARD {
51
 
+               type string
52
 
+       }
53
 
+       type hw
54
 
+       card $CARD
55
 
+       device 1
56
 
+}      
57
 
+
58
 
+<confdir:pcm/center_lfe.conf>
59
 
+
60
 
+SB-XFi.pcm.center_lfe.0 {
61
 
+       @args [ CARD ]
62
 
+       @args.CARD {
63
 
+               type string
64
 
+       }
65
 
+       type hw
66
 
+       card $CARD
67
 
+       device 2
68
 
+}      
69
 
+
70
 
+<confdir:pcm/side.conf>
71
 
+
72
 
+SB-XFi.pcm.side.0 {
73
 
+       @args [ CARD ]
74
 
+       @args.CARD {
75
 
+               type string
76
 
+       }
77
 
+       type hw
78
 
+       card $CARD
79
 
+       device 3
80
 
+}      
81
 
+
82
 
+<confdir:pcm/surround40.conf>
83
 
+<confdir:pcm/surround41.conf>
84
 
+<confdir:pcm/surround50.conf>
85
 
+<confdir:pcm/surround51.conf>
86
 
+<confdir:pcm/surround71.conf>
87
 
+
88
 
+SB-XFi.pcm.surround40.0 cards.SB-XFi.pcm.front.0
89
 
+SB-XFi.pcm.surround51.0 cards.SB-XFi.pcm.front.0
90
 
+SB-XFi.pcm.surround71.0 cards.SB-XFi.pcm.front.0
91
 
+
92
 
+<confdir:pcm/iec958.conf>
93
 
+
94
 
+SB-XFi.pcm.iec958.0 {
95
 
+       @args [ CARD AES0 AES1 AES2 AES3 ]
96
 
+       @args.CARD {
97
 
+               type string
98
 
+       }
99
 
+       @args.AES0 {
100
 
+               type integer
101
 
+       }
102
 
+       @args.AES1 {
103
 
+               type integer
104
 
+       }
105
 
+       @args.AES2 {
106
 
+               type integer
107
 
+       }
108
 
+       @args.AES3 {
109
 
+               type integer
110
 
+       }
111
 
+       type hw
112
 
+       card $CARD
113
 
+       device 4
114
 
+       # FIXME: AES status bits
115
 
+}
116
 
Index: alsa-lib-1.0.20/src/conf/cards/Makefile.in
117
 
===================================================================
118
 
--- alsa-lib-1.0.20.orig/src/conf/cards/Makefile.in     2009-09-05 14:17:37.000000000 -0400
119
 
+++ alsa-lib-1.0.20/src/conf/cards/Makefile.in  2009-09-05 14:17:37.000000000 -0400
120
 
@@ -192,7 +192,7 @@
121
 
        RME9636.conf RME9652.conf SI7018.conf TRID4DWAVENX.conf \
122
 
        USB-Audio.conf YMF744.conf VIA686A.conf VIA8233.conf \
123
 
        VIA8233A.conf VIA8237.conf VX222.conf VXPocket.conf \
124
 
-       VXPocket440.conf $(am__append_1)
125
 
+       VXPocket440.conf SB-XFi.conf $(am__append_1)
126
 
 alsa_DATA = $(cfg_files)
127
 
 @BUILD_ALISP_TRUE@SI7018dir = $(alsaconfigdir)/cards/SI7018
128
 
 @BUILD_ALISP_FALSE@SI7018_files =