~ubuntu-branches/ubuntu/natty/alsa-utils/natty

« back to all changes in this revision

Viewing changes to debian/patches/unset_pulse_internal.patch

  • Committer: Bazaar Package Importer
  • Author(s): Luke Yelavich, Daniel T Chen
  • Date: 2009-11-06 11:29:35 UTC
  • mfrom: (2.3.4 squeeze)
  • Revision ID: james.westby@ubuntu.com-20091106112935-stzy6l7u9auw6hm0
Tags: 1.0.21-1ubuntu1
* Merge from debian unstable, remaining changes:
  - debian/init:
    + wait until /usr/bin and /var/lib/alsa exist
    + only display an error when dealing with alsactl if there is no card
      specified
    + Set sane level for 'Speaker' and 'Headphone', needed for Dell Mini 9
      and Dell E series
    + ute PC Beep on hda cards that support it during initial volume setup
    + update lsb header to indicate no running of the script unless the
      udev rule is run
    + Mute *Analog/Digital Control for Creative cards by default
    + Default Digital Input Source to be Digital Mic 1 so that users
      with digital mic will be able to use it out of the box
    + Make use of lsb-functions/log calls
    + Mute "IEC958 Optical Raw" by default (LP: #408370)
  - debian/rules:
    + ship udev rules file in /lib/udev/rules.d
    + Do not install start symlinks for the alsa-utils init script, it gets
      run from a udev rule
  - debian/udev.script: do not use hotplug functions
  - debian/README.init.cs4236: Include in /usr/share/doc/alsa-utils so that
    users of snd-cs4236 (e.g., ThinkPad 600) can have audible sound
  - debian/patches/unset_pulse_internal.patch: We don't want alsamixer to
    show the pulse mixer by default, since it can be controlled from
    pulseaudio itself.
  - debian/patches/fix_misspelling_speaker-test_man_page.patch: Fix
    misspelling in speaker-test(1)
  - Set sane level for headphone 1 for Dell Studio XPS with 2.6.30.
  - Remove alsaconf from build system and remove po files

[ Daniel T Chen ]
"The beginning of the great initscript-sectomy"

* debian/alsa-mixer-save.upstart: Create an upstart job specifically
  saving mixer levels to resolve race (LP: #454265)
* debian/control: Version build-dep to upstart-aware debhelper.
* debian/init:
  + Revert all initscript changes in 1.0.20-2ubuntu[456]. They were
    crackful.
  + Restore more sane behavior/compatibility with 8.10 by not mucking
    with sound card state if alsactl restore fails.
  + Don't wait for 1 second after alsactl store, which already is
    expensive. Also, if store is going to fail, this wait is useless.
* debian/preinst: Handle upgrades from upstart-unaware versions.
* debian/rules: Move the former initscript into /sbin. We now have an
  upstart job just for handling alsactl store.
* debian/NOTES:
  debian/README.Debian:
  debian/modprobe-post-install-part:
  debian/udev.script: Use the new script path.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: alsa-utils-1.0.20/alsamixer/alsamixer.c
2
 
===================================================================
3
 
--- alsa-utils-1.0.20.orig/alsamixer/alsamixer.c        2009-05-06 03:07:24.000000000 -0400
4
 
+++ alsa-utils-1.0.20/alsamixer/alsamixer.c     2009-09-04 22:01:31.000000000 -0400
5
 
@@ -2293,6 +2293,10 @@
6
 
       char **argv)
7
 
 {
8
 
   int opt;
 
1
diff -urN alsa-utils-1.0.21/alsamixer/cli.c alsa-utils-1.0.21.new/alsamixer/cli.c
 
2
--- alsa-utils-1.0.21/alsamixer/cli.c   2009-09-01 01:13:36.000000000 +1000
 
3
+++ alsa-utils-1.0.21.new/alsamixer/cli.c       2009-11-05 15:58:15.000000000 +1100
 
4
@@ -120,6 +120,10 @@
 
5
        textdomain(PACKAGE);
 
6
 #endif
 
7
 
 
8
+       /* We don't want to control a pulseaudio mixer, since that can be done from
 
9
+        * pulseaudio itself. */
 
10
+       setenv("PULSE_INTERNAL", "0", 1);
9
11
+
10
 
+  /* We don't want to control a pulseaudio mixer, since that can be done from
11
 
+   * pulseaudio itself. */
12
 
+  setenv("PULSE_INTERNAL", "0", 1);
13
 
   
14
 
   /* parse args
15
 
    */
16
 
Index: alsa-utils-1.0.20/amixer/amixer.c
17
 
===================================================================
18
 
--- alsa-utils-1.0.20.orig/amixer/amixer.c      2009-05-06 03:07:24.000000000 -0400
19
 
+++ alsa-utils-1.0.20/amixer/amixer.c   2009-09-04 22:01:31.000000000 -0400
 
12
        parse_options(argc, argv);
 
13
 
 
14
        create_mixer_object(&selem_regopt);
 
15
diff -urN alsa-utils-1.0.21/amixer/amixer.c alsa-utils-1.0.21.new/amixer/amixer.c
 
16
--- alsa-utils-1.0.21/amixer/amixer.c   2009-09-01 01:13:36.000000000 +1000
 
17
+++ alsa-utils-1.0.21.new/amixer/amixer.c       2009-11-05 15:57:21.000000000 +1100
20
18
@@ -1892,6 +1892,11 @@
21
19
 {
22
20
        int morehelp, level = 0;
29
27
        static const struct option long_option[] =
30
28
        {
31
29
                {"help", 0, NULL, 'h'},
32
 
Index: alsa-utils-1.0.20/iecset/iecset.c
33
 
===================================================================
34
 
--- alsa-utils-1.0.20.orig/iecset/iecset.c      2009-05-06 03:07:24.000000000 -0400
35
 
+++ alsa-utils-1.0.20/iecset/iecset.c   2009-09-04 22:01:31.000000000 -0400
 
30
diff -urN alsa-utils-1.0.21/iecset/iecset.c alsa-utils-1.0.21.new/iecset/iecset.c
 
31
--- alsa-utils-1.0.21/iecset/iecset.c   2009-09-01 01:13:36.000000000 +1000
 
32
+++ alsa-utils-1.0.21.new/iecset/iecset.c       2009-11-05 15:57:22.000000000 +1100
36
33
@@ -324,6 +324,10 @@
37
34
        char tmpname[32];
38
35
        int parms[IDX_LAST];