~ubuntu-branches/ubuntu/natty/dsdo/natty

« back to all changes in this revision

Viewing changes to debian/patches/1005_improve-main-rules.patch

  • Committer: Bazaar Package Importer
  • Author(s): Jonas Smedegaard
  • Date: 2007-04-22 21:07:57 UTC
  • mfrom: (1.4.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20070422210757-mpb5arctjqcvyzwf
Tags: 1.4.60-1
* New upstream release.
* Update local cdbs snippets:
  + Replace auto-update.mk with (overload of) buildcore.mk.
  + Add upstream-tarball.mk adding get-orig-source rule and more.
  + Switch from simple-patchsys.mk to patchsys-quilt.mk.
  + Fix buildinfo.mk to run only once.
  + Divert bugreports only for non-Debian suites.
  + Look also for "(c)" in copyright-check.mk, and avoid non-printable
    characters.
  + Check copyrights in prebuild (in clean it may choke on not yet
    cleaned stuff), and make sure it runs only once.
  + List non-binary files affected if discovering new copyrights.
  + Add README.cdbs-tweaks documenting the added tweaks.
  + Advertise README.cdbs-tweaks in debian/rules.
* Fix watch file to use suffix tgz (not tar.gz).
* Bump standards-version to 3.7.2 (no changes needed).
* Update debian/copyright:
  + Change encoding to UTF-8 (was ISO8859-1).
* Have idanish and wdanish explicitly depend on debconf (apparently
  not handled by installdeb-* scripts as intended). Thanks to lintian.
* Duplicate clean rules (they are unpatched at clean time).
* Explicitly symlink myspell dicts to force non-country symlinks.
  Closes: bug#373738, thanks to Rene Engelhard.
* Semi-auto-update debian/control.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff -ruN dsdo-1.4.60.orig/Makefile dsdo-1.4.60/Makefile
 
2
--- dsdo-1.4.60.orig/Makefile   2007-04-22 22:05:46.000000000 +0200
 
3
+++ dsdo-1.4.60/Makefile        2007-04-22 22:13:46.000000000 +0200
 
4
@@ -12,37 +12,51 @@
 
5
 #-----------------------------------------------------------------------------
 
6
 # Build rules:
 
7
 
 
8
-all: words aspell ispell
 
9
+all: words new-aspell ispell myspell
 
10
 
 
11
 words: words-$(language_code)
 
12
 
 
13
 words-$(language_code): words-$(language_code).sq unsq
 
14
        ./unsq < words-$(language_code).sq > words-$(language_code)
 
15
+       ./unsq < words-$(language_code).excluded.sq > words-$(language_code).excluded
 
16
 
 
17
 aspell: words
 
18
        $(MAKE) -C aspell all
 
19
 
 
20
+new-aspell: words
 
21
+       $(MAKE) -C new_aspell all
 
22
+
 
23
 ispell: words
 
24
        $(MAKE) -C ispell all
 
25
 
 
26
+myspell: words
 
27
+       $(MAKE) -C myspell all
 
28
+
 
29
 #-----------------------------------------------------------------------------
 
30
 # Installation rules:
 
31
 
 
32
-install: install-words install-aspell install-ispell
 
33
+install: install-words install-new-aspell install-ispell
 
34
 
 
35
 install-words: words
 
36
 
 
37
 install-aspell: aspell
 
38
        $(MAKE) -C aspell install
 
39
 
 
40
+install-new-aspell: new-aspell
 
41
+       $(MAKE) -C new_aspell install
 
42
+
 
43
 install-ispell: ispell
 
44
        $(MAKE) -C ispell install
 
45
 
 
46
+install-myspell: myspell
 
47
+       $(MAKE) -C myspell install
 
48
+
 
49
 #-----------------------------------------------------------------------------
 
50
 # Cleanup rules:
 
51
 
 
52
 clean:
 
53
-       rm -f words-$(language_code)
 
54
+       rm -f words-$(language_code) words-$(language_code).excluded
 
55
        $(MAKE) -C aspell clean
 
56
+       $(MAKE) -C new_aspell clean
 
57
        $(MAKE) -C ispell clean
 
58
-
 
59
+       $(MAKE) -C myspell clean