~ubuntu-branches/ubuntu/natty/eucalyptus/natty-updates

« back to all changes in this revision

Viewing changes to debian/patches/18-priv_security.patch

  • Committer: Bazaar Package Importer
  • Author(s): Dave Walker (Daviey), Dave Walker (Daviey), Scott Moser
  • Date: 2010-08-04 06:36:06 UTC
  • mfrom: (1.1.39 upstream)
  • Revision ID: james.westby@ubuntu.com-20100804063606-fnf1qbymtg9yueaf
Tags: 2.0~bzr1218-0ubuntu1
[ Dave Walker (Daviey) ]
* New upstream merge, r1218
* debian/eucalyptus.conf:
  - Changed JVM_MEM to CLOUD_OPTS, as a standardised method.
  - Introduced new stub SC, adding ability to disable EBS and ISCSI.
  - Added to CC stub ability to disable tunnelling in multi-cluster deployments.
  - In NC section added various VIRTIO options with sane defaults.
  - Added hints for changing the resource allocation, making limiting and over
    provisioning easier to identify. (MAX_MEM, MAX_CORES & MAX_DISK).
* debian/control: 
  - eucalyptus-nc, Added Recommends libcrypt-openssl-(random,rsa,x509)-perl
  - eucalytpus-sc, Added Recommends tgt, open-iscsi
  - eucalyptus-java-common, Depend on libasm3-java rather than libasm2-java
* debian/eucalyptus-nc.install: Install upstream isci perl scripts
  - /usr/share/eucalyptus/{connect,disconnect,get}_iscsitarget.pl
* debian/eucalyptus-common.install: Install new upstream python tools:
  euca-{describe|(de)register}-walrus(es), euca-describe-properties
  euca-{add|delete|describe}-user(s), euca-get-credentials
  euca-{describe|(de)register}-cluster(s), euca-modify-property
  euca-{describe|(de)register}-storage-controller(s). (LP: #608773)
* debian/patches/:
  - 07-local_support_euca_conf-in.patch: Refactored to reflect upstream.   
  - 12-tools-euca_conf-8.patch: Dropped, applied upstream.
  - 13-tools_eucalyptus-conf-5.patch: Dropped, applied upstream.
  - 20-brute-force-webui.patch: Dropped, applied upstream.
* The binary resulting jar's have been renamed from eucalyptus-*-main.jar
  to eucalyptus-*-2.0.0.jar:
  - debian/eucalyptus-cc.upstart
  - debian/eucalyptus-cloud.install
  - debian/eucalyptus-common.eucalyptus.upstart
  - debian/eucalyptus-java-common.install
  - debian/eucalyptus-network.upstart
  - debian/eucalyptus-sc.install
  - debian/eucalyptus-walrus.install

[ Scott Moser ]
* Add support for booting multiboot images from a floppy (LP: #611144)

Show diffs side-by-side

added added

removed removed

Lines of Context:
3
3
Bug: https://launchpad.net/bugs/436977
4
4
--- a/util/euca_rootwrap.c
5
5
+++ b/util/euca_rootwrap.c
6
 
@@ -1,73 +1,218 @@
 
6
@@ -1,83 +1,218 @@
7
7
 /*
8
8
-Copyright (c) 2009  Eucalyptus Systems, Inc.   
9
9
+   Copyright (C) 2009 Canonical, Ltd.
77
77
-  WITHDRAWAL OF THE CODE CAPABILITY TO THE EXTENT NEEDED TO COMPLY WITH
78
78
-  ANY SUCH LICENSES OR RIGHTS.
79
79
 */
80
 
+#define _GNU_SOURCE
 
80
 #define _GNU_SOURCE
81
81
 #include <stdio.h>
82
82
 #include <stdlib.h>
83
83
+#include <string.h>
259
259
-    exit(1);
260
260
-  }
261
261
-  newargv = argv + 1;
262
 
-  exit(execvp(newargv[0], newargv));
 
262
-
 
263
-  if (setresuid((uid_t)0, (uid_t)0, (uid_t)0)) {
 
264
-      perror("setresuid");
 
265
-  }
 
266
-  
 
267
-  if (setresgid((gid_t)0, (gid_t)0, (gid_t)0)) {
 
268
-      perror("setresgid");
 
269
-  }
 
270
-  
 
271
-  exit(execv(newargv[0], newargv));
263
272
+int main(int argc, char *argv[])
264
273
+{
265
274
+    struct wrapper_command *cmd=NULL;