~ubuntu-branches/ubuntu/natty/firefox/natty-security

« back to all changes in this revision

Viewing changes to debian/patches/no-sps-profiler-on-unsupported-archs.patch

  • Committer: Package Import Robot
  • Author(s): Chris Coulson, Chris Coulson, Jamie Strandboge
  • Date: 2012-04-23 13:20:06 UTC
  • mfrom: (1.2.6)
  • Revision ID: package-import@ubuntu.com-20120423132006-yjtjnfbta86pvlz0
Tags: 12.0+build1-0ubuntu0.11.04.1
* New upstream stable release (FIREFOX_12_0_BUILD1)
  - see LP: #987262 for USN information

[ Chris Coulson <chris.coulson@canonical.com> ]
* Update globalmenu-extension to 2.0.6
  - Add support for Firefox 12
  - Ensure we correctly hide dummy menu items
* Make sure to add a binary libgconf2-4 dependency as dpkg-shlibdeps won't
  do this for us now
  - update debian/rules
  - update debian/control{,.in}
* Firefox recommends libcanberra0 now that bmo: #635918 has landed
  - update debian/control{,in}
* Clean up search plugin installation now that we build our own
  language packs:
  - Drop the recursive symlink from /usr/lib/firefox-addons/searchplugins,
    which lintian kept complaining about
  - Don't effectively symlink distribution/searchplugins to searchplugins,
    as they have different layouts and this avoids the same data being
    iterated over twice
  - Revert to the upstream layout in distribution/searchplugins
    - add debian/firefox-locale.preinst.in, which will end up in all
      language packs to assist the symlink -> folder transition
    - update debian/firefox.dirs.in
    - update debian/firefox.install.in
    - update debian/firefox.links.in
    - update debian/firefox.preinst.in
    - update debian/patches/distro-locale-searchplugins.patch
    - update debian/rules
* Fix LP: #894166 - Make Firefox work with our system hyphenation patterns,
  and stop including our own
  - update debian/vendor.js
  - add debian/patches/dont-include-hyphenation-patterns.patch
  - update debian/patches/series
* Fix LP: #807733 - Firefox doesn't restart after upgrades where the version
  changes. Don't include the version number in the install path, as Firefox
  cannot re-exec itself. In doing this, we also move the distribution.ini
  back in to our installation directory, as that never made sense in
  /usr/lib/firefox-addons
  - update debian/firefox-dev.install.in
  - update debian/firefox-dev.links.in
  - update debian/firefox-locale.preinst.in
  - update debian/firefox.lintian-overrides.in
  - update debian/firefox.preinst.in
  - update debian/rules
* Expose distribution/extensions in /usr/lib/firefox-addons, to allow
  administrators to add extensions that they want to add to default user
  profiles, and that they want the addon manager to keep updated. We lost
  this functionality when upgrading from Firefox 3.6, due to the loss of
  /etc/firefox/profile
  - update debian/firefox.dirs.in
  - update debian/firefox.install.in
  - update debian/firefox.links.in
  - update debian/firefox.postinst.in
* Refresh patches
  - update debian/patches/avoid-dbus-roundtrip-for-httpchannel.patch
  - update debian/patches/firefox-kde.patch
  - update debian/patches/mozilla-kde.patch
  - update debian/patches/no-sps-profiler-on-unsupported-archs.patch
  - update debian/patches/ubuntu-codes-google.patch
* Massively simplify distro-locale-searchplugins.patch, as we don't need
  to swap the loading order of common / locale-specific searchplugin
  paths. $LIBDIR/distribution/searchplugins/common is no longer a symlink
  to $LIBDIR/searchplugins, so there is no need to have the ability for
  locale-specific plugins to override common ones. They already override
  those in $LIBDIR/searchplugins
  - update debian/patches/distro-locale-searchplugins.patch
* Refresh locales
  - refresh debian/config/locales.all
  - refresh debian/control
* Make the language packs Architecture: any. Whilst they are actually
  architecture independent, we do install them in to /usr/lib (as the
  extensions location is shared with architecture-specific extensions).
  This also avoids the problem of offering incompatible language pack
  upgrades to users on architectures where Firefox fails to build
  (I'm looking at you, powerpc)
  - update debian/control.langpacks
  - update debian/control.langpacks.unavail
  - update debian/rules
  - refresh debian/control
* Disable fix-build-failure-without-yarr-jit.patch, as it needs some work.
  This means that there is currently no powerpc support

[ Jamie Strandboge <jamie@ubuntu.com> ]
* debian/usr.bin.firefox.apparmor.*:
  - allow access to statm and smaps for about:memory (LP: #911494)
  - allow read access to files in /opt (LP: #728485)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
# HG changeset patch
 
2
# User Mike Hommey <mh+mozilla@glandium.org>
 
3
# Date 1331628480 -3600
 
4
# Node ID 5168ba8c86f0ac4f6b4f15f981bc7ae770236bda
 
5
# Parent  ad62dcabf6969355343034d3003546436ed0023e
 
6
Bug 734335 - Only build SPS on supported platforms. r=bgirard,r=khuey
 
7
 
 
8
Index: mozilla/configure.in
 
9
===================================================================
 
10
--- mozilla.orig/configure.in   2012-03-15 00:57:32.000000000 +0000
 
11
+++ mozilla/configure.in        2012-03-15 00:58:42.410718796 +0000
 
12
@@ -2124,10 +2124,33 @@
 
13
 dnl ========================================================
 
14
 dnl SPS Profiler
 
15
 dnl ========================================================
 
16
-MOZ_ARG_ENABLE_BOOL(sps,
 
17
-[  --enable-sps          Enable sps profiling tool.],
 
18
-    MOZ_ENABLE_PROFILER_SPS=1,
 
19
-    MOZ_ENABLE_PROFILER_SPS= )
 
20
+MOZ_ENABLE_PROFILER_SPS=1
 
21
+
 
22
+case "${OS_TARGET}" in
 
23
+Android)
 
24
+    case "${CPU_ARCH}" in
 
25
+    x86 | arm) ;;
 
26
+    *)
 
27
+        MOZ_ENABLE_PROFILER_SPS=
 
28
+    esac
 
29
+    ;;
 
30
+Linux)
 
31
+    case "${CPU_ARCH}" in
 
32
+    x86 | x86_64) ;;
 
33
+    *)
 
34
+        MOZ_ENABLE_PROFILER_SPS=
 
35
+    esac
 
36
+    ;;
 
37
+WINNT|Darwin) ;;
 
38
+*)
 
39
+    MOZ_ENABLE_PROFILER_SPS=
 
40
+    ;;
 
41
+esac
 
42
+
 
43
+MOZ_ARG_DISABLE_BOOL(sps,
 
44
+[  --disable-sps         Disable sps profiling tool.],
 
45
+    MOZ_ENABLE_PROFILER_SPS=,
 
46
+    MOZ_ENABLE_PROFILER_SPS=1)
 
47
 if test -n "$MOZ_ENABLE_PROFILER_SPS"; then
 
48
     AC_DEFINE(MOZ_ENABLE_PROFILER_SPS)
 
49
 fi
 
50
Index: mozilla/toolkit/library/Makefile.in
 
51
===================================================================
 
52
--- mozilla.orig/toolkit/library/Makefile.in    2012-03-14 15:24:27.000000000 +0000
 
53
+++ mozilla/toolkit/library/Makefile.in 2012-03-15 00:58:42.410718796 +0000
 
54
@@ -315,7 +315,9 @@
 
55
 
 
56
 STATIC_LIBS += thebes gl ycbcr
 
57
 
 
58
+ifdef MOZ_ENABLE_PROFILER_SPS
 
59
 COMPONENT_LIBS += profiler
 
60
+endif
 
61
 
 
62
 ifeq (windows,$(MOZ_WIDGET_TOOLKIT))
 
63
 COMPONENT_LIBS += widget_windows
 
64
Index: mozilla/toolkit/library/nsStaticXULComponents.cpp
 
65
===================================================================
 
66
--- mozilla.orig/toolkit/library/nsStaticXULComponents.cpp      2012-03-14 15:24:27.000000000 +0000
 
67
+++ mozilla/toolkit/library/nsStaticXULComponents.cpp   2012-03-15 00:58:42.410718796 +0000
 
68
@@ -198,6 +198,12 @@
 
69
 #endif
 
70
 #endif
 
71
 
 
72
+#if defined(MOZ_ENABLE_PROFILER_SPS)
 
73
+#define PROFILER_MODULE MODULE(nsProfilerModule)
 
74
+#else
 
75
+#define PROFILER_MODULE
 
76
+#endif
 
77
+
 
78
 #define XUL_MODULES                          \
 
79
     MODULE(nsUConvModule)                    \
 
80
     MODULE(nsI18nModule)                     \
 
81
@@ -214,7 +220,7 @@
 
82
     MODULE(nsWindowDataSourceModule)         \
 
83
     MODULE(nsParserModule)                   \
 
84
     MODULE(nsGfxModule)                      \
 
85
-    MODULE(nsProfilerModule)                 \
 
86
+    PROFILER_MODULE                          \
 
87
     WIDGET_MODULES                           \
 
88
     MODULE(nsImageLib2Module)                \
 
89
     ICON_MODULE                              \
 
90
Index: mozilla/tools/profiler/sampler.h
 
91
===================================================================
 
92
--- mozilla.orig/tools/profiler/sampler.h       2012-03-14 15:24:38.000000000 +0000
 
93
+++ mozilla/tools/profiler/sampler.h    2012-03-15 00:58:42.410718796 +0000
 
94
@@ -78,7 +78,7 @@
 
95
 #define SAMPLER_H
 
96
 
 
97
 // Redefine the macros for platforms where SPS is supported.
 
98
-#if defined(ANDROID) || defined(__linux__) || defined(XP_MACOSX) || defined(XP_WIN)
 
99
+#ifdef MOZ_ENABLE_PROFILER_SPS
 
100
 
 
101
 #include "sps_sampler.h"
 
102
 
1
103
Index: mozilla/tools/profiler/Makefile.in
2
104
===================================================================
3
 
--- mozilla.orig/tools/profiler/Makefile.in     2012-03-07 02:11:41.000000000 +0000
4
 
+++ mozilla/tools/profiler/Makefile.in  2012-03-08 15:33:02.506149247 +0000
5
 
@@ -74,7 +74,7 @@
6
 
   Profiler.jsm \
7
 
   $(NULL)
8
 
 
9
 
-ifneq (,$(filter Android Linux,$(OS_TARGET)))
10
 
+ifeq ($(filter-out Android Linux, $(OS_TARGET)),$(filter-out arm% %86 x86_64, $(TARGET_CPU)))
11
 
 
12
 
 DEFINES += -DMOZ_ENABLE_PROFILER_SPS
 
105
--- mozilla.orig/tools/profiler/Makefile.in     2012-03-14 15:24:38.000000000 +0000
 
106
+++ mozilla/tools/profiler/Makefile.in  2012-03-15 01:02:05.778715184 +0000
 
107
@@ -48,8 +48,10 @@
 
108
 
 
109
 include $(DEPTH)/config/autoconf.mk
 
110
 
 
111
-EXPORTS = \
 
112
-  sampler.h \
 
113
+EXPORTS = sampler.h
 
114
+
 
115
+ifdef MOZ_ENABLE_PROFILER_SPS
 
116
+EXPORTS += \
 
117
   sps_sampler.h \
 
118
   thread_helper.h \
 
119
   $(NULL)
 
120
@@ -68,6 +70,7 @@
 
121
 CPPSRCS                = \
 
122
   nsProfilerFactory.cpp \
 
123
   nsProfiler.cpp \
 
124
+  TableTicker.cpp \
 
125
   $(NULL)
 
126
 
 
127
 XPIDLSRCS = \
 
128
@@ -80,12 +83,9 @@
 
129
 
 
130
 ifneq (,$(filter Android Linux,$(OS_TARGET)))
 
131
 
 
132
-DEFINES += -DMOZ_ENABLE_PROFILER_SPS
 
133
-
 
134
 CPPSRCS += \
 
135
   shared-libraries-linux.cc \
 
136
   platform-linux.cc \
 
137
-  TableTicker.cpp \
 
138
   $(NULL)
 
139
 endif
 
140
 ifeq ($(OS_TARGET),Darwin)
 
141
@@ -94,27 +94,21 @@
 
142
 # for platform-macosx.cc is in the hg history and should be
 
143
 # used when we can stackwalk using a thread handle.
 
144
 
 
145
-DEFINES += -DMOZ_ENABLE_PROFILER_SPS
 
146
-
 
147
 CPPSRCS += \
 
148
   shared-libraries-macos.cc \
 
149
   platform-linux.cc \
 
150
-  TableTicker.cpp \
 
151
   $(NULL)
 
152
 endif
 
153
 
 
154
 ifeq ($(OS_TARGET),WINNT)
 
155
 
 
156
-DEFINES += -DMOZ_ENABLE_PROFILER_SPS
 
157
-
 
158
 CPPSRCS += \
 
159
   shared-libraries-win32.cc \
 
160
   platform-win32.cc \
 
161
-  TableTicker.cpp \
 
162
   $(NULL)
 
163
 endif
 
164
 
 
165
-
 
166
+endif
 
167
 
 
168
 include $(topsrcdir)/config/rules.mk
 
169