~ubuntu-branches/ubuntu/natty/foo2zjs/natty

« back to all changes in this revision

Viewing changes to debian/patches/60-getweb.in.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Till Kamppeter
  • Date: 2010-07-28 22:47:45 UTC
  • mfrom: (1.2.5 upstream)
  • Revision ID: james.westby@ubuntu.com-20100728224745-5gplbymqfr8588w7
Tags: 20100728-0ubuntu1
* New upstream release
   o Snapshot from Jul 28, 2010.
* debian/patches/91-wrapper-scripts-custom-pagesize-via-command-line.dpatch:
  Removed, fixed upstream.
* debian/patches/30-udev-rules.dpatch,
  debian/patches/60-getweb.in.dpatch: Updated to work with new foo2zjs
  source.
* debian/patches/60-getweb.in.dpatch, debian/patches/80-getweb.in.dpatch:
  merged 80-getweb.in.dpatch into 60-getweb.in.dpatch.
* debian/rules: Added "CUPS_SERVERBIN=..." to the "make install" command
  line.
* debian/foo2zjs.postinst: Migrate driver name "foo2zjs" to "foo2zjs-z1"
  and "foo2zjs-z2".

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 60-getweb.dpatch by Debian FOO2ZJS Maintainers
 
2
## 60-getweb.in.dpatch by  <till.kamppeter@gmail.com>
3
3
##
4
4
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Improve getweb also for installing the firmware
 
5
## DP: No description.
6
6
 
7
7
@DPATCH@
8
 
diff -urNad foo2zjs-20100210~/getweb.in foo2zjs-20100210/getweb.in
9
 
--- foo2zjs-20100210~/getweb.in 2009-06-23 20:31:20.000000000 +0200
10
 
+++ foo2zjs-20100210/getweb.in  2010-03-16 16:30:34.740868271 +0100
 
8
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' foo2zjs-20100728~/getweb.in foo2zjs-20100728/getweb.in
 
9
--- foo2zjs-20100728~/getweb.in 2010-07-29 00:48:10.000000000 +0200
 
10
+++ foo2zjs-20100728/getweb.in  2010-07-29 00:51:41.947050797 +0200
11
11
@@ -2,7 +2,7 @@
12
12
 
13
13
 #
18
18
 #
19
19
 # PLEASE don't remove the copyright statements.  They should 
20
20
@@ -12,6 +12,18 @@
21
 
 VERSION='$Id: getweb.in,v 1.89 2009/06/23 18:31:20 rick Exp $'
 
21
 VERSION='$Id: getweb.in,v 1.91 2010/06/15 16:50:56 rick Exp $'
22
22
 
23
23
 WGETOPTS="--passive-ftp -q"
24
24
+ARM2HPDL="/usr/bin/arm2hpdl"
36
36
 
37
37
 usage() {
38
38
 cat <<EOF
39
 
@@ -94,7 +106,7 @@
 
39
@@ -95,7 +107,7 @@
40
40
 }
41
41
 
42
42
 SYSTEM=`uname -s`
45
45
 if [ "$SYSTEM" = Darwin -a "$WGET" = "" ]
46
46
 then
47
47
     WGETOPTS=
48
 
@@ -104,6 +116,13 @@
 
48
@@ -105,6 +117,13 @@
49
49
     }
50
50
 fi
51
51
 
59
59
 #
60
60
 #      Download a .EXE file from the web, unzip it, and extract the
61
61
 #      files we want
62
 
@@ -141,6 +160,7 @@
 
62
@@ -142,6 +161,7 @@
63
63
 getone() {
64
64
     case "$1" in
65
65
     lj1000|1000)
67
67
        gettgz \
68
68
            http://foo2zjs.rkkda.com/firmware sihp1000.tar.gz \
69
69
            ""
70
 
@@ -150,8 +170,10 @@
 
70
@@ -151,8 +171,10 @@
71
71
            #lj1488en.exe \
72
72
            #sihp1000.img
73
73
        copyright "(c) Copyright Hewlett-Packard 2001"
78
78
        gettgz \
79
79
            http://foo2zjs.rkkda.com/firmware sihp1005.tar.gz \
80
80
            ""
81
 
@@ -161,38 +183,50 @@
 
81
@@ -162,38 +184,50 @@
82
82
            #lj1005hostbased-en.exe \
83
83
            #sihp1005.img
84
84
        copyright "(c) Copyright Hewlett-Packard 2002"
93
93
+       putfw sihp1018.img sihp1018.dl
94
94
        ;;
95
95
     lj1020|1020)
96
 
+       cd /usr/share/foo2zjs/firmware/
 
96
+        cd /usr/share/foo2zjs/firmware/
97
97
        gettgz \
98
98
            http://foo2zjs.rkkda.com/firmware sihp1020.tar.gz \
99
99
            ""
105
105
        gettgz \
106
106
            http://foo2zjs.rkkda.com/firmware sihpP1005.tar.gz \
107
107
            ""
108
 
        copyright "(c) Copyright Hewlett-Packard 2008"
 
108
        copyright "(c) Copyright Hewlett-Packard 2009"
109
109
+       putfw sihpP1005.img sihpP1005.dl
110
110
        ;;
111
111
     [pP]100[68])
113
113
        gettgz \
114
114
            http://foo2zjs.rkkda.com/firmware sihpP1006.tar.gz \
115
115
            ""
116
 
        copyright "(c) Copyright Hewlett-Packard 2008"
117
 
+       putfw sihpP1006.img sihpP1006.dl
 
116
        copyright "(c) Copyright Hewlett-Packard 2009"
 
117
+        putfw sihpP1006.img sihpP1006.dl
118
118
        ;;
119
119
-    [pP]1505)
120
120
+    [pP]1505*)
122
122
        gettgz \
123
123
            http://foo2zjs.rkkda.com/firmware sihpP1505.tar.gz \
124
124
            ""
125
 
        copyright "(c) Copyright Hewlett-Packard 2008"
 
125
        copyright "(c) Copyright Hewlett-Packard 2009"
126
126
+       putfw sihpP1505.img sihpP1505.dl
127
127
        ;;
128
128
     2200dl|2200)
130
130
        if false; then
131
131
            gettgz \
132
132
                http://foo2zjs.rkkda.com/icm dl2300.tar.gz \
133
 
@@ -205,6 +239,7 @@
 
133
@@ -206,6 +240,7 @@
134
134
        copyright "(c) Copyright Minolta-QMS 1999"
135
135
        ;;
136
136
     2300dl|2300)
138
138
        if false; then
139
139
            gettgz \
140
140
                http://foo2zjs.rkkda.com/icm dl2300.tar.gz \
141
 
@@ -229,6 +264,7 @@
 
141
@@ -230,6 +265,7 @@
142
142
        echo "*** Now use a windows box to unzip and install $FILE ***"
143
143
        ;;
144
144
     cpwl|pageworks)
146
146
        if true; then
147
147
            gettgz \
148
148
                http://foo2zjs.rkkda.com/icm dl2300.tar.gz \
149
 
@@ -241,19 +277,21 @@
 
149
@@ -242,19 +278,21 @@
150
150
            do
151
151
                base=`basename $i .IC_`
152
152
                mv $base.IC_ $base.ic_
164
164
            ""
165
165
        copyright "(c) Copyright Konica Minolta 2003"
166
166
        ;;
167
 
     2530|2490|6115|2480|1600w|1680|1690|4690)
 
167
     2530|2490|6115|2480|1600w|1680|1690|4690|110)
168
168
+       cd /usr/share/foo2lava/icm/
169
169
        gettgz \
170
170
            http://foo2lava.rkkda.com/icm km2530.tar.gz \
171
171
            ""
172
 
@@ -264,7 +302,23 @@
 
172
@@ -265,7 +303,23 @@
173
173
            ""
174
174
        copyright "(c) Copyright Rick Richardson 2009.  All Rights Reserved"
175
175
        ;;
194
194
        gettgz \
195
195
            http://foo2hp.rkkda.com/icm hpclj2600n.tar.gz \
196
196
            ""
197
 
@@ -279,6 +333,7 @@
 
197
@@ -280,6 +334,7 @@
198
198
        copyright "(c) Copyright Rick Richardson 2008.  All Rights Reserved"
199
199
        ;;
200
200
     300|310|315|2160|3160|3175|6110)
202
202
        gettgz \
203
203
            http://foo2qpdl.rkkda.com/icm samclp300.tar.gz \
204
204
            ""
205
 
@@ -292,6 +347,7 @@
 
205
@@ -293,6 +348,7 @@
206
206
        ;;
207
207
 
208
208
     500)
210
210
        gettgz \
211
211
            http://foo2slx.rkkda.com/icm lexc500.tar.gz \
212
212
            ""
213
 
@@ -300,6 +356,7 @@
 
213
@@ -301,6 +357,7 @@
214
214
 
215
215
     oki)
216
216
        echo "Please wait, ~20MB is being downloaded from a slow site..."
218
218
        getexe \
219
219
            http://www.okiprintingsolutions.at/binaryData/16516/ \
220
220
            ICCProfiles.zip \
221
 
@@ -313,18 +370,21 @@
 
221
@@ -314,18 +371,21 @@
222
222
        copyright "(c) Copyright Okidata 2005, 2006"
223
223
        ;;
224
224
     3100|3200|5100|5150|5200|5250)
240
240
        gettgz \
241
241
            http://foo2hiperc.rkkda.com/icm okic5600.tar.gz \
242
242
            ""
243
 
@@ -431,6 +491,8 @@
 
243
@@ -395,7 +455,7 @@
 
244
        tar zxf $HERE/$file
 
245
        cd $HERE
 
246
        echo "The tarball is extracted and the current directory is up to date."
 
247
-       echo -e "Remove the tarball (y/n)? \c"
 
248
+       printf "Remove the tarball (y/n)? "
 
249
        read ans
 
250
        if [ "$ans" = y ]; then
 
251
            rm -f $file
 
252
@@ -433,6 +493,8 @@
244
253
        # getone 2430 already done
245
254
        # getone cpwl # file doesn't exist 1/28/08
246
255