~ubuntu-branches/ubuntu/natty/gecko-mediaplayer/natty

« back to all changes in this revision

Viewing changes to debian/patches/fix-width+height-initialisation.patch

  • Committer: Bazaar Package Importer
  • Author(s): Cesare Tirabassi
  • Date: 2007-12-14 17:26:45 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20071214172645-8ul52mlwizw9qed4
Tags: 0.5.3-0ubuntu1
* New upstream release
* Update watch file in accordance with upstream change of download page
* Remove patch fix-width+height-initialisation.patch applied upstream
* Add xulrunner-1.9 and xulrunner support
* debian/control:
  - bump Standards-Version to 3.7.3
  - move Homepage: to proper field in accordance with new Debian policy

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: gecko-mediaplayer-0.5.2/src/plugin_setup.cpp
2
 
===================================================================
3
 
--- gecko-mediaplayer-0.5.2.orig/src/plugin_setup.cpp   2007-11-04 15:03:11.000000000 +0100
4
 
+++ gecko-mediaplayer-0.5.2/src/plugin_setup.cpp        2007-11-04 15:12:34.000000000 +0100
5
 
@@ -54,7 +54,7 @@
6
 
     GRand *rand;
7
 
     gchar *tmp;
8
 
     gchar **parse;
9
 
-    gint width,height;
10
 
+    gint width = 0, height = 0;
11
 
 
12
 
     instance->mode = parameters->mode;
13
 
     instance->mimetype = g_strdup(parameters->type);
14
 
@@ -328,7 +328,7 @@
15
 
 
16
 
     // list_dump(instance->playlist);
17
 
 
18
 
-    if (instance->hidden == TRUE || (width == 0 || height == 0)) {
19
 
+    if (instance->hidden == TRUE || ((width == 0 || height == 0) && instance->mode != NP_FULL)) {
20
 
 
21
 
         if (item->streaming) {
22
 
             open_location(instance, item, FALSE);