~ubuntu-branches/ubuntu/natty/gnome-do/natty

« back to all changes in this revision

Viewing changes to debian/patches/11_fix_autostart_when_directory_does_not_exist.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Christopher James Halse Rogers
  • Date: 2009-06-27 10:40:45 UTC
  • mfrom: (1.1.8 upstream) (0.1.5 squeeze)
  • Revision ID: james.westby@ubuntu.com-20090627104045-7st10y1cqr6dpz37
Tags: 0.8.2+dfsg-1
* New upstream release
  + No longer uses a plugin repository.  Fixes many plugin-
    related issues. (LP: #343096, LP: #330025, LP #345001)
  + No longer blocks on "About Do" (LP: #361679)
  + Reacts correctly when a Composite manager is enabled/
    disabled at runtime. (LP: #346347, LP: #390150)
  + Fixes for space reserved by Docky blocking drag and 
    drop operations. (LP: #354729, LP: #347052, LP: #382843)
  + Properly sets "Hidden" key on autostart files in response to 
    "Start on login" option.  (Closes: #526023) (LP: #369988)
* debian/patches/10_application_search_path:
  + Drop; included upstream
* debian/patches/10_sk_translation_update:
  + Import sk translation update from Debian BTS.
    (Closes: #531779)
* debian/patches/11_fix_autostart_when_directory_does_not_exist:
  + Patch from upstream.  Fixes the "Start on login" option when the 
    ~/.config/autostart directory does not exist. (LP: #393729)
* debian/control:
  + Update standards version to 3.8.2; no changes required.
  + Add libtool to Build-Depends; required for autoreconf.
  + Add Recommends: on new gnome-do-docklets package.
* debian/gnome-do.1
  + Fix spelling: GNOME-Do => GNOME Do.
  + Miscelaneous lintian fixes; NAME section, escaping minus signs with \-
* debian/copyright:
  + Update for new copyright holders.
  + Minor update to DEP-5 format

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 11_fix_autostart_when_directory_does_not_exist.dpatch by Christopher James Halse Rogers <raof@ubuntu.com>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Pull patch from bzr lp:do r1272 to fix setting of autostart when the
 
6
## DP: ~/.config/autostart directory does not exist, such as when GNOME Do
 
7
## DP: is the first app to try to set user-local autostart.
 
8
 
 
9
@DPATCH@
 
10
=== modified file 'Do.Platform.Linux/src/Do.Platform/Do.Platform.Linux/SystemService.cs'
 
11
diff -urNad gnome-do-0.8.2~/Do.Platform.Linux/src/Do.Platform/Do.Platform.Linux/SystemService.cs gnome-do-0.8.2/Do.Platform.Linux/src/Do.Platform/Do.Platform.Linux/SystemService.cs
 
12
--- gnome-do-0.8.2~/Do.Platform.Linux/src/Do.Platform/Do.Platform.Linux/SystemService.cs        2009-06-24 03:12:20 +0000
 
13
+++ gnome-do-0.8.2/Do.Platform.Linux/src/Do.Platform/Do.Platform.Linux/SystemService.cs 2009-07-01 18:04:57 +0000
 
14
@@ -18,6 +18,7 @@
 
15
 //
 
16
 
 
17
 using System;
 
18
+using System.IO;
 
19
 using System.Reflection;
 
20
 
 
21
 using NDesk.DBus;
 
22
@@ -174,6 +175,9 @@
 
23
                                        autostartfile = DesktopItem.NewFromFile (System.IO.Path.Combine (AssemblyInfo.InstallData, "applications/gnome-do.desktop"),
 
24
                                                                                 DesktopItemLoadFlags.NoTranslations);
 
25
                                        try {
 
26
+                                               if (!Directory.Exists (AutoStartDir))
 
27
+                                                       Directory.CreateDirectory (AutoStartDir);
 
28
+
 
29
                                                autostartfile.Save (AutoStartUri, true);
 
30
                                                autostartfile.Location = AutoStartUri;
 
31
                                        } catch (Exception e) {
 
32