~ubuntu-branches/ubuntu/natty/gnome-panel/natty

« back to all changes in this revision

Viewing changes to debian/patches/90_fix_linking_DSO_link.patch

  • Committer: Bazaar Package Importer
  • Author(s): Didier Roche
  • Date: 2010-11-09 19:05:02 UTC
  • Revision ID: james.westby@ubuntu.com-20101109190502-1wr3zu0o80g7en3y
Tags: 1:2.32.0.2-0ubuntu2
* debian/patches/16_compiz_workspace_switcher.patch:
  - update for seeing the pager capplet with new compiz (it will need to
    export the layout to the root window then to see the effective number of
    viewport/worskpace to be taken into account)
* debian/patches/90_fix_linking_DSO_link.patch:
  - fix FTBFS due to missing DSO linking

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: fix DSO linking issue
 
2
Bug: https://bugzilla.gnome.org/show_bug.cgi?id=634446
 
3
Author: Didier Roche <didrocks@ubuntu.com>
 
4
 
 
5
Index: gnome-panel-2.32.0.2/gnome-panel/Makefile.am
 
6
===================================================================
 
7
--- gnome-panel-2.32.0.2.orig/gnome-panel/Makefile.am   2010-11-09 18:51:19.250239002 +0100
 
8
+++ gnome-panel-2.32.0.2/gnome-panel/Makefile.am        2010-11-09 18:52:44.434239002 +0100
 
9
@@ -8,6 +8,8 @@
 
10
 
 
11
 AM_CPPFLAGS =                                                  \
 
12
        $(PANEL_CFLAGS)                                         \
 
13
+       $(X_CFLAGS)                                             \
 
14
+       $(XRANDR_CFLAGS)                                        \
 
15
        -I.                                                     \
 
16
        -I$(srcdir)                                             \
 
17
        -I$(top_builddir)/gnome-panel                           \
 
18
@@ -149,7 +151,9 @@
 
19
 
 
20
 gnome_desktop_item_edit_LDADD =        \
 
21
        $(top_builddir)/gnome-panel/libpanel-util/libpanel-util.la \
 
22
-       $(PANEL_LIBS)
 
23
+       $(PANEL_LIBS)   \
 
24
+       $(X_LIBS)               \
 
25
+       $(XRANDR_LIBS)
 
26
 
 
27
 panel_test_applets_SOURCES =           \
 
28
        panel-modules.c                 \
 
29
@@ -166,7 +170,8 @@
 
30
 panel_test_applets_LDADD =             \
 
31
        $(top_builddir)/gnome-panel/libpanel-applet-private/libpanel-applet-private-mini.la     \
 
32
        $(top_builddir)/gnome-panel/libpanel-util/libpanel-util.la                              \
 
33
-       $(PANEL_LIBS)
 
34
+       $(PANEL_LIBS)   \
 
35
+       $(XRANDR_LIBS)
 
36
 
 
37
 panel_test_applets_LDFLAGS = -export-dynamic
 
38