~ubuntu-branches/ubuntu/natty/gnome-vfs/natty

« back to all changes in this revision

Viewing changes to debian/patches/40_http_seeking.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastian Dröge
  • Date: 2008-02-15 13:22:31 UTC
  • Revision ID: james.westby@ubuntu.com-20080215132231-x61jjhvp7po9gmqh
Tags: 1:2.20.1-2ubuntu1
* Merge with Debian/Unstable:
  + See changelog of 1:2.20.1-2 for all old Ubuntu changes.
  + debian/control.in:
    - Keep gamin | fam in Recommends.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: gnome-vfs/modules/http-neon-method.c
 
2
===================================================================
 
3
--- gnome-vfs/modules/http-neon-method.c        (Revision 5445)
 
4
+++ gnome-vfs/modules/http-neon-method.c        (Arbeitskopie)
 
5
@@ -2402,19 +2402,12 @@
 
6
                        return result;
 
7
                } 
 
8
        } else {
 
9
-               handle->use_range = (mode & GNOME_VFS_OPEN_RANDOM);
 
10
+                /* Always try to make Ranged puts */
 
11
+               handle->use_range = TRUE;
 
12
        }
 
13
 
 
14
        result = http_transfer_start (handle);  
 
15
 
 
16
-       if (result == GNOME_VFS_OK && mode & GNOME_VFS_OPEN_READ) {
 
17
-               
 
18
-               if (handle->use_range && ! handle->can_range) {
 
19
-                       /*Review: Not supported or invalid open mode ? */
 
20
-                       result = GNOME_VFS_ERROR_NOT_SUPPORTED;
 
21
-               }       
 
22
-       } 
 
23
-               
 
24
        if (result != GNOME_VFS_OK) {
 
25
                http_file_handle_destroy (handle);
 
26
                handle = NULL;
 
27