~ubuntu-branches/ubuntu/natty/icedtea-web/natty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/001_fix_pluginappletviewer_linkage.patch

  • Committer: Bazaar Package Importer
  • Author(s): Chris Coulson
  • Date: 2010-11-23 21:19:01 UTC
  • Revision ID: james.westby@ubuntu.com-20101123211901-c80ciy667hycuxvw
Tags: 1.0~20101021-0ubuntu6
* Fix link flag ordering issues
  - add debian/patches/001_fix_pluginappletviewer_linkage.patch
  - add debian/patches/series
  - update debian/rules
  - update debian/control{.in}
* Change xulrunner build-dep to xulrunner-2.0-dev for Natty and rebuild
  against the latest version. Change binary dependency to
  xulrunner-2.0 | firefox (>= 4.0~b7), because eventually, xulrunner will
  not be installed by default and we don't want to force Firefox users to
  install it
  - update debian/rules
  - update debian/control

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- a/Makefile.am
 
2
+++ b/Makefile.am
 
3
@@ -185,7 +185,7 @@ $(PLUGIN_DIR)/launcher/%.o: $(LAUNCHER_S
 
4
        $(CC) $(LAUNCHER_FLAGS) -DJAVA_ARGS='{ "sun.applet.PluginMain" }' -DPROGNAME='"pluginappletviewer"'  -c -o $@ $<
 
5
 
 
6
 $(PLUGIN_DIR)/launcher/pluginappletviewer: $(PLUGIN_LAUNCHER_OBJECTS)
 
7
-       $(CC) $(LAUNCHER_LINK) $(PLUGIN_LAUNCHER_OBJECTS)
 
8
+       $(CC) $(PLUGIN_LAUNCHER_OBJECTS) $(LAUNCHER_LINK)
 
9
 
 
10
 clean-IcedTeaPlugin:
 
11
        rm -f $(PLUGIN_DIR)/*.o
 
12
@@ -308,7 +308,7 @@ $(NETX_DIR)/launcher/%.o: $(LAUNCHER_SRC
 
13
 
 
14
 $(NETX_DIR)/launcher/javaws: $(NETX_LAUNCHER_OBJECTS)
 
15
        mkdir -p launcher
 
16
-       $(CC) $(LAUNCHER_LINK) $(NETX_LAUNCHER_OBJECTS)
 
17
+       $(CC) $(NETX_LAUNCHER_OBJECTS) $(LAUNCHER_LINK)
 
18
 
 
19
 # plugin tests
 
20
 
 
21
--- a/Makefile.in
 
22
+++ b/Makefile.in
 
23
@@ -667,7 +667,7 @@ uninstall-local:
 
24
 @ENABLE_PLUGIN_TRUE@   $(CC) $(LAUNCHER_FLAGS) -DJAVA_ARGS='{ "sun.applet.PluginMain" }' -DPROGNAME='"pluginappletviewer"'  -c -o $@ $<
 
25
 
 
26
 @ENABLE_PLUGIN_TRUE@$(PLUGIN_DIR)/launcher/pluginappletviewer: $(PLUGIN_LAUNCHER_OBJECTS)
 
27
-@ENABLE_PLUGIN_TRUE@   $(CC) $(LAUNCHER_LINK) $(PLUGIN_LAUNCHER_OBJECTS)
 
28
+@ENABLE_PLUGIN_TRUE@   $(CC) $(PLUGIN_LAUNCHER_OBJECTS) $(LAUNCHER_LINK)
 
29
 
 
30
 @ENABLE_PLUGIN_TRUE@clean-IcedTeaPlugin:
 
31
 @ENABLE_PLUGIN_TRUE@   rm -f $(PLUGIN_DIR)/*.o
 
32
@@ -789,7 +789,7 @@ $(NETX_DIR)/launcher/%.o: $(LAUNCHER_SRC
 
33
 
 
34
 $(NETX_DIR)/launcher/javaws: $(NETX_LAUNCHER_OBJECTS)
 
35
        mkdir -p launcher
 
36
-       $(CC) $(LAUNCHER_LINK) $(NETX_LAUNCHER_OBJECTS)
 
37
+       $(CC) $(NETX_LAUNCHER_OBJECTS) $(LAUNCHER_LINK)
 
38
 
 
39
 # plugin tests
 
40