~ubuntu-branches/ubuntu/natty/insserv/natty-updates

« back to all changes in this revision

Viewing changes to debian/patches/20_install_perms_fixup.patch

  • Committer: Bazaar Package Importer
  • Author(s): Petter Reinholdtsen, Kel Modderman, Petter Reinholdtsen
  • Date: 2010-05-07 09:45:19 UTC
  • mfrom: (1.1.6 upstream)
  • Revision ID: james.westby@ubuntu.com-20100507094519-laz6segpkp1t9mce
Tags: 1.14.0-2
[ Kel Modderman ]
* Add 21_tweak_warnings.patch to make insserv warn about differing on
  disk state/LSB runlevel info for the script(s) in its argument list.
  (Closes: #578308)
* Add 100_show.patch which allows insserv --showall to dump start/stop
  bit, sequence number, runlevels and script name in the format:
  SK:NUM:RUNLEVELS:SCRIPT. It is commented out in quilt series file
  until confirmation from #573004 that it is actually useful.
* Add 30_interactive_regexp_match_fix.patch which fixes failure to
  properly match the correct group in the regular expression used on
  the X-Interactive keyword. (Closes: #580564)
* Modify 92_m68k_alignment.patch so that the define is grouped in an
  area of code which other similar defines live.

[ Petter Reinholdtsen ]
* Improve the output from make-testsuite. 
* Adjust the test_x_interactive behaviour to make sure it fails with
  a fatal error if X-Interactive: true do not work.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Purpose: Use correct permissions for installing /sbin/insserv and
2
 
         /etc/insserv.conf
3
 
Authour: Kel Modderman
4
 
Fixes:   -
5
 
Status:  Not yet submitted upstream.
6
 
 
7
 
Index: insserv/Makefile
8
 
===================================================================
9
 
--- insserv.orig/Makefile       2009-09-26 22:35:39.000000000 +0200
10
 
+++ insserv/Makefile    2009-09-26 22:35:39.000000000 +0200
11
 
@@ -41,14 +41,14 @@
12
 
             RM = rm -f
13
 
          MKDIR = mkdir -p
14
 
          RMDIR = rm -rf
15
 
-   INSTBINFLAGS = -m 0700
16
 
+   INSTBINFLAGS = -m 0755
17
 
        INSTBIN = install $(INSTBINFLAGS)
18
 
-   INSTSRPFLAGS = -m 0700
19
 
+   INSTSRPFLAGS = -m 0755
20
 
        INSTSRP = install $(INSTSRPFLAGS)
21
 
-   INSTDOCFLAGS = -c -m 0444
22
 
+   INSTDOCFLAGS = -c -m 0644
23
 
        INSTDOC = install $(INSTDOCFLAGS)
24
 
    INSTCONFLAGS = -c -m 0644
25
 
-       INSTCON = install $(INSTDOCFLAGS)
26
 
+       INSTCON = install $(INSTCONFLAGS)
27
 
           LINK = ln -sf
28
 
 #
29
 
        SDOCDIR = $(DESTDIR)/usr/share/man/man8