~ubuntu-branches/ubuntu/natty/jabref/natty

« back to all changes in this revision

Viewing changes to debian/patches/04_HONOR_DISPLAY_PROPERTIES.patch

  • Committer: Bazaar Package Importer
  • Author(s): Onkar Shinde
  • Date: 2008-08-09 14:51:41 UTC
  • mfrom: (2.1.1 lenny)
  • Revision ID: james.westby@ubuntu.com-20080809145141-kz5hgm0zvx57gx80
Tags: 2.3.1-5ubuntu1
* Merge from debian unstable. (LP: #225450, #227125)
* Remaining changes:
  - debian/control
    * Change build dependency default-jdk-builddep to default-jdk.
    * Change run time dependency to default-jre | java2-runtime.
      There is no evidence that it does not run with latest Free JVMs.
      (LP: #164216, #194509)
    * Modify Maintainer value to match the DebianMaintainerField
      specification.
  - debian/rules
    * Change JAVA_HOME for default-jdk.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Author: <gregor+debian@comodo.priv.at>
 
2
Description: JEditorPane.HONOR_DISPLAY_PROPERTIES not understood by java-gcj-compat-dev ...
 
3
--- a/src/java/net/sf/jabref/JabRefMain.java
 
4
+++ b/src/java/net/sf/jabref/JabRefMain.java
 
5
@@ -109,7 +109,6 @@
 
6
                 "We are sorry for the trouble and thanks for reporting problems with JabRef!</html>");
 
7
             pane.setEditable(false);
 
8
             pane.setOpaque(false);
 
9
-            pane.putClientProperty(JEditorPane.HONOR_DISPLAY_PROPERTIES, Boolean.TRUE);
 
10
             
 
11
             Component componentToDisplay;
 
12
             if (pane.getPreferredSize().getHeight() > 700){
 
13
@@ -157,7 +156,6 @@
 
14
                 "<p>For more information visit <b>http://jabref.sf.net/faq.php</b>.</p></html>");
 
15
             pane.setEditable(false);
 
16
             pane.setOpaque(false);
 
17
-            pane.putClientProperty(JEditorPane.HONOR_DISPLAY_PROPERTIES, Boolean.TRUE);
 
18
             
 
19
             JOptionPane.showMessageDialog(null, pane, "Insufficient Java Version Installed", JOptionPane.ERROR_MESSAGE);
 
20
         }