~ubuntu-branches/ubuntu/natty/libbusiness-onlinepayment-ippay-perl/natty

« back to all changes in this revision

Viewing changes to debian/patches/no-connectivity.patch

  • Committer: Bazaar Package Importer
  • Author(s): Nicholas Bamber, gregor herrmann, Nicholas Bamber, Ansgar Burchardt
  • Date: 2010-10-28 14:28:52 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20101028142852-tkh4l5fw0lyygl4o
Tags: 0.05-1
[ gregor herrmann ]
* Bump debhelper dependency in debian/control to 7.

[ Nicholas Bamber ]
* New upstream release
* Upped standards version to 3.9.1
* echo '3.0 (quilt)' > debian/source/format
* Added myself to Uploaders
* Rewrote short and long descriptions
* Refreshed copyright
* Reviewed patch (and converted from diff format)

[ Ansgar Burchardt ]
* debian/control: Make build-dep on perl unversioned.
* debian/control: Change Homepage field to Business::OnlinePayment homepage
  which is more informative than the module's CPAN page. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Subject: Skip tests requiring connectivity
 
2
Author: Ivan Kohler <ivan-debian@420.am>
 
3
Forwarded: not-needed
 
4
Reviewed-By: Nicholas Bamber <nicholas@periapt.co.uk>
 
5
Last-Update: 2010-10-28
 
6
--- a/t/card.t
 
7
+++ b/t/card.t
 
8
@@ -1,11 +1,11 @@
 
9
 #!/usr/bin/perl -w
 
10
 
 
11
-use Test::More;
 
12
+use Test::More skip_all => 'Skip network tests in Debian build';
 
13
 
 
14
 my($login, $password, @opts) = ('TESTMERCHANT', '',
 
15
                                 'default_Origin' => 'RECURRING' );
 
16
 plan tests => 43;
 
17
-  
 
18
+
 
19
 use_ok 'Business::OnlinePayment';
 
20
 
 
21
 my %content = (
 
22
--- a/t/check.t
 
23
+++ b/t/check.t
 
24
@@ -1,6 +1,6 @@
 
25
 #!/usr/bin/perl -w
 
26
 
 
27
-use Test::More;
 
28
+use Test::More skip_all => 'Skip network tests in Debian build';
 
29
 
 
30
 my($login, $password, %opt) = ('TESTMERCHANT', '', 'Origin' => 'RECURRING' );
 
31
 plan tests => 16;