~ubuntu-branches/ubuntu/natty/libmpc/natty

« back to all changes in this revision

Viewing changes to debian/patches/04_link-order.patch

  • Committer: Bazaar Package Importer
  • Author(s): Stefan Potyra
  • Date: 2010-12-12 02:07:30 UTC
  • Revision ID: james.westby@ubuntu.com-20101212020730-ixvruwxurpgglprt
Tags: 2:0.1~r459-1ubuntu1
* debian/patches/04_link-order.patch: Link against -lm only after the
  static libraries that use math functions. Fixes the build failure
  from --as-needed, which enforces strict order.
* debian/patches/99_autoreconf.patch: Regenerate by autoconf -i and
  removing the cache directory afterwards.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: libmpc-0.1~r459/mpc2sv8/Makefile.am
 
2
===================================================================
 
3
--- libmpc-0.1~r459.orig/mpc2sv8/Makefile.am    2010-12-12 02:06:29.610851037 +0100
 
4
+++ libmpc-0.1~r459/mpc2sv8/Makefile.am 2010-12-12 02:06:38.080851002 +0100
 
5
@@ -11,6 +11,7 @@
 
6
 METASOURCES = AUTO
 
7
 bin_PROGRAMS = mpc2sv8
 
8
 mpc2sv8_SOURCES = mpc2sv8.c $(common_sources)
 
9
-mpc2sv8_LDADD = -lm \
 
10
+mpc2sv8_LDADD = \
 
11
        $(top_builddir)/libmpcdec/libmpcdec.la \
 
12
-       $(top_builddir)/libmpcenc/libmpcenc.a
 
13
+       $(top_builddir)/libmpcenc/libmpcenc.a \
 
14
+       -lm
 
15
Index: libmpc-0.1~r459/mpcdec/Makefile.am
 
16
===================================================================
 
17
--- libmpc-0.1~r459.orig/mpcdec/Makefile.am     2010-12-12 02:05:03.790851001 +0100
 
18
+++ libmpc-0.1~r459/mpcdec/Makefile.am  2010-12-12 02:05:11.770851000 +0100
 
19
@@ -9,6 +9,7 @@
 
20
 METASOURCES = AUTO
 
21
 bin_PROGRAMS = mpcdec
 
22
 mpcdec_SOURCES = mpcdec.c
 
23
-mpcdec_LDADD = -lm \
 
24
+mpcdec_LDADD = \
 
25
        $(top_builddir)/libmpcdec/libmpcdec.la \
 
26
-       $(top_builddir)/libwavformat/libwavformat.a
 
27
+       $(top_builddir)/libwavformat/libwavformat.a \
 
28
+       -lm
 
29
Index: libmpc-0.1~r459/mpcenc/Makefile.am
 
30
===================================================================
 
31
--- libmpc-0.1~r459.orig/mpcenc/Makefile.am     2010-12-12 02:05:38.200851002 +0100
 
32
+++ libmpc-0.1~r459/mpcenc/Makefile.am  2010-12-12 02:05:51.660851636 +0100
 
33
@@ -22,8 +22,9 @@
 
34
        $(common_sources) \
 
35
        mpcenc.h predict.h config.h
 
36
 
 
37
-mpcenc_LDADD = -lm \
 
38
+mpcenc_LDADD = \
 
39
        $(EXTRALIBS) \
 
40
        $(top_builddir)/libmpcpsy/libmpcpsy.a \
 
41
-       $(top_builddir)/libmpcenc/libmpcenc.a
 
42
+       $(top_builddir)/libmpcenc/libmpcenc.a \
 
43
+       -lm
 
44