~ubuntu-branches/ubuntu/natty/ocamlnet/natty

« back to all changes in this revision

Viewing changes to debian/patches/rpath-apache.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Stéphane Glondu, Stefano Zacchiroli, Stephane Glondu
  • Date: 2009-10-06 16:35:12 UTC
  • mfrom: (4.1.4 squeeze)
  • Revision ID: james.westby@ubuntu.com-20091006163512-uqg6gtdar30iqxbz
Tags: 2.2.9-7
[ Stefano Zacchiroli ]
* debian/copyright: point to GPL-2 under /usr/share/common-licenses/

[ Stephane Glondu ]
* Switch packaging to dh-ocaml 0.9 (Closes: #549849)
* Add README.source
* debian/control:
  - add myself to Uploaders
  - move to section ocaml
  - update Standards-Version to 3.8.3
* Add Lintian override for RPATH in mod_netcgi_apache.so

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## rpath-apache.dpatch by Stefano Zacchiroli <zack@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: add rpath to Apache module, pointing to `ocamlc -where`
6
 
## DP: rationale: ensure libcamlrun_shared.so can be found
7
 
 
8
 
@DPATCH@
9
 
diff -urNad ocamlnet~/src/netcgi2-apache/Makefile.def ocamlnet/src/netcgi2-apache/Makefile.def
10
 
--- ocamlnet~/src/netcgi2-apache/Makefile.def   2008-10-29 00:19:10.175784001 +0100
11
 
+++ ocamlnet/src/netcgi2-apache/Makefile.def    2008-10-29 00:19:56.095780612 +0100
12
 
@@ -46,7 +46,7 @@
13
 
 ### Embed Caml code into the C code.
14
 
 ### Requires `caml_startup' instead of `caml_main' in handler.c
15
 
 mod_netcgi_apache.so: $(MOD_OBJECTS)
16
 
-       $(APXS) -c -o $@ $^ -L$(APACHE_OCAMLLIBDIR) $(patsubst -lcamlrun,-lcamlrun_shared,$(APACHE_OCAMLLIBS))
17
 
+       $(APXS) -c -o $@ $^ -L$(APACHE_OCAMLLIBDIR) -Wl,--rpath,$(APACHE_OCAMLLIBDIR) $(patsubst -lcamlrun,-lcamlrun_shared,$(APACHE_OCAMLLIBS))
18
 
        test -f .libs/$@ && cp .libs/$@ .
19
 
 
20
 
 netcgi_apache_mod.lo: netcgi_apache_mod.o