~ubuntu-branches/ubuntu/natty/openttd-opensfx/natty

« back to all changes in this revision

Viewing changes to debian/patches/install-mkdir.patch

  • Committer: Bazaar Package Importer
  • Author(s): Matthijs Kooijman, Matthijs Kooijman
  • Date: 2010-04-02 15:45:39 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20100402154539-3dbha95ba81wbqtd
Tags: 0.2.3-1
[ Matthijs Kooijman ]
* [9f4d281] New upstream release 0.2.3.
* [5801386] Don't use "free" or "open source" to descripe OpenSFX.
  (Closes: #573952)
* [487e4a1] Remove install-mkdir.patch, the issue was fixed upstream.
* [bf7b68e] Enable md5 sum checking after build.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: Matthijs Kooijman <matthijs@stdin.nl>
2
 
Subject: Create directories on make install
3
 
 
4
 
The original Makefile assumes directories are available, which is not
5
 
the case when building a Debian package.
6
 
 
7
 
Index: openttd-opensfx/Makefile
8
 
===================================================================
9
 
--- openttd-opensfx.orig/Makefile       2010-02-23 19:04:36.000000000 +0100
10
 
+++ openttd-opensfx/Makefile    2010-02-23 19:57:31.000000000 +0100
11
 
@@ -155,8 +155,9 @@
12
 
        $(_V)$(BZIP) $(BZIP_FLAGS) $^
13
 
 
14
 
 # Installation process
15
 
-install: $(TAR_FILENAME) $(INSTALLDIR)
16
 
+install: $(TAR_FILENAME)
17
 
        $(_E) "[INSTALL] to $(INSTALLDIR)"
18
 
+       $(_V)-mkdir -p $(INSTALLDIR)
19
 
        $(_V)-cp $(TAR_FILENAME) $(INSTALLDIR)
20
 
        $(_E)
21
 
 
22
 
@@ -172,10 +173,6 @@
23
 
        $(_V) $(TAR) --gzip -cf $(DIR_NAME_SRC).tar.gz $(DIR_NAME_SRC)
24
 
        $(_V) rm -rf $(DIR_NAME_SRC)
25
 
 
26
 
-
27
 
-$(INSTALLDIR):
28
 
-       $(_E) "$(error Installation dir does not exist. Check your makefile.local)"
29
 
-
30
 
 release-install:
31
 
        $(_E) "Target is obsolete. Use 'install' instead."
32
 
 release-source: