~ubuntu-branches/ubuntu/natty/psicode/natty

« back to all changes in this revision

Viewing changes to debian/patches/01_DESTDIR.patch

  • Committer: Bazaar Package Importer
  • Author(s): Michael Banck
  • Date: 2006-09-10 14:01:33 UTC
  • Revision ID: james.westby@ubuntu.com-20060910140133-bn0f2c0g4gpo0xiu
Tags: 3.2.3-1
InitialĀ upload.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- include/Makefile.in.orig    2005-05-06 20:19:35.491871824 +0200
 
2
+++ include/Makefile.in 2005-05-06 20:21:37.193370384 +0200
 
3
@@ -25,8 +25,8 @@
 
4
 install: install_inc
 
5
 
 
6
 install_inc: $(HEADERS)
 
7
-       $(MKDIRS) $(incdir)
 
8
-       $(INSTALL_INCLUDE) $^ $(incdir)
 
9
+       $(MKDIRS) $(DESTDIR)$(incdir)
 
10
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(incdir)
 
11
 
 
12
 $(top_srcdir)/configure: $(top_srcdir)/configure.in $(top_srcdir)/aclocal.m4
 
13
        cd $(top_srcdir) && autoconf
 
14
--- lib/Makefile.in.orig        2005-05-07 02:19:30.572920496 +0200
 
15
+++ lib/Makefile.in     2005-05-07 02:19:49.367063352 +0200
 
16
@@ -21,13 +21,13 @@
 
17
 INSTALL_DATA = @INSTALL_DATA@
 
18
 
 
19
 install: pbasis.dat psi.dat
 
20
-       $(MKDIRS) $(datadir)
 
21
-       $(INSTALL_DATA) $(srcdir)/pbasis.dat $(datadir)
 
22
-       $(INSTALL_DATA) $(srcdir)/psi.dat $(datadir)
 
23
+       $(MKDIRS) $(DESTDIR)$(datadir)
 
24
+       $(INSTALL_DATA) $(srcdir)/pbasis.dat $(DESTDIR)$(datadir)
 
25
+       $(INSTALL_DATA) $(srcdir)/psi.dat $(DESTDIR)$(datadir)
 
26
 
 
27
 install_man: macro.psi
 
28
-       $(MKDIRS) $(datadir)
 
29
-       $(INSTALL_DATA) $< $(datadir)
 
30
+       $(MKDIRS) $(DESTDIR)$(datadir)
 
31
+       $(INSTALL_DATA) $< $(DESTDIR)$(datadir)
 
32
 
 
33
 $(top_srcdir)/configure: $(top_srcdir)/configure.in $(top_srcdir)/aclocal.m4
 
34
        cd $(top_srcdir) && autoconf
 
35
--- src/bin/MakeRules.in.orig   2005-05-06 19:26:10.818056296 +0200
 
36
+++ src/bin/MakeRules.in        2005-05-06 19:27:07.276473312 +0200
 
37
@@ -52,8 +52,8 @@
 
38
        $(LD) $(LDFLAGS) -o $@ $^ $(LDLIBS)
 
39
 
 
40
 install_target:: $(TARGET)
 
41
-       $(MKDIRS) $(bindir)
 
42
-       $(INSTALL_PROGRAM) $< $(bindir)
 
43
+       $(MKDIRS) $(DESTDIR)$(bindir)
 
44
+       $(INSTALL_PROGRAM) $< $(DESTDIR)$(bindir)
 
45
 
 
46
 #
 
47
 # clean up
 
48
--- src/lib/MakeRules.in.orig   2005-05-06 19:35:11.633839800 +0200
 
49
+++ src/lib/MakeRules.in        2005-05-06 19:35:39.474607360 +0200
 
50
@@ -52,9 +52,9 @@
 
51
        $(RANLIB)  $(TARGET)
 
52
 
 
53
 install_target:: $(TARGET)
 
54
-       $(MKDIRS) $(libdir)
 
55
-       $(INSTALL_DATA) $< $(libdir)
 
56
-       $(RANLIB) $(libdir)/`basename $(TARGET)`
 
57
+       $(MKDIRS) $(DESTDIR)$(libdir)
 
58
+       $(INSTALL_DATA) $< $(DESTDIR)$(libdir)
 
59
+       $(RANLIB) $(DESTDIR)$(libdir)/`basename $(TARGET)`
 
60
 
 
61
 install_man::
 
62
 
 
63
--- src/util/MakeRules.in.orig  2005-05-06 19:36:00.892351368 +0200
 
64
+++ src/util/MakeRules.in       2005-05-06 19:38:05.218450928 +0200
 
65
@@ -51,8 +51,8 @@
 
66
        $(LD) $(LDFLAGS) -o $@ $^ $(LDLIBS)
 
67
 
 
68
 install_target:: $(TARGET)
 
69
-       $(MKDIRS) $(bindir)
 
70
-       $(INSTALL_PROGRAM) $< $(bindir)
 
71
+       $(MKDIRS) $(DESTDIR)$(bindir)
 
72
+       $(INSTALL_PROGRAM) $< $(DESTDIR)$(bindir)
 
73
 
 
74
 #
 
75
 # clean up
 
76
--- src/lib/libbasis/Makefile.in.orig   2005-05-06 20:29:27.606856664 +0200
 
77
+++ src/lib/libbasis/Makefile.in        2005-05-06 20:34:04.101823040 +0200
 
78
@@ -20,7 +20,7 @@
 
79
 endif
 
80
 
 
81
 install_inc:: $(DEPENDINCLUDE)
 
82
-       $(MKDIRS) $(incdir)/libbasis
 
83
-       $(INSTALL_INCLUDE) $^ $(incdir)/libbasis
 
84
+       $(MKDIRS) $(DESTDIR)$(incdir)/libbasis
 
85
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(incdir)/libbasis
 
86
 
 
87
 
 
88
--- src/lib/libchkpt/Makefile.in.orig   2005-05-06 20:29:27.683844960 +0200
 
89
+++ src/lib/libchkpt/Makefile.in        2005-05-06 20:34:04.114821064 +0200
 
90
@@ -86,8 +86,8 @@
 
91
 include ../MakeRules
 
92
 
 
93
 install_inc:: $(DEPENDINCLUDE)
 
94
-       $(MKDIRS) $(incdir)/libchkpt
 
95
-       $(INSTALL_INCLUDE) $^ $(incdir)/libchkpt
 
96
+       $(MKDIRS) $(DESTDIR)$(incdir)/libchkpt
 
97
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(incdir)/libchkpt
 
98
 
 
99
 ifneq ($(DODEPEND),no)
 
100
 include $(LIBOBJ:%.o=%.d)
 
101
--- src/lib/libciomr/Makefile.in.orig   2005-05-06 20:29:27.699842528 +0200
 
102
+++ src/lib/libciomr/Makefile.in        2005-05-06 20:34:04.126819240 +0200
 
103
@@ -82,5 +82,5 @@
 
104
 endif
 
105
 
 
106
 install_inc:: libciomr.h iomrparam.h
 
107
-       $(MKDIRS) $(incdir)/libciomr
 
108
-       $(INSTALL_INCLUDE) $^ $(incdir)/libciomr
 
109
+       $(MKDIRS) $(DESTDIR)$(incdir)/libciomr
 
110
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(incdir)/libciomr
 
111
--- src/lib/libderiv/Makefile.in.orig   2005-05-06 20:29:27.715840096 +0200
 
112
+++ src/lib/libderiv/Makefile.in        2005-05-06 20:34:04.138817416 +0200
 
113
@@ -66,11 +66,11 @@
 
114
 targetclean:
 
115
 
 
116
 install: $(TARGET) $(TARGET_HEADERS)
 
117
-       $(MKDIRS) $(libdir)
 
118
-       $(INSTALL_DATA) $< $(libdir)
 
119
-       $(RANLIB) $(libdir)/`basename $(TARGET)`
 
120
-       $(MKDIRS) $(incdir)/libderiv
 
121
-       $(INSTALL_INCLUDE) $(TARGET_HEADERS) $(incdir)/libderiv
 
122
+       $(MKDIRS) $(DESTDIR)$(libdir)
 
123
+       $(INSTALL_DATA) $< $(DESTDIR)$(libdir)
 
124
+       $(RANLIB) $(DESTDIR)$(libdir)/`basename $(TARGET)`
 
125
+       $(MKDIRS) $(DESTDIR)$(incdir)/libderiv
 
126
+       $(INSTALL_INCLUDE) $(TARGET_HEADERS) $(DESTDIR)$(incdir)/libderiv
 
127
 
 
128
 #
 
129
 # keep the configuration information and makefiles up-to-date
 
130
--- src/lib/libdpd/Makefile.in.orig     2005-05-07 01:58:30.776438672 +0200
 
131
+++ src/lib/libdpd/Makefile.in  2005-05-07 02:00:01.081710184 +0200
 
132
@@ -55,10 +55,10 @@
 
133
 endif
 
134
 
 
135
 install_inc:: dpd.h
 
136
-       $(MKDIRS) $(incdir)/libdpd
 
137
-       $(INSTALL_INCLUDE) $^ $(incdir)/libdpd
 
138
+       $(MKDIRS) $(DESTDIR)$(incdir)/libdpd
 
139
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(incdir)/libdpd
 
140
 
 
141
 install_man:: libdpd.html
 
142
-       $(MKDIRS) $(htmldir)
 
143
-       $(INSTALL_INCLUDE) $^ $(htmldir)
 
144
+       $(MKDIRS) $(DESTDIR)$(htmldir)
 
145
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(htmldir)
 
146
 
 
147
--- src/lib/libint/Makefile.in.orig     2005-05-06 20:29:27.752834472 +0200
 
148
+++ src/lib/libint/Makefile.in  2005-05-06 20:34:04.163813616 +0200
 
149
@@ -62,11 +62,11 @@
 
150
 targetclean:
 
151
 
 
152
 install: $(TARGET) $(TARGET_HEADERS)
 
153
-       $(MKDIRS) $(libdir)
 
154
-       $(INSTALL_DATA) $< $(libdir)
 
155
-       $(RANLIB) $(libdir)/`basename $(TARGET)`
 
156
-       $(MKDIRS) $(incdir)/libint
 
157
-       $(INSTALL_INCLUDE) $(TARGET_HEADERS) $(incdir)/libint
 
158
+       $(MKDIRS) $(DESTDIR)$(libdir)
 
159
+       $(INSTALL_DATA) $< $(DESTDIR)$(libdir)
 
160
+       $(RANLIB) $(DESTDIR)$(libdir)/`basename $(TARGET)`
 
161
+       $(MKDIRS) $(DESTDIR)$(incdir)/libint
 
162
+       $(INSTALL_INCLUDE) $(TARGET_HEADERS) $(DESTDIR)$(incdir)/libint
 
163
 
 
164
 #
 
165
 # keep the configuration information and makefiles up-to-date
 
166
--- src/lib/libipv1/Makefile.in.orig    2005-05-06 20:29:27.758833560 +0200
 
167
+++ src/lib/libipv1/Makefile.in 2005-05-06 20:34:04.174811944 +0200
 
168
@@ -40,8 +40,8 @@
 
169
        $(LEX) -t $^ > scan.c
 
170
 
 
171
 install_inc:: $(ALLINCLUDE)
 
172
-       $(MKDIRS) $(incdir)/libipv1
 
173
-       $(INSTALL_INCLUDE) $^ $(incdir)/libipv1
 
174
+       $(MKDIRS) $(DESTDIR)$(incdir)/libipv1
 
175
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(incdir)/libipv1
 
176
 
 
177
 clean::
 
178
        -/bin/rm -f y.tab.h y.tab.c y.output scan.c
 
179
--- src/lib/libiwl/Makefile.in.orig     2005-05-07 01:49:10.449621296 +0200
 
180
+++ src/lib/libiwl/Makefile.in  2005-05-07 01:49:47.497989088 +0200
 
181
@@ -27,10 +27,10 @@
 
182
 endif
 
183
 
 
184
 install_inc:: iwl.h
 
185
-       $(MKDIRS) $(incdir)/libiwl
 
186
-       $(INSTALL_INCLUDE) $^ $(incdir)/libiwl
 
187
+       $(MKDIRS) $(DESTDIR)$(incdir)/libiwl
 
188
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(incdir)/libiwl
 
189
 
 
190
 install_man:: libiwl.txt
 
191
-       $(MKDIRS) $(txtdir)
 
192
-       $(INSTALL_INCLUDE) $^ $(txtdir)
 
193
+       $(MKDIRS) $(DESTDIR)$(txtdir)
 
194
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(txtdir)
 
195
 
 
196
--- src/lib/libpsio/Makefile.in.orig    2005-05-07 01:58:22.205741616 +0200
 
197
+++ src/lib/libpsio/Makefile.in 2005-05-07 01:59:45.727044448 +0200
 
198
@@ -26,10 +26,10 @@
 
199
 endif
 
200
 
 
201
 install_inc:: psio.h psio.gbl
 
202
-       $(MKDIRS) $(incdir)/libpsio
 
203
-       $(INSTALL_INCLUDE) $^ $(incdir)/libpsio
 
204
+       $(MKDIRS) $(DESTDIR)$(incdir)/libpsio
 
205
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(incdir)/libpsio
 
206
 
 
207
 install_man:: libpsio.html
 
208
-       $(MKDIRS) $(htmldir)
 
209
-       $(INSTALL_INCLUDE) $^ $(htmldir)
 
210
+       $(MKDIRS) $(DESTDIR)$(htmldir)
 
211
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(htmldir)
 
212
 
 
213
--- src/lib/libqt/Makefile.in.orig      2005-05-07 01:50:56.334524344 +0200
 
214
+++ src/lib/libqt/Makefile.in   2005-05-07 01:55:26.564443152 +0200
 
215
@@ -30,9 +30,9 @@
 
216
 endif
 
217
 
 
218
 install_inc:: qt.h
 
219
-       $(MKDIRS) $(incdir)/libqt
 
220
-       $(INSTALL_INCLUDE) $^ $(incdir)/libqt
 
221
+       $(MKDIRS) $(DESTDIR)$(incdir)/libqt
 
222
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(incdir)/libqt
 
223
 
 
224
 install_man:: libqt.txt
 
225
-       $(MKDIRS) $(txtdir)
 
226
-       $(INSTALL_INCLUDE) $^ $(txtdir)
 
227
+       $(MKDIRS) $(DESTDIR)$(txtdir)
 
228
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(txtdir)
 
229
--- src/lib/libr12/Makefile.in.orig     2005-05-06 20:29:27.811825504 +0200
 
230
+++ src/lib/libr12/Makefile.in  2005-05-06 20:34:04.221804800 +0200
 
231
@@ -64,11 +64,11 @@
 
232
 targetclean:
 
233
 
 
234
 install: $(TARGET)
 
235
-       $(MKDIRS) $(libdir)
 
236
-       $(INSTALL_DATA) $< $(libdir)
 
237
-       $(RANLIB) $(libdir)/`basename $(TARGET)`
 
238
-       $(MKDIRS) $(incdir)/libr12
 
239
-       $(INSTALL_INCLUDE) $(TARGET_HEADERS) $(incdir)/libr12
 
240
+       $(MKDIRS) $(DESTDIR)$(libdir)
 
241
+       $(INSTALL_DATA) $< $(DESTDIR)$(libdir)
 
242
+       $(RANLIB) $(DESTDIR)$(libdir)/`basename $(TARGET)`
 
243
+       $(MKDIRS) $(DESTDIR)$(incdir)/libr12
 
244
+       $(INSTALL_INCLUDE) $(TARGET_HEADERS) $(DESTDIR)$(incdir)/libr12
 
245
 
 
246
 #
 
247
 # keep the configuration information and makefiles up-to-date
 
248
--- src/bin/ccenergy/Makefile.in.orig   2005-05-07 01:23:42.257941744 +0200
 
249
+++ src/bin/ccenergy/Makefile.in        2005-05-07 01:23:42.267940224 +0200
 
250
@@ -27,6 +27,6 @@
 
251
 endif
 
252
 
 
253
 install_man:: ccenergy.1
 
254
-       $(MKDIRS) $(mandir)/man1
 
255
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
256
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
257
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
258
 
 
259
--- src/bin/cceom/Makefile.in.orig      2005-05-07 01:23:42.312933384 +0200
 
260
+++ src/bin/cceom/Makefile.in   2005-05-07 01:23:42.321932016 +0200
 
261
@@ -28,6 +28,6 @@
 
262
 endif
 
263
 
 
264
 install_man:: cceom.1
 
265
-       $(MKDIRS) $(mandir)/man1
 
266
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
267
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
268
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
269
 
 
270
--- src/bin/cints/Makefile.in.orig      2005-05-07 01:58:43.903443064 +0200
 
271
+++ src/bin/cints/Makefile.in   2005-05-07 01:59:28.831612944 +0200
 
272
@@ -130,18 +130,18 @@
 
273
 install:: install_html
 
274
 
 
275
 install_man:: cints.1
 
276
-       $(MKDIRS) $(mandir)/man1
 
277
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
278
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
279
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
280
 
 
281
 install_html:: install_index install_htmlsrc
 
282
 
 
283
 install_index:: cints.html
 
284
-       $(MKDIRS) $(htmldir)
 
285
-       $(INSTALL_INCLUDE) $^ $(htmldir)
 
286
+       $(MKDIRS) $(DESTDIR)$(htmldir)
 
287
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(htmldir)
 
288
 
 
289
 HTMLSRC = $(shell echo `ls $(srcdir)/Documentation/*.html`)
 
290
 install_htmlsrc: $(HTMLSRC)
 
291
-       $(MKDIRS) $(htmldir)/CINTS
 
292
-       $(INSTALL_INCLUDE) $(HTMLSRC) $(htmldir)/CINTS
 
293
+       $(MKDIRS) $(DESTDIR)$(htmldir)/CINTS
 
294
+       $(INSTALL_INCLUDE) $(HTMLSRC) $(DESTDIR)$(htmldir)/CINTS
 
295
 
 
296
 
 
297
--- src/bin/clag/Makefile.in.orig       2005-05-07 01:23:42.537899184 +0200
 
298
+++ src/bin/clag/Makefile.in    2005-05-07 01:23:42.546897816 +0200
 
299
@@ -22,5 +22,5 @@
 
300
 endif
 
301
 
 
302
 install_man:: clag.1
 
303
-       $(MKDIRS) $(mandir)/man1
 
304
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
305
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
306
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
307
--- src/bin/cscf/Makefile.in.orig       2005-05-07 01:23:42.624885960 +0200
 
308
+++ src/bin/cscf/Makefile.in    2005-05-07 01:23:42.634884440 +0200
 
309
@@ -26,5 +26,5 @@
 
310
 endif
 
311
 
 
312
 install_man:: cscf.1
 
313
-       $(MKDIRS) $(mandir)/man1
 
314
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
315
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
316
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
317
--- src/bin/dboc/Makefile.in.orig       2005-05-07 01:23:42.679877600 +0200
 
318
+++ src/bin/dboc/Makefile.in    2005-05-07 01:23:42.688876232 +0200
 
319
@@ -22,6 +22,6 @@
 
320
 endif
 
321
 
 
322
 install_man:: dboc.1
 
323
-       $(MKDIRS) $(mandir)/man1
 
324
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
325
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
326
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
327
 
 
328
--- src/bin/detcas/Makefile.in.orig     2005-05-07 01:23:42.707873344 +0200
 
329
+++ src/bin/detcas/Makefile.in  2005-05-07 01:23:42.716871976 +0200
 
330
@@ -24,5 +24,5 @@
 
331
 endif
 
332
 
 
333
 install_man:: detcas.1
 
334
-       $(MKDIRS) $(mandir)/man1
 
335
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
336
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
337
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
338
--- src/bin/detcasman/Makefile.in.orig  2005-05-07 01:23:42.726870456 +0200
 
339
+++ src/bin/detcasman/Makefile.in       2005-05-07 01:23:42.735869088 +0200
 
340
@@ -19,5 +19,5 @@
 
341
 endif
 
342
 
 
343
 install_man:: detcasman.1
 
344
-       $(MKDIRS) $(mandir)/man1
 
345
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
346
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
347
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
348
--- src/bin/detci/Makefile.in.orig      2005-05-07 01:23:42.753866352 +0200
 
349
+++ src/bin/detci/Makefile.in   2005-05-07 01:23:42.763864832 +0200
 
350
@@ -36,5 +36,5 @@
 
351
 endif
 
352
 
 
353
 install_man:: detci.1
 
354
-       $(MKDIRS) $(mandir)/man1
 
355
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
356
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
357
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
358
--- src/bin/extrema/Makefile.in.orig    2005-05-07 01:23:42.778862552 +0200
 
359
+++ src/bin/extrema/Makefile.in 2005-05-07 01:23:42.787861184 +0200
 
360
@@ -13,7 +13,7 @@
 
361
 CXXSRC = extrema.cc small_functions.cc $(DIRS:%=%/*.cc)
 
362
 TRUESRC = $(notdir $(shell echo `ls $(CXXSRC:%=$(srcdir)/%)`))
 
363
 
 
364
-CXXINC += -I$(srcdir) $(DIRS:%=-I$(srcdir)/%) -I$(objincdir) -I$(incdir) -I$(prefix)/include
 
365
+CXXINC += -I$(srcdir) $(DIRS:%=-I$(srcdir)/%) -I$(objincdir) -I$(DESTDIR)$(incdir) -I$(prefix)/include
 
366
 
 
367
 BINOBJ = $(TRUESRC:%.cc=%.o)
 
368
 
 
369
--- src/bin/geom/Makefile.in.orig       2005-05-07 01:23:42.818856472 +0200
 
370
+++ src/bin/geom/Makefile.in    2005-05-07 01:23:42.827855104 +0200
 
371
@@ -17,5 +17,5 @@
 
372
 endif
 
373
 
 
374
 install_man:: geom.1
 
375
-       $(MKDIRS) $(mandir)/man1
 
376
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
377
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
378
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
379
--- src/bin/input/Makefile.in.orig      2005-05-07 01:23:42.842852824 +0200
 
380
+++ src/bin/input/Makefile.in   2005-05-07 01:23:42.851851456 +0200
 
381
@@ -25,6 +25,6 @@
 
382
 endif
 
383
 
 
384
 install_man:: input.1
 
385
-       $(MKDIRS) $(mandir)/man1
 
386
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
387
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
388
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
389
 
 
390
--- src/bin/mocube/Makefile.in.orig     2005-05-07 01:23:42.896844616 +0200
 
391
+++ src/bin/mocube/Makefile.in  2005-05-07 01:23:42.906843096 +0200
 
392
@@ -20,6 +20,6 @@
 
393
 endif
 
394
 
 
395
 install_man:: mocube.1
 
396
-       $(MKDIRS) $(mandir)/man1
 
397
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
398
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
399
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
400
 
 
401
--- src/bin/mp2/Makefile.in.orig        2005-05-07 01:23:42.924840360 +0200
 
402
+++ src/bin/mp2/Makefile.in     2005-05-07 01:23:42.933838992 +0200
 
403
@@ -19,6 +19,6 @@
 
404
 endif
 
405
 
 
406
 install_man:: mp2.1
 
407
-       $(MKDIRS) $(mandir)/man1
 
408
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
409
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
410
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
411
 
 
412
--- src/bin/mp2r12/Makefile.in.orig     2005-05-07 01:23:42.957835344 +0200
 
413
+++ src/bin/mp2r12/Makefile.in  2005-05-07 01:23:42.966833976 +0200
 
414
@@ -19,6 +19,6 @@
 
415
 endif
 
416
 
 
417
 install_man:: mp2r12.1
 
418
-       $(MKDIRS) $(mandir)/man1
 
419
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
420
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
421
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
422
 
 
423
--- src/bin/mvo/Makefile.in.orig        2005-05-07 01:23:42.986830936 +0200
 
424
+++ src/bin/mvo/Makefile.in     2005-05-07 01:23:43.002828504 +0200
 
425
@@ -21,5 +21,5 @@
 
426
 endif
 
427
 
 
428
 install_man:: mvo.1
 
429
-       $(MKDIRS) $(mandir)/man1
 
430
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
431
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
432
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
433
--- src/bin/oeprop/Makefile.in.orig     2005-05-07 01:23:43.015826528 +0200
 
434
+++ src/bin/oeprop/Makefile.in  2005-05-07 01:23:43.024825160 +0200
 
435
@@ -25,6 +25,6 @@
 
436
 endif
 
437
 
 
438
 install_man:: oeprop.1
 
439
-       $(MKDIRS) $(mandir)/man1
 
440
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
441
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
442
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
443
 
 
444
--- src/bin/optking/Makefile.in.orig    2005-05-07 01:23:43.048821512 +0200
 
445
+++ src/bin/optking/Makefile.in 2005-05-07 01:23:43.057820144 +0200
 
446
@@ -30,6 +30,6 @@
 
447
 endif
 
448
 
 
449
 install_man:: optking.1
 
450
-       $(MKDIRS) $(mandir)/man1
 
451
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
452
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
453
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
454
 
 
455
--- src/bin/psi3/Makefile.in.orig       2005-05-07 01:23:43.081816496 +0200
 
456
+++ src/bin/psi3/Makefile.in    2005-05-07 01:23:43.090815128 +0200
 
457
@@ -19,7 +19,7 @@
 
458
 endif
 
459
 
 
460
 install_man:: psi3.1
 
461
-       $(MKDIRS) $(mandir)/man1
 
462
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
463
        cat $(top_srcdir)/lib/macro.psi $< | sed "s OS_NAME_HERE UNIX " > \
 
464
-            $(mandir)/man1/psi3.1
 
465
+            $(DESTDIR)$(mandir)/man1/psi3.1
 
466
 
 
467
--- src/bin/psiclean/Makefile.in.orig   2005-05-07 01:23:43.125809808 +0200
 
468
+++ src/bin/psiclean/Makefile.in        2005-05-07 01:23:43.129809200 +0200
 
469
@@ -17,6 +17,6 @@
 
470
 endif
 
471
 
 
472
 install_man:: psiclean.1
 
473
-       $(MKDIRS) $(mandir)/man1
 
474
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
475
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
476
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
477
 
 
478
--- src/bin/stable/Makefile.in.orig     2005-05-07 01:23:43.176802056 +0200
 
479
+++ src/bin/stable/Makefile.in  2005-05-07 01:23:43.180801448 +0200
 
480
@@ -23,5 +23,5 @@
 
481
 endif
 
482
 
 
483
 install_man:: stable.1
 
484
-       $(MKDIRS) $(mandir)/man1
 
485
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
486
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
487
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
488
--- src/bin/transqt/Makefile.in.orig    2005-05-07 01:23:43.200798408 +0200
 
489
+++ src/bin/transqt/Makefile.in 2005-05-07 01:23:43.204797800 +0200
 
490
@@ -33,6 +33,6 @@
 
491
 endif
 
492
 
 
493
 install_man:: transqt.1
 
494
-       $(MKDIRS) $(mandir)/man1
 
495
-       $(INSTALL_INCLUDE) $^ $(mandir)/man1
 
496
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
497
+       $(INSTALL_INCLUDE) $^ $(DESTDIR)$(mandir)/man1
 
498
 
 
499
--- src/util/tocprint/Makefile.in.orig  2005-05-07 01:24:50.424578840 +0200
 
500
+++ src/util/tocprint/Makefile.in       2005-05-07 01:25:17.884404312 +0200
 
501
@@ -17,5 +17,5 @@
 
502
 endif
 
503
 
 
504
 install_man:: tocprint.1
 
505
-       $(MKDIRS) $(mandir)/man1
 
506
-       $(INSTALL_PROGRAM) $(srcdir)/tocprint.1 $(mandir)/man1
 
507
+       $(MKDIRS) $(DESTDIR)$(mandir)/man1
 
508
+       $(INSTALL_PROGRAM) $(srcdir)/tocprint.1 $(DESTDIR)$(mandir)/man1