~ubuntu-branches/ubuntu/natty/pygtk/natty-proposed

« back to all changes in this revision

Viewing changes to debian/patches/02_fix_get_application_info_crash.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sebastien Bacher
  • Date: 2009-06-22 16:49:42 UTC
  • mfrom: (1.2.6 upstream)
  • Revision ID: james.westby@ubuntu.com-20090622164942-19zeltp4z0u5iw72
Tags: 2.15.2-0ubuntu1
* New upstream version:
  - Rename gtk.Statusbar.remove() to gtk.Statusbar.remove_message
  - Allow pango.Context creation 
  - Make gtk.gdk.Pixbuf.add_alpha accept integers, retaining backward
    compatibility accepting also chars 
  - Protect window obj from GC in gtk.window_get_toplevels 
  - Plug huge number of memory leaks in Pango wrappers 
  - Add gtk.gdk.WINDOWING constant 
  - Wrap gdk_pixbuf_apply_embedded_orientation 
  - Modernize constructors of seven more types 
  - Don't free a string we don't own 
  - Some docs tweaking 
* debian/control.in:
  - set vcs location
* debian/patches/02_fix_get_application_info_crash.patch:
  - the change is in the new version

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
# Description: Fix crash in gtk.RecentInfo.get_application_info() by not freeing an unowned string gtk/gtk.override 
2
 
# Ubuntu: LP: #386035
3
 
# Upstream: GNOME #585458, git 956592c614c567623510dccf5fc1edaee9c766c1
4
 
--- pygtk-2.15.1.orig/gtk/gtk.override
5
 
+++ pygtk-2.15.1/gtk/gtk.override
6
 
@@ -7549,7 +7549,8 @@
7
 
                                                &time_);
8
 
     if (ret) {
9
 
         py_ret = Py_BuildValue("(sii)", app_exec, count, time_);
10
 
-        g_free(app_exec);
11
 
+       /* Note that we mustn't free 'app_exec' even though it's not
12
 
+        * 'const'. See bug #585458. */
13
 
     } else {
14
 
         py_ret = Py_None;
15
 
     }