~ubuntu-branches/ubuntu/natty/python-distutils-extra/natty

« back to all changes in this revision

Viewing changes to debian/patches/debian-changes-2.22-2

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2010-09-23 16:00:58 UTC
  • mfrom: (18.2.1 experimental)
  • Revision ID: james.westby@ubuntu.com-20100923160058-ag84trzcbib2za53
Tags: 2.22-2
* Upload to unstable, now that the current python3 is in unstable.
* Add debian/watch.
* Add bzr-builddeb configuration (merge mode).
* debian/copyright: Add missing Canonical copyright (Closes: #597548).
  While we are at it, also convert the file to DEP-5, and fix the
  common-licenses link to point to the versioned GPL.
* DistUtilsExtra/command/check.py: Remove explicit GPL-3 license header, so
  that the file falls under the package's general GPL-2+ license. Rodney
  Dawes, the author, gave his explicit permission for this in #597548 (in
  fact, GPL-3 was unintended in the first place).
* test/auto.py: Ignore python warning about import from local path.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Upstream changes introduced in version 2.22-2
 
2
 This patch has been created by dpkg-source during the package build.
 
3
 Here's the last changelog entry, hopefully it gives details on why
 
4
 those changes were made:
 
5
 .
 
6
 python-distutils-extra (2.22-2) unstable; urgency=low
 
7
 .
 
8
   * Upload to unstable, now that the current python3 is in unstable.
 
9
   * Add debian/watch.
 
10
   * Add bzr-builddeb configuration (merge mode).
 
11
   * debian/copyright: Add missing Canonical copyright (Closes: #597548).
 
12
     While we are at it, also convert the file to DEP-5, and fix the
 
13
     common-licenses link to point to the versioned GPL.
 
14
   * DistUtilsExtra/command/check.py: Remove explicit GPL-3 license header, so
 
15
     that the file falls under the package's general GPL-2+ license. Rodney
 
16
     Dawes, the author, gave his explicit permission for this in #597548 (in
 
17
     fact, GPL-3 was unintended in the first place).
 
18
   * test/auto.py: Ignore python warning about import from local path.
 
19
 .
 
20
 The person named in the Author field signed this changelog entry.
 
21
Author: Martin Pitt <mpitt@debian.org>
 
22
Bug-Debian: http://bugs.debian.org/597548
 
23
 
 
24
---
 
25
The information above should follow the Patch Tagging Guidelines, please
 
26
checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
 
27
are templates for supplementary fields that you might want to add:
 
28
 
 
29
Origin: <vendor|upstream|other>, <url of original patch>
 
30
Bug: <url in upstream bugtracker>
 
31
Bug-Debian: http://bugs.debian.org/<bugnumber>
 
32
Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
 
33
Forwarded: <no|not-needed|url proving that it has been forwarded>
 
34
Reviewed-By: <name and email of someone who approved the patch>
 
35
Last-Update: <YYYY-MM-DD>
 
36
 
 
37
--- python-distutils-extra-2.22.orig/DistUtilsExtra/command/check.py
 
38
+++ python-distutils-extra-2.22/DistUtilsExtra/command/check.py
 
39
@@ -1,20 +1,7 @@
 
40
 # DistUtilsExtra.command.check - check command for DistUtilsExtra
 
41
 #
 
42
 # Author: Rodney Dawes <rodney.dawes@canonical.com>
 
43
-#
 
44
 # Copyright 2009 Canonical Ltd.
 
45
-#
 
46
-# This program is free software: you can redistribute it and/or modify it 
 
47
-# under the terms of the GNU General Public License version 3, as published 
 
48
-# by the Free Software Foundation.
 
49
-#
 
50
-# This program is distributed in the hope that it will be useful, but 
 
51
-# WITHOUT ANY WARRANTY; without even the implied warranties of 
 
52
-# MERCHANTABILITY, SATISFACTORY QUALITY, or FITNESS FOR A PARTICULAR 
 
53
-# PURPOSE.  See the GNU General Public License for more details.
 
54
-#
 
55
-# You should have received a copy of the GNU General Public License along 
 
56
-# with this program.  If not, see <http://www.gnu.org/licenses/>.
 
57
 
 
58
 """DistUtilsExtra.command.check
 
59
 
 
60
--- python-distutils-extra-2.22.orig/test/auto.py
 
61
+++ python-distutils-extra-2.22/test/auto.py
 
62
@@ -9,6 +9,10 @@ class T(unittest.TestCase):
 
63
         self.src = tempfile.mkdtemp()
 
64
 
 
65
         self._mksrc('setup.py', '''
 
66
+# ignore warning about import from local path
 
67
+import warnings
 
68
+warnings.filterwarnings('ignore', 'Module DistUtilsExtra was already imported from.*')
 
69
+
 
70
 from DistUtilsExtra.auto import setup
 
71
 
 
72
 setup(