~ubuntu-branches/ubuntu/natty/pywebkitgtk/natty

« back to all changes in this revision

Viewing changes to debian/patches/01_fix_codegen_error.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Emilio Pozuelo Monfort, Emilio Pozuelo Monfort, Christophe Sauthier
  • Date: 2009-11-14 11:20:42 UTC
  • mfrom: (2.1.4 sid)
  • Revision ID: james.westby@ubuntu.com-20091114112042-ka7x5nylakhcc3gf
Tags: 1.1.7-1
[ Emilio Pozuelo Monfort ]
* debian/watch: Fixed.

[ Christophe Sauthier ]
* New upstream version
* debian/control.in
  - Add libglib2.0-dev as a build dependency to reflect confgure check.
* debian/patches/01_fix_codegen_error.dpatch removed since it has been
  integrated upstream.
* debian/patches/03_autoreconf.dpatch updated.
* debian/python-webkit.examples change tabbed_browser.py by browser.py

[ Emilio Pozuelo Monfort ]
* debian/control.in:
  - Use spaces consistently.
  - Build depend on libwebkit-dev >= 1.1.10 for the new version.
  - Standards-Version is 3.8.3, no changes needed.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 01_fix_codegen_error.dpatch by Christophe Sauthier <christophe.sauthier@objectif-libre.com>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Avoid to change to the srcdir directory, and stay in the build one, which## DP: is needed due to the multiple python build .
6
 
 
7
 
@DPATCH@
8
 
diff -urNad pywebkitgtk-1.1.4~/Makefile.am pywebkitgtk-1.1.4/Makefile.am
9
 
--- pywebkitgtk-1.1.4~/Makefile.am      2009-05-31 00:50:04.000000000 +0200
10
 
+++ pywebkitgtk-1.1.4/Makefile.am       2009-05-31 12:40:02.000000000 +0200
11
 
@@ -52,8 +54,7 @@
12
 
 # disable for now since line is not really critical.
13
 
 #      && ! grep -q -v "^\*\*\*INFO\*\*\*" $(*D)/$(*F).errors
14
 
 %.defs.c:
15
 
-       (cd $(srcdir) \
16
 
-        && $(PYGOBJECT_CODEGEN) \
17
 
+       ($(PYGOBJECT_CODEGEN) \
18
 
             --register $(PYGTK_DEFSDIR)/gdk-types.defs \
19
 
             --register $(PYGTK_DEFSDIR)/gtk-types.defs \
20
 
            --override $(*D)/$(*F).override \