~ubuntu-branches/ubuntu/natty/sarg/natty

« back to all changes in this revision

Viewing changes to debian/patches/totger_buffers.patch

  • Committer: Bazaar Package Importer
  • Author(s): Luigi Gangitano
  • Date: 2009-01-10 18:14:18 UTC
  • mfrom: (3.1.3 lenny)
  • Revision ID: james.westby@ubuntu.com-20090110181418-tffq642drpfiyi6e
Tags: 2.2.5-2
* debian/watch
  - Use SF redirector and make lintian happy

* debian/{rules,compat}
  - Move DH_COMPAT to debian/compat and make lintian happy

* debian/rules
  - Change make clean invocation and make lintian happier
  - Added support for DEB_BUILD_OPTIONS
  - Move documentation files from sarg-php to doc directory
  - Remove hidden file from /etc/squid/languages

* debian/control
  - Removed dependency on bash, now essential
  - Bumped Standard-Version to 3.8.0

* debian/postinst
  - Make postint fail on error

* debian/copyright
  - Added copyright notice
  - Updated maintainer reference

* debian/sarg-reports.1
  - Added man page, thanks to Juan Angulo Moreno (Closes: #481889)

* debian/patches/show_read_statistics.patch
  - Added patch from Vladimir Lettiev fixing segfault with
    show_read_statistics set to no. (Closes: #444845, # 370811)

* debian/patches/totger_patches.patch
  - Added patch from Thomas Bliesener fixing several buffer overflows
    (Closes: #470791)

* debian/patches/opensuse_1_getword_boundary_limit.patch
  - Added patch from OpenSUSE to avoid segfaults in getword() calls

* debian/patches/opensuse_2_enlarge_report_buffers.patch
  - Added patch from OpenSUSE to avoid overflow in report buffers

* debian/patches/opensuse_3_too_small_font_buffer.patch
  - Added patch from OpenSUSE to avoid overflow in font buffer

* debian/patches/opensuse_4_enlarge_log_buffer.patch
  - Added patch from OpenSUSE to avoid overflow in log buffer

* debian/patches/opensuse_5_limit_sprintf.patch
  - Added patch from OpenSUSE to avoid segfaults in sprintf() calls

* debian/patches/opensuse_6_limit_useragent_sprintf.patch
  - Added patch from OpenSUSE to avoid segfaults in sprintf() calls

* debian/patches/opensuse_7_year_assertion.patch
  - Added patch from OpenSUSE to avoid assertion in year parsing

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- sarg-2.2.5/totger.c 2008-03-13 11:53:47.000000000 -0600
 
2
+++ sarg-2.2.5/totger.c_new     2008-03-13 11:52:25.000000000 -0600
 
3
@@ -35,9 +35,9 @@
 
4
    long long int tnbytes=0;
 
5
    long long int telap=0;
 
6
    long long int tincache=0, toucache=0;
 
7
-   char wger[MAXLEN], user[MAXLEN], nacc[10], nbytes[10], url[1024];
 
8
-   char ip[MAXLEN], hora[9], data[11], elap[15];
 
9
-   char incac[15], oucac[15];
 
10
+   char wger[MAXLEN], user[MAXLEN], nacc[16], nbytes[16], url[1024];
 
11
+   char ip[MAXLEN], hora[9], data[11], elap[16];
 
12
+   char incac[16], oucac[16];
 
13
 
 
14
    strcpy(wger,dirname);
 
15
    strcat(wger,"/sarg-general");
 
16