~ubuntu-branches/ubuntu/natty/unity-2d/natty-updates

« back to all changes in this revision

Viewing changes to debian/patches/debian-changes-0.1-0ubuntu4

  • Committer: Bazaar Package Importer
  • Author(s): Oliver Grawert
  • Date: 2011-01-21 13:11:45 UTC
  • Revision ID: james.westby@ubuntu.com-20110121131145-tn95f1z7mxi4n1bx
Tags: 0.1-0ubuntu4
* add Vcs-Bzr location to debian/control
* update branch location in debian/copyright
* pull in some upstream fixes

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Upstream changes introduced in version 0.1-0ubuntu4
 
2
 This patch has been created by dpkg-source during the package build.
 
3
 Here's the last changelog entry, hopefully it gives details on why
 
4
 those changes were made:
 
5
 .
 
6
 unity-2d (0.1-0ubuntu4) natty; urgency=low
 
7
 .
 
8
   * add Vcs-Bzr location to debian/control
 
9
   * update branch location in debian/copyright
 
10
   * pull in some upstream fixes
 
11
 .
 
12
 The person named in the Author field signed this changelog entry.
 
13
Author: Oliver Grawert <ogra@ubuntu.com>
 
14
 
 
15
---
 
16
The information above should follow the Patch Tagging Guidelines, please
 
17
checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
 
18
are templates for supplementary fields that you might want to add:
 
19
 
 
20
Origin: <vendor|upstream|other>, <url of original patch>
 
21
Bug: <url in upstream bugtracker>
 
22
Bug-Debian: http://bugs.debian.org/<bugnumber>
 
23
Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
 
24
Forwarded: <no|not-needed|url proving that it has been forwarded>
 
25
Reviewed-By: <name and email of someone who approved the patch>
 
26
Last-Update: <YYYY-MM-DD>
 
27
 
 
28
--- /dev/null
 
29
+++ unity-2d-0.1/spread/spread.qmlproject
 
30
@@ -0,0 +1,18 @@
 
31
+/* File generated by QtCreator */
 
32
+
 
33
+import QmlProject 1.0
 
34
+
 
35
+Project {
 
36
+    /* Include .qml, .js, and image files from current directory and subdirectories */
 
37
+    QmlFiles {
 
38
+        directory: "."
 
39
+    }
 
40
+    JavaScriptFiles {
 
41
+        directory: "."
 
42
+    }
 
43
+    ImageFiles {
 
44
+        directory: "."
 
45
+    }
 
46
+    /* List of plugin directories passed to QML runtime */
 
47
+    // importPaths: [ "../exampleplugin" ]
 
48
+}
 
49
--- unity-2d-0.1.orig/places/dash.qml
 
50
+++ unity-2d-0.1/places/dash.qml
 
51
@@ -37,12 +37,18 @@ Item {
 
52
         */
 
53
         placeEntryModel.active = true
 
54
         placeEntryModel.activeSection = section
 
55
-        placeEntryView.model = placeEntryModel
 
56
-        activatePage(placeEntryView)
 
57
+        pageLoader.source = "PlaceEntryView.qml"
 
58
+        /* Take advantage of the fact that the loaded qml is local and setting
 
59
+           the source loads it immediately making pageLoader.item valid */
 
60
+        pageLoader.item.model = placeEntryModel
 
61
+        activatePage(pageLoader.item)
 
62
     }
 
63
 
 
64
     function activateHome() {
 
65
-        activatePage(home)
 
66
+        pageLoader.source = "Home.qml"
 
67
+        /* Take advantage of the fact that the loaded qml is local and setting
 
68
+           the source loads it immediately making pageLoader.item valid */
 
69
+        activatePage(pageLoader.item)
 
70
     }
 
71
 
 
72
     property variant places: LauncherPlacesList {
 
73
@@ -77,8 +83,8 @@ Item {
 
74
             height: 47
 
75
         }
 
76
 
 
77
-        Item {
 
78
-            id: pages
 
79
+        Loader {
 
80
+            id: pageLoader
 
81
 
 
82
             anchors.top: search_bar.bottom
 
83
             anchors.topMargin: 12
 
84
@@ -88,18 +94,6 @@ Item {
 
85
             anchors.leftMargin: 7
 
86
             anchors.right: parent.right
 
87
             anchors.rightMargin: 8
 
88
-
 
89
-            Home {
 
90
-                id: home
 
91
-                anchors.fill: parent
 
92
-                visible: false
 
93
-            }
 
94
-
 
95
-            PlaceEntryView {
 
96
-                id: placeEntryView
 
97
-                anchors.fill: parent
 
98
-                visible: false
 
99
-            }
 
100
         }
 
101
     }
 
102
 }
 
103
--- unity-2d-0.1.orig/places/RendererGrid.qml
 
104
+++ unity-2d-0.1/places/RendererGrid.qml
 
105
@@ -12,7 +12,15 @@ Renderer {
 
106
     id: renderer
 
107
 
 
108
     property variant cellRenderer
 
109
-    property bool folded: true
 
110
+    property bool folded
 
111
+    folded: {
 
112
+        /* Look for the groupId as a complete word inside the list of expanded groups.
 
113
+           Examples of ExpandedGroups hint: "2", "1 3 7", "1 2", etc.
 
114
+         */
 
115
+        var re = RegExp("\\b%1\\b".arg(renderer.groupId))
 
116
+        var expandedGroups = placeEntryModel.entryRendererHints["ExpandedGroups"]
 
117
+        return !re.test(expandedGroups)
 
118
+    }
 
119
 
 
120
     property int cellWidth: 158
 
121
     property int cellHeight: 76
 
122
--- unity-2d-0.1.orig/places/Renderer.qml
 
123
+++ unity-2d-0.1/places/Renderer.qml
 
124
@@ -11,6 +11,7 @@ import Qt 4.7
 
125
 Item {
 
126
     property string displayName /* Name of the group typically displayed in the header */
 
127
     property string iconHint /* Icon id of the group */
 
128
+    property int groupId /* Index of the group */
 
129
     property variant model /* List model containing the items to be displayed by the renderer */
 
130
     property variant placeEntryModel /* Reference to the place entry the group belongs to */
 
131
     property variant parentListView /* Reference to the ListView the renderer is nested into */
 
132
--- unity-2d-0.1.orig/places/PlaceEntryView.qml
 
133
+++ unity-2d-0.1/places/PlaceEntryView.qml
 
134
@@ -55,6 +55,7 @@ Item {
 
135
                 item.parentListView = results.list
 
136
                 item.displayName = displayName
 
137
                 item.iconHint = iconHint
 
138
+                item.groupId = groupId
 
139
                 item.model = group_model
 
140
                 item.placeEntryModel = placeEntryView.model
 
141
             }
 
142
--- unity-2d-0.1.orig/launcher/UnityApplications/launcherapplication.cpp
 
143
+++ unity-2d-0.1/launcher/UnityApplications/launcherapplication.cpp
 
144
@@ -285,7 +285,9 @@ LauncherApplication::setIconGeometry(int
 
145
 void
 
146
 LauncherApplication::onWindowAdded(BamfWindow* window)
 
147
 {
 
148
-    windowAdded(window->xid());
 
149
+    if (window != NULL) {
 
150
+        windowAdded(window->xid());
 
151
+    }
 
152
 }
 
153
 
 
154
 int